NorthStar Application UI Overview

 

NorthStar has two user interfaces (UIs):

  • NorthStar Controller UI (web)—for working with a live network

  • NorthStar Planner UI (Java client)—for simulating the effect of various scenarios on the network, without affecting the live network

UI Comparison

Table 1 summarizes the major use cases for the Controller and Planner.

Note

All user administration (adding, modifying, and deleting users) must be done from the web UI.

Table 1: Controller Versus Planner Comparison

NorthStar Controller (web client)

NorthStar Planner (Java client)

Manage, monitor, and provision a live network in real-time.

Design, simulate, and analyze a network offline.

Live network topology map shows node status, link utilization, and LSP paths.

Network topology map shows simulated or imported data for nodes, links, and LSP paths.

Network information table shows live status of nodes, links, and LSPs.

Network information table shows simulated or imported data for nodes, links, and LSPs.

Discover nodes, links, and LSPs from the live network using PCEP or NETCONF.

Import or add nodes, links, and LSPs for network modeling.

Provision LSPs directly to the network.

Add and stage LSPs for provisioning to the network.

Create or schedule maintenance events to re-route LSPs around the impacted nodes and links.

Create or schedule simulation events to analyze the network model from failure scenarios.

Dashboard reports shows current status and KPIs of the live network.

Report manager provides extensive reports for simulation and planning.

Analytics collects real-time interface traffic or delay statistics and stores the data for querying and chart displays.

Import interface data or aggregate archived data to generate historical statistics for querying and chart displays.

The NorthStar Login Window

You connect to NorthStar using a modern web browser such as Microsoft Edge, Google Chrome, or Mozilla Firefox.

Your external IP address is provided to you when you install the NorthStar application. In the address bar of your browser window, type that secure host external IP address, followed by a colon and port number 8443 (for example, https://10.0.1.29:8443). The NorthStar login window is displayed, as shown in Figure 1. This same login window grants access to the NorthStar Controller UI and the NorthStar Planner UI.

Note

If you attempt to reach the login window, but instead, are routed to a message window that says, “Please enter your confirmation code to complete setup,” you must go to your license file and obtain the confirmation code as directed. Enter the confirmation code along with your administrator password to be routed to the web UI login window. The requirement to enter the confirmation code only occurs when the installation process was not completed correctly and the NorthStar application needs to confirm that you have the authorization to continue.

Figure 1: NorthStar Login Window
NorthStar Login Window
Warning

To avoid a Browser Exploit Against SSL/TLS (BEAST) attack, whenever you log in to NorthStar through a browser tab or window, make sure that the tab or window was not previously used to surf a non-HTTPS website. A best practice is to close your browser and relaunch it before logging in to NorthStar.

NorthStar Controller features are available through the web UI. NorthStar Planner features are available through the Java Client UI.

A configurable User Inactivity Timer is available to the System Administrator (only). If set, any user who is idle and has not performed any actions (keystrokes or mouse clicks) is automatically logged out of NorthStar after the specified number of minutes. By default, the timer is disabled. To set the timer, navigate to Administration > System Settings in the NorthStar Controller web UI.

Logging In to and Out of the NorthStar Controller Web UI

Table 2 shows the Internet browsers that have been tested and confirmed compatible with the NorthStar Controller web UI.

Table 2: Internet Browsers Compatible with the NorthStar Controller Web UI

OS

Browser

Windows 10

  • Google Chrome versions 55, 56

  • Mozilla Firefox version 53

  • Microsoft Edge version 38.14393

Windows 7

  • Google Chrome versions 58

  • Mozilla Firefox version 53

CentOS 6.8/6.9

  • Google Chrome versions 56

  • Mozilla Firefox version 53

Mac OS

  • Google Chrome versions 58

  • Apple Safari version 10.1.1

To access the NorthStar Controller web UI, enter the username and password provided to you when you installed the NorthStar application. Optionally click the Enable Full Access check box. Click Launch on the Controller side of the login window.

Note

You will be required to change your password after logging in for the first time.

To log out of the web UI, click the User Options drop-down menu (person icon) in the upper right corner of the main window and select Log Out. Figure 2 shows the User Options drop-down menu. If you close the browser without logging out, you are automatically logged out after 10 seconds.

Figure 2: User Options Menu
User Options Menu

Logging In to and Out of the NorthStar Planner Java Client UI

To access the NorthStar Planner, enter your credentials on the initial login window and click Launch on the Planner side of the login window. The default memory allocation for NorthStar Planner is displayed, which you can modify. Click Launch in the memory allocation window.

Depending on the browser you are using, a dialog box might be displayed, asking if you want to open or save the .jnlp file, accept downloading of the application, and agree to run the application. Once you respond to all browser requests, a dialog box is displayed in which you enter your user ID and password. Click Login.

You can also launch the NorthStar Planner from within the NorthStar Controller by navigating to NorthStar Planner from the More Options menu as shown in Figure 3:

Figure 3: More Options Menu
More Options Menu

To log out of the NorthStar Planner, select File > Exit to display the Confirm Exit screen. Click Yes to exit.