NorthStar Planner UI Overview

 

Use the NorthStar Planner to simulate the effect on the network of various scenarios without affecting the live network.

Note

NETWORK ARCHIVE COLLECTION REQUIRED

NorthStar Planner obtains its network information from the network archive collection tasks you run in the NorthStar Operator. By default, there are no automatic snapshots of the live network available. See Collection Tasks to Create Network Archives for more information and instructions.

This topic describes some of the elements displayed from the NorthStar Planner main window from which all other windows are launched or opened.

NorthStar Planner UI

After you log in to the NorthStar Planner, the main window shows the Map, Console, and Network Info panes, as shown in Figure 1. However, many standard functions and features do not become available until a network topology is loaded. This includes some of the menus as well as the topology view from the Map.

Figure 1: NorthStar Planner Main Window
NorthStar Planner Main Window
Note

To refresh the network view, click Update at the top left corner of the window under the toolbar.

Menu Options for the NorthStar Planner UI

Table 1 describes the options available from the main window.

Table 1: Menu Options for the NorthStar Planner UI

Menu OptionDescription

Application

The Application menu shows a calendar view of maintenance events and provides path optimization information.

File

The File menu contains network file functions such as opening the File Manager, loading network files, and exiting the UI.

Help

The Help menu provides basic system information, including NorthStar product version, server version and IP address, operating system information, and Java virtual machine (JVM) details.

Network

The Network menu includes network summary information (network elements, LSP placement, LSP types, hop counts, and LSP bandwidth).

Tools

The Tools menu includes general options to monitor network progress, show login/logout activities, configure the interval between keep-alive messages, and specify network map preferences.

An Admin user can also connect to the NorthStar server and perform NorthStar user administration tasks.

Windows

The Windows menu provides options to display, hide, or reset the Map, Console, and Network Info windows of the NorthStar UI.

RSVP Live Util Legend

Use the drop-down menu in the left pane to configure the map view. By default, the RSVP Live Util legend is displayed. The RSVP (Live) Util view allows you to configure the link color based on utilization. The scale of colors can be configured in this section. Both the colors and the range of utilization can be changed and added. A right click on the scale provides access to the menu for configuring the scale (Edit Color, Add Divider, and so on).

Links are not always displayed as a single solid color. Some are displayed as half one color and half another color. The presence of two different colors indicates that the utilization in one direction (A->Z) is different from the utilization in the other direction (Z->A). The half of the link originating from a certain node is colored according to the link utilization in the direction from that node to the other node.

On the color bar, drag the separator between two colors up and down to move the separator and release it at the desired position. The number to the right of the separator indicates the utilization percentage corresponding to the selected position. For example, if you move the separator between the dark-blue segment and light-blue segment of the bar up to 40.0%, some formerly light-blue links might change to dark blue.

Customizing Nodes and Links in the Map Legends

From the RSVP Util drop-down menu, you can use the following four submenus (Filters, Network Elements, Utilization Legends, and Subviews).

  • Select Subviews > Types. Select the drop-down menu a second time and notice that the Subviews submenu is now shown with the selected option button on its left, and the items underneath it are provided as a shortcut to other menu items in the same category. To view other information such as the vendor and media information, click the relevant item in the list.

  • Note that each legend has its own color settings. Some legends, such as “RSVP Util”, change link colors, but leave the node colors the same as for the previous legend. Other legends change the node colors, but not the link colors. Others, such as “Types”, change both.

  • Colors can be changed by clicking the button next to the type of element you want to change.

  • In addition to colors, node icons and line styles (for example, solid vs. dotted) can be changed by right-clicking one of the buttons for nodes or links. For node icons, the menu is Set This Icon, and for link styles it is Set Line Style. The setting applies when the particular legend in which you set the line style is open.

  • Right-click a node or link icon in the left pane. Notice that the menu item Highlight These Items can be used to highlight all nodes (or links) of a particular type.