Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Interactive Map Features

 

The topology map is interactive, meaning that you can use features within the map itself to customize the map and network information panes. The map uses a geographic coordinate reference system. Some features enabled by that system include:

  • Constrained zooming: NorthStar Controller performs coordinate checking so the view is constrained to the coordinates of the earth.

  • World wrapping/map wrapping: Scrolling the map in one direction is like spinning a globe. This enables representation of links across the pacific, for example.

    Note

    NorthStar Controller draws links as continuous straight lines between two points. This means links will not display screen wrapping behavior because this requires a third point of reference to determine the intended depiction. But you can adjust your field of view so the intended link display is shown on the topology.

The following sections describe additional map features and functionality:

Right-Click Functions

Right-click a node, selected nodes, or node group on the topology map to execute node-specific filtering as shown in Figure 1 and described in Table 1.

Figure 1: Right-Click Options for Nodes or Groups
Right-Click Options for Nodes
or Groups

Table 1: Right-Click Options for Nodes or Groups

Option

Function

Filter in Node Table

Filters the nodes displayed in the network information pane to display only the selected node(s) or node group(s).

Node SIDs from selected node

Labels the nodes in the topology with the node SIDs from the perspective of the node on which you right-clicked.

Show Config

Opens the Configuration Viewer, displaying the configuration of the node on which you right-clicked. See Configuration Viewer for prerequisites for the configuration to be available.

Show Neighbors

Opens a new window displaying the neighbors of the node on which you right-clicked.

Tunnels On or Thru Node

Filters the tunnels displayed in the network information pane to include only those that meet the On or Thru Node criteria.

Tunnels Starting at Node

Filters the tunnels displayed in the network information pane to include only those that meet the Starting at Node criteria.

Tunnels Ending at Node

Filters the tunnels displayed in the network information pane to include only those that meet the Ending at Node criteria.

Group selected nodes

Prompts you to give the group of nodes a name, after which the group can be expanded or collapsed on the topology map. This is a shortcut to the Layout > Group selected nodes function.

Ungroup selected nodes

Ungroups the nodes in the selected group. This is a shortcut to the Layout > Ungroup selected nodes function.

Ungroup All

Ungroups the nodes in all groups. This is a shortcut to the Layout > Ungroup All function.

Circle selected nodes

Arranges the selected nodes in a roughly circular pattern with the nodes and links separated as much as possible. This is a shortcut to the Layout > Circle selected nodes function.

Distribute selected nodes

Forces the selected elements away from each other and minimizes overlap. This is a shortcut to the Layout > Distribute selected nodes function.

Straighten selected nodes

Aligns the selected nodes in a linear pattern. This is a shortcut to the Layout > Straighten selected nodes function.

Right-click a link on the topology map to execute link-specific filtering as shown in Figure 2 and described in Table 2.

Option

Function

Filter in Link Table

Filters the tunnels displayed in the network information pane to display only the selected link.

Tunnels On or Thru Link

Filters the tunnels displayed in the network information pane to include only those that meet the On or Thru Link criteria.

View Link Events

Opens a new window in which you select the time range for the events you wish to view. Click Submit to open the Events window.

View Interface Traffic

Opens a new tab in the network information table at the bottom of the window, displaying the interface traffic.

View Interface Delay

Opens a new tab in the network information table at the bottom of the window, displaying interface delay over time.

View Packet Loss

Opens a new tab in the network information table at the bottom of the window, displaying packet loss statistics.

Note

To clear the tunnel filter so that all tunnels are again displayed, click a different tab (Node, for example), and then click the Tunnel tab again.

Right-click blank space in the topology map pane to access the whole-map functions shown in Figure 3 and described in Table 3.

Figure 3: Right-Click Options for the Topology Map as a Whole
Right-Click Options for the
Topology Map as a Whole

Table 3: Right-Click Options for the Topology Map as a Whole

Option

Function

Distribute All Nodes

Distributes all the nodes in the map, pushing elements away from each other and minimizing overlap. This is a shortcut to selecting all nodes and navigating to Layout>Distribute selected nodes.

Save Default Map Layout

Saves the current layout as your default. The default layout is displayed when you first log in to NorthStar Controller. If you already have a default layout, this function overrides the existing default. You can also designate a default layout by navigating to Layout>Manage Layouts.

Select All Nodes

Selects all nodes on the topology map. This is a shortcut to using shift-left-click to create a selection box around all nodes or individually shift-clicking on all nodes.

Refresh Utilization

Refreshes the display of link colors based on RSVP utilization.

Note: Updates are periodically pushed to the client by the server.

Reload Network

Reloads the network to update the display.

Topology Menu Bar

On the right side of the topology window is a menu bar offering various topology settings, as shown in Figure 4.

Figure 4: Topology Settings Menu Bar
Topology Settings Menu Bar

From the menu bar, you can:

  • Center the topology in the window (target icon).

  • Enlarge the topology in the window (plus symbol).

  • Reduce the size of the topology in the window (minus symbol).

  • Access the topology settings window (tools icon).

Topology Settings Window

Access the Topology Settings window by clicking on the tools icon in the upper right corner of the topology window. Figure 5 shows the tools icon.

Figure 5: Tools Icon to Access Topology Settings
Tools Icon to Access
Topology Settings

The Topology Settings window contains many topology display settings, all in one place. Figure 6 shows the Topology Settings window with the five tabs that group related settings.

On the Options tab, you can select as many settings as you like by clicking the associated check boxes.

Figure 6: Topology Settings Window, Options Tab
Topology Settings Window,
Options Tab

A couple of these settings might not be self-explanatory:

  • Hide Partially Visible Links

    When selected, this option removes from the display any links for which both end nodes are not within the field of view. This is useful for focusing on a subset of a large network.

  • Center on Selected Node from Table

    With this option enabled, when you click on a node entry in the network information table (Node tab), the topology automatically centers the view on that selected node.

The Node Label tab offers options for labeling the nodes on the topology, as shown in Figure 7.

Figure 7: Topology Settings Window, Node Label Tab
Topology Settings
Window, Node Label Tab

Only one node labeling option at a time can be in effect. Click the radio button beside your selection to choose it. Be sure you have also selected Show Node Labels in the Options tab.

The Link Label tab offers options for labeling the links in the topology, as shown in Figure 8.

Only one link labeling option at a time can be in effect. Click the radio button beside your selection to choose it. Be sure you have also selected Show Link Labels in the Options tab.

In the Font tab, you can select the size of the text used for labels in the topology, as shown in Figure 9.

Figure 9: Topology Settings Window, Font Tab
Topology Settings
Window, Font Tab

In the Map tab, shown in Figure 10, you can opt to have the world map displayed, with or without graticules (a grid of lines parallel to meridians of longitude and parallels of latitude) and labeling of major populated places. You can also choose a light or dark map background.

Note

Even if you deselect Show World Map, the topology still behaves according to geographical coordinates in terms of displaying the topology within the field of view.

Figure 10: Topology Settings Window, Map Tab
Topology Settings
Window, Map Tab

Figure 11 shows an example of the light and dark map styles.

Figure 11: Light and Dark Map Styles
Light and Dark Map Styles