Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

 

Topology Map Layout Pop-Up Menu

 

Right-click in the topology map window and select Layout to display options for arranging network elements in the topology map. The menu options are shown in Figure 1 and described in Table 1.

Figure 1: Topology Map Layout Menu Options
Topology Map Layout Menu Options

Table 1: Topology Map Layout Menu Option Descriptions

Layout Option

Description

Circle Selected Nodes

Creates a circular arrangement of network elements. Select the nodes or groups to be included before you choose this option from the menu.

When you select this option, the cursor becomes a crosshair.

Click once on the map to indicate the center of the circle, and click a second time to choose the radius of the circle. All selected elements (highlighted) are moved onto the circumference of the circle at equally spaced intervals.

Distribute Selected Points

Creates an arrangement of network elements that forces the selected elements away from each other and minimizes overlap. Select the nodes or groups to be included before you choose this option from the menu.

When selected, the cursor becomes a crosshair. Click once on the map to indicate the center of a circle that will contain the elements, and click a second time to choose the radius of the circle. All the selected network elements (highlighted) are arranged within the circle in a way that is easier to see. If any of the elements are collapsed groups, the groups are expanded, their contents distributed, then collapsed again, and so on recursively.

Distribute Selected Points Within Groups

Available in the Layout menu only after selecting collapsed groups. Select the nodes or groups to be included before you choose this option from the menu.

For each selected group, the elements are distributed for that group, and if multiple groups are selected, they are distributed in a way that minimizes overlap between the groups when they are expanded.

Straighten Selected Nodes

Similar to the Circle Selected Nodes option, except that selected elements are arranged onto a horizontal line, equally spaced. Select the nodes or groups to be included before you choose this option from the menu.

You can rotate the horizontal line with the drag and rotate tool if you prefer an angle other than horizontal.

Flip

Flips the entire layout vertically or horizontally, according to your selection.

Stiffen

Only relevant when Draw Multiple Links as Curves is turned on in Map Preferences.

When there are multiple links between two nodes but some of the links are hidden from view, the parallel links might be spread apart too wide or unevenly or all to one side. In this case, select Stiffen > Stiffen Visible Curves to bring the parallel links closer together and center them.

Select Stiffen > Unstiffen All to undo this stiffening.

Reset by Lat/Lon

Resets the network topology to its original geographical layout (provided that the latitude and longitude coordinates are used in the network). This function is useful when you want to view the network in its geographical layout according to previously specified Lat/Lon values.

Set Lat/Lon From Map

Assigns latitude and longitude values to all selected nodes based on their current location on the map. This function is useful if you have manually moved nodes on the map to desired locations and want to save these locations for future sessions.

Push Lat/Lon to NorthStar Operator

Allows you to export the latitude and longitude coordinates from the NorthStar Planner client to the NorthStar Operator client.

Before selecting this option, select Layout > Set Lat/Lon From Map to assign latitude and longitude values based on their current location on the map. Then select Layout > Push Lat/Lon to NorthStar Operator to copy the coordinates to the live model (NorthStar Operator client).

From the NorthStar Operator client, you can then navigate to Layout > Reset By Lat/Lon to reset the topology according to the imported coordinates. In the Operator client, this action overwrites any previous latitude and longitude settings.

Quick Layout

Recomputes the X, Y coordinates of all the points using the program algorithms to try to lay them out clearly. This is the same algorithm used when a topology map window is opened and no saved coordinates are available. If latitude and longitude coordinates are available, they are used to position the nodes, and nodes with the same Lat/Lon are laid out at the city location in a small radius around the city center. The full recalculation could take a long time for large networks.

Detailed Layout

This topology layout algorithm attempts to distribute the nodes and links as a planar graph, meaning the topology is drawn in such a way that links intersect only at nodes, or no links cross each other. This layout is useful to create a topology to display a minimal number of links crossing over each other while keeping node groups together. Various parameters relating to the geographical Lat/Lon position, distance proximity to other nodes, link length, and groups can have their cost weights adjusted. Adjusting these weights impacts the algorithm’s topology display.