Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Interactive Map Features

 

The topology map is interactive, meaning that you can use features within the map itself to customize the map and network information panes.

Right-Click Functions

Right-click a node, selected nodes, or node group on the topology map to execute node-specific filtering as shown in Figure 1 and described in Table 1.

Figure 1: Right-Click Options for Nodes or Groups
Right-Click Options for Nodes
or Groups

Table 1: Right-Click Options for Nodes or Groups

Option

Function

Filter in Node Table

Filters the nodes displayed in the network information pane to display only the selected node(s) or node group(s).

Tunnels On or Thru Node

Filters the tunnels displayed in the network information pane to include only those that meet the On or Thru Node criteria.

Tunnels Starting at Node

Filters the tunnels displayed in the network information pane to include only those that meet the Starting at Node criteria.

Tunnels Ending at Node

Filters the tunnels displayed in the network information pane to include only those that meet the Ending at Node criteria.

Group selected nodes

Prompts you to give the group of nodes a name, after which the group can be expanded or collapsed on the topology map. This is a shortcut to the Layout > Group selected nodes function.

Ungroup selected nodes

Ungroups the nodes in the selected group. This is a shortcut to the Layout > Ungroup selected nodes function.

Circle selected nodes

Arranges the selected nodes in a roughly circular pattern with the nodes and links separated as much as possible. This is a shortcut to the Layout > Circle selected nodes function.

Distribute selected nodes

Forces the selected elements away from each other and minimizes overlap. This is a shortcut to the Layout > Distribute selected nodes function.

Straighten selected nodes

Aligns the selected nodes in a linear pattern. This is a shortcut to the Layout > Straighten selected nodes function.

Right-click a link on the topology map to execute link-specific filtering as shown in Figure 2 and described in Table 2.

Option

Function

Filter in Link Table

Filters the tunnels displayed in the network information pane to display only the selected link.

Tunnels On or Thru Link

Filters the tunnels displayed in the network information pane to include only those that meet the On or Thru Link criteria.

Note

To clear the tunnel filter so that all tunnels are again displayed, click a different tab (Node, for example), and then click the Tunnel tab again.

Right-click blank space in the topology map pane to access the whole-map functions shown in Figure 3 and described in Table 3.

Figure 3: Right-Click Options for the Topology Map as a Whole
Right-Click Options for the
Topology Map as a Whole

Table 3: Right-Click Options for the Topology Map as a Whole

Option

Function

Distribute All Nodes

Distributes all the nodes in the map, pushing elements away from each other and minimizing overlap. This is a shortcut to selecting all nodes and navigating to Layout>Distribute selected nodes.

Save Default Map Layout

Saves the current layout as your default. The default layout is displayed when you first log in to NorthStar Controller. If you already have a default layout, this function overrides the existing default. You can also designate a default layout by navigating to Layout>Manage Layouts.

Select All Nodes

Selects all nodes on the topology map. This is a shortcut to using shift-left-click to create a selection box around all nodes or individually shift-clicking on all nodes.

Reset Event Counts

Resets the number of events tracked in the Event View available from the top menu bar. These are events coming in from the topology server.

Refresh Utilization

Refreshes the display of link colors based on RSVP utilization.

Note: Updates are periodically pushed to the client by the server.

Topology Settings window

Access the Topology Settings window by clicking on the tools icon in the upper right corner of the topology window. Figure 4 shows the tools icon.

Figure 4: Tools Icon to Access Topology Settings
Tools Icon to Access
Topology Settings

The Topology Settings window contains many topology display settings, all in one place. Figure 5 shows the Topology Settings window with the four tabs that group related settings.

Figure 5: Topology Settings Window
Topology Settings Window

One of the options in the Options tab is Hide Partially Visible Links. When selected, this option removes from the display any links for which both end nodes are not within the field of view. This is useful for focusing on a subset of a large network.