Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Configuring the MX Series Router in a Distributed Deployment

    You need to configures interfaces, virtual routing and forwarding instances (VRFs), and DHCP on the MX Series router with Junos OS. You can, however, use Administration Portal to specify configuration settings for both endpoints of the required IPSec tunnel between the MX Series router and the NFX250 with Administration Portal. When the NFX250 becomes operational, Contrail Service Orchestration components set up the tunnel.

    To configure the MX Series router in Junos OS:

    1. Configure the interfaces on the MX Series router.

      For example:

      ge-0/3/7 { 
      
              description "to nfx wan0 i.e. ge-0/0/10"; 
      
              vlan-tagging; 
      
              unit 10 { 
      
                  description "NFX WAN_0 data"; 
      
                  vlan-id 10; 
      
                  family inet { 
      
                      address 195.195.195.1/24; 
      
                  } 
      
              } 
      
              unit 20 { 
      
                  description "NFX WAN_0 OAM"; 
      
                  vlan-id 20; 
      
                  family inet { 
      
                      address 196.196.196.254/24; 
      
                  } 
      
              } 
      
          } 
      
          ge-0/3/8 { 
      
              description "to nfx wan1 i.e. ge-0/0/11 FOR IPSEC"; 
      
              unit 0 { 
      
                  family inet { 
      
                      address 198.198.198.1/24; 
      
                  } 
      
              } 
      
          } 
      
    2. Configure a VRF for Operation, Administration, and Maintenance (OAM) traffic between Contrail Service Orchestration and the NFX250.

      For example:

      nfx-oam { 
      
              instance-type vrf; 
      
              interface ge-0/0/0.220; 
      
              vrf-target target:64512:10000; 
      
              vrf-table-label; 
      
              routing-options { 
      
                  static { 
      
                      route 0.0.0.0/0 next-hop 192.168.220.2; 
      
                  } 
      
              } 
      
          } 
      
    3. Configure a VRF for data traffic that travels over the wide area network (WAN).

      Data that travels through the IPSec tunnel also uses this VRF. When you configure the MX endpoint of the IPSec tunnel in Administration Portal, you specify these VRF settings.

      For example:

      nfx-data { 
      
              instance-type vrf; 
      
              interface ge-0/3/7.10; 
      
              vrf-target target:64512:10001; 
      
              vrf-table-label; 
      
              protocols { 
      
                  bgp { 
      
                      group nfx-gwr-bgp-grp { 
      
                          type external; 
      
                          family inet { 
      
                              unicast; 
      
                          } 
      
                          export send-direct; 
      
                          peer-as 65000; 
      
                          neighbor 195.195.195.2; 
      
                      } 
      
                  } 
      
              } 
      
          }    
    4. Configure DHCP on the MX Series router.
      System{ 
      
          Services {  
      
              dhcp-local-server { 
      
                  group 8-csp-gpr { 
      
                      interface ge-0/3/8.0; 
      
                  } 
      
              } 
      
          } 
      
       
      
      access { 
      
          address-assignment { 
      
              pool 8-csp-gpr-pool { 
      
                  family inet { 
      
                      network 198.198.198.0/24; 
      
                      range valid { 
      
                          low 198.198.198.5; 
      
                          high 198.198.198.250; 
      
                      } 
      
                      dhcp-attributes { 
      
                          domain-name juniper.net; 
      
                          name-server { 
      
                              8.8.8.8; 
      
                          } 
      
                      } 
      
                  } 
      
              } 
      
          } 
      
      } 

    Modified: 2016-10-12