Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Monitoring the Current Configuration of the System in Manual Commit Mode

    Purpose

    Display the configuration currently running on the router, a specified virtual router, a specified interface, or a specified category of router settings.

    Action

    To display the configuration currently running on the router:

    host1# show running-configuration
    ! Configuration script being generated on TUE JAN 29 200X 00:31:12 UTC! Juniper Networks Edge Routing Switch ERX700
    ! Version: x.y.z (January 18, 200X 15:01)
    ! Copyright (c) 1999-200X Juniper Networks, Inc. All rights reserved.
    Commands displayed are limited to those available at privilege level 10
    ! Juniper Networks Edge Routing Switch ERX700
    boot config startup-configuration
    boot system erx_x-y-z.rel
    no boot backup
    no boot subsystem
    no boot backup subsystem
    no boot force-backup
    !
    aaa domain-map map1
     auth-router-name default
     ip-router-name default
     ipv6-router-name default
     ipv6-prefix-pool-name pool1
    !
    hostname host1
    !
    service config-monitor-periodicity 1800
    control-plane
    !
    controller t3 4/0
    controller t3 4/1
    controller t3 4/2
    controller t3 4/3
    controller t3 4/4
    controller t3 4/5
    controller t3 4/6
    controller t3 4/7
    controller t3 4/8
    controller t3 4/9
    controller t3 4/10
    controller t3 4/11
    .
    controller sonet 5/0
    !
    controller sonet 5/1
    !
    controller sonet 5/2
    !
    controller sonet 5/3
    !
    controller sonet 5/4
    !
    controller sonet 5/5
    !
    controller sonet 5/6
    !
    controller sonet 5/7
    !
    !
    dos-protection-group default
    line console 0
    line vty 0 4
     no login
    !
    !
    traffic-class best-effort
    !
    drop-profile default
    !
    queue-profile default
    !
    scheduler-profile default
    !
    qos-shared-shaper-control
    !
    statistics-profile default
    !
    qos-profile atm-default
    !
    qos-profile serial-default
    !
    qos-profile ethernet-default
    !
    qos-profile server-default
    !
    qos-profile lag-default
    !
    !
    qos-port-type-profile ethernet qos-profile ethernet-default
    !
    qos-port-type-profile atm qos-profile atm-default
    !
    qos-port-type-profile serial qos-profile serial-default
    !
    qos-port-type-profile server-port qos-profile server-default
    !
    qos-port-type-profile lag qos-profile lag-default
    !
    ipv6 classifier-list class1
    redundancy
    virtual-router default
    aaa authentication atm1483 default radius
    aaa accounting atm1483 default radius
    aaa authentication ip default radius
    aaa accounting ip default radius
    aaa authentication ipsec default radius
    aaa accounting ipsec default radius
    aaa authentication ppp default radius
    aaa accounting ppp default radius
    !
    ip address-pool local
    aaa authentication radius-relay default radius
    aaa accounting radius-relay default radius
    aaa authentication tunnel default radius
    aaa accounting tunnel default radius
    !
    service dhcp-local equal-access
    ip dhcp-local pool pool1
     lease infinite
    !
    ip dhcp-local pool default
     lease 0 0 30
    !
    !
    interface null 0
    !
    interface fastEthernet 0/0
     ip address 10.6.128.226 255.255.128.0
    !
    interface gigabitEthernet 6/0
    !
    ip route 0.0.0.0 0.0.0.0 10.6.128.1
    no ip source-route
    !
    !
    ipv6 address-pool local
    !
    ipv6 local pool pool1
     dns-server 2001:2003::2005
    !
    license ipsec-tunnels l0agskcs7wd6w6
    sscc enable cops-pr
    sscc transportRouter default
    no sscc update-policy-request enable
    !
    !
    log engineering
    log verbosity low
    no log severity *
    no log engineering
    log fields timestamp instance no-calling-task
    !
    service manual-commit
    ! End of generated configuration script.
    

    To display the configuration currently running on a specified interface:

    host1# show running-configuration interface serial 4/0
    interface atm 4/0
     atm vc-per-vp 1024
     atm uni-version 3.0
    !
    interface atm 4/0.1 point-to-point
     profile pppoe myProfile
     qos-profile myQosProfile
    !
    interface atm 4/0.2 point-to-point
     qos-profile myQosProfile
     ip description TestIP
    !
    interface atm 4/0.3 point-to-point
    

    To display the configuration currently running on a specified category of router settings:

    host1# show running-configuration category system file-system
    boot config startup-configuration
    boot system m.rel
    no boot backup
    no boot subsystem
    no boot backup subsystem
    

    Published: 2014-08-12