Software Compatibility

An E Series software release supports a specific set of line modules and associated I/O modules or IOAs. Before you install a new line module, I/O module, or IOA, you should install a software release that supports the new module.

Line Modules

If the router uses a software version that does not support a line module that you install, you see the message unrecognized board type, and the router disables the module. When you issue a show version command, the state of the line module is disabled (admin).

If you subsequently boot the router with software that supports the line module, the line module becomes available and its state is enabled.

I/O Modules and IOAs

If the router uses a software version that does not support an I/O module or IOA that you install, the I/O module or IOA will be unavailable, and you will not be able to upgrade the software on the router. To upgrade the software:

  1. Remove the I/O module or IOA.
  2. Reboot the line module that corresponds to this I/O module or IOA. See Booting the System .
  3. When the line module has rebooted, install the I/O module or IOA.
  4. Upgrade the software on the router. See Installing JunosE Software .