Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Configuring Interfaces for VPLS Routing in ACX Series

    On each PE router and for each VPLS routing instance, specify which interfaces are intended for the VPLS traffic traveling between PE and CE routers. To specify the interface for VPLS traffic, include the interface statement in the routing instance configuration:

    interface interface-name;

    You can include this statement at the following hierarchy levels:

    • [edit routing-instances routing-instance-name]
    • [edit logical-systems logical-system-name routing-instances routing-instance-name]

    Note: ACX Series routers do not support the [edit logical-systems] hierarchy.

    You must also define each interface by including the following statements:

    vlan-tagging;
    encapsulation encapsulation-type;
    unit logical-unit-number {
    family vpls;
    vlan-id vlan-id-number;
    }

    You can include these statements at the following hierarchy levels:

    • [edit interfaces interface-name]
    • [edit logical-systems logical-system-name interfaces interface-name]

    Note: ACX Series routers do not support the [edit logical-systems] hierarchy.

    The following sections provide enough information to enable you to configure interfaces for VPLS routing. For detailed information about configuring interfaces and the statements at the [edit interfaces] hierarchy level, see the Junos OS Network Interfaces Library for Routing Devices.

    Configuring the VPLS Interface Name

    Specify both the physical and logical portions of the interface name, in the following format:

    physical.logical

    For example, in ge-1/2/1.2, ge-1/2/1 is the physical portion of the interface name and 2 is the logical portion. If you do not specify the logical portion of the interface name, 0 is set by default.

    A logical interface can be associated with only one routing instance.

    If you enable a routing protocol on all instances by specifying interfaces all when configuring the master instance of the protocol at the [edit protocols] hierarchy level, and you configure a specific interface for VPLS routing at the [edit routing-instances routing-instance-name] hierarchy level, the latter interface statement takes precedence and the interface is used exclusively for VPLS.

    If you explicitly configure the same interface name at both the [edit protocols] and [edit routing-instances routing-instance-name] hierarchy levels and then attempt to commit the configuration, the commit operation fails.

    Configuring VPLS Interface Encapsulation

    You need to specify an encapsulation type for each PE-router-to-CE-router interface configured for VPLS. This section describes the encapsulation statement configuration options available for VPLS.

    To configure the encapsulation type on the physical interface, include the encapsulation statement:

    encapsulation (ethernet-vpls | ether-vpls-over-atm-llc |extended-vlan-vpls | vlan-vpls);

    Note: ACX Series routers do not support the ether-vpls-over-atm-llc and extended-vlan-vpls options for encapsulation.

    You can include the encapsulation statement for physical interfaces at the following hierarchy levels:

    • [edit interfaces interface-name]
    • [edit logical-systems logical-system-name interfaces interface-name]

    Note: ACX Series routers do not support the [edit logical-systems] hierarchy.

    You can configure the following physical interface encapsulations for VPLS routing instances:

    • ethernet-vpls—Use Ethernet VPLS encapsulation on Ethernet interfaces that have VLAN 802.1Q tagging and VPLS enabled. The PE router expects to receive Ethernet frames with VLAN tags that are not service-delimiting. The Ethernet frames are not meaningful to the PE router and cannot be used by the service provider to separate customer traffic.

      On M Series routers (except the M320 router), the 4-port Fast Ethernet TX PIC and the 1-port, 2-port, and 4-port, 4-slot Gigabit Ethernet PICs can use the Ethernet VPLS encapsulation type.

    • ether-vpls-over-atm-llc—For ATM intelligent queuing (IQ) interfaces only, use the Ethernet virtual private LAN service (VPLS) over ATM LLC encapsulation to bridge Ethernet interfaces and ATM interfaces over a VPLS routing instance (as described in RFC 2684, Multiprotocol Encapsulation over ATM Adaptation Layer 5). Packets from the ATM interfaces are converted to standard ENET2/802.3 encapsulated Ethernet frames with the frame check sequence (FCS) field removed.
    • extended-vlan-vpls—Use extended virtual LAN (VLAN) VPLS encapsulation on Ethernet interfaces that have VLAN 802.1Q tagging and VPLS enabled and that must accept packets carrying TPIDs 0x8100, 0x9100, and 0x9901. On M Series routers (except the M320 router), the 4-port Fast Ethernet TX PIC and the 1-port, 2-port, and 4-port, 4-slot Gigabit Ethernet PICs can use the Ethernet VPLS encapsulation type.

      Note: The built-in Gigabit Ethernet PIC on an M7i router does not support extended VLAN VPLS encapsulation.

    • vlan-vpls—Use VLAN VPLS encapsulation on Ethernet interfaces with VLAN 802.1Q tagging and VPLS enabled. The PE router expects to receive Ethernet frames with VLAN tags that are service-delimiting. These VLAN tags can be used by the service provider to separate customer traffic. For example, LAN traffic from different customers can flow through the same service provider switch, which can then apply VLAN tags to distinguish one customer’s traffic from the others. The traffic can then be forwarded to the PE router.

      Interfaces with VLAN VPLS encapsulation accept packets carrying standard TPID values only. On M Series routers (except the M320 router), the 4-port Fast Ethernet TX PIC and the 1-port, 2-port, and 4-port, 4-slot Gigabit Ethernet PICs can use the Ethernet VPLS encapsulation type.

    To configure the encapsulation type for logical interfaces, include the encapsulation statement:

    encapsulation (ether-vpls-over-atm-llc | vlan-vpls);

    You can include the encapsulation statement for logical interfaces at the following hierarchy levels:

    • [edit interfaces interface-name unit number]
    • [edit logical-systems logical-system-name interfaces interface-name unit number]

    You can configure the following logical interface encapsulations for VPLS routing instances:

    • ether-vpls-over-atm-llc—Use Ethernet VPLS over Asynchronous Transfer Mode (ATM) logical link control (LLC) encapsulation to bridge Ethernet interfaces and ATM interfaces over a VPLS routing instance (as described in RFC 2684, Multiprotocol Encapsulation over ATM Adaptation Layer 5). Packets from the ATM interfaces are converted to standard ENET2/802.3-encapsulated Ethernet frames with the frame check sequence (FCS) field removed. This encapsulation type is supported on ATM intelligent queuing (IQ) interfaces only.
    • vlan-vpls—Use VLAN VPLS encapsulation on Ethernet interfaces with VLAN 802.1Q tagging and VPLS enabled. The PE router expects to receive Ethernet frames with VLAN tags that are service-delimiting. These VLAN tags can be used by the service provider to separate customer traffic. For example, LAN traffic from different customers can flow through the same service provider switch, which can then apply VLAN tags to distinguish one customer's traffic from the others. The traffic can then be forwarded to the PE router.

      Interfaces with VLAN VPLS encapsulation accept packets carrying standard TPID values only. On M Series routers (except the M320 router), the 4-port Fast Ethernet TX PIC and the 1-port, 2-port, and 4-port, 4-slot Gigabit Ethernet PICs can use the Ethernet VPLS encapsulation type.

      Note: Label-switched interfaces (LSIs) do not support VLAN VPLS encapsulation. Therefore, you can only use VLAN VPLS encapsulation on a PE-router-to-CE-router interface and not a core-facing interface.

    When you configure the physical interface encapsulation as vlan-vpls, you also need to configure the same interface encapsulation for the logical interface. You need to configure the vlan-vpls encapsulation on the logical interface because the vlan-vpls encapsulation allows you to configure a mixed mode, where some of the logical interfaces use regular Ethernet encapsulation (the default for logical interfaces) and some use vlan-vpls.

    Note: Starting with Junos OS release 13.3, a commit error occurs when you configure vlan-vpls encapsulation on a physical interface and configure family inet on one of the logical units. Previously, it was possible to commit this invalid configuration.

    Enabling Flexible VLAN Tagging

    Junos OS supports receiving and forwarding routed Ethernet frames with 802.1Q virtual local area network (VLAN) tags and running the Virtual Router Redundancy Protocol (VRRP) over 802.1Q-tagged interfaces. For VPLS to function properly, configure the router to receive and forward frames with 802.1Q VLAN tags by including the vlan-tagging statement at the [edit interfaces interface-name] hierarchy level:

    [edit interfaces interface-name]

    Gigabit Ethernet interfaces can be partitioned. You can assign up to 4095 different logical interfaces, one for each VLAN, but you are limited to a maximum of 1024 VLANs on any single Gigabit Ethernet or 10-Gigabit Ethernet port.

    Configuring VLAN IDs for Logical Interfaces

    You can bind a VLAN identifier to a logical interface by including the vlan-id statement:

    vlan-id number;

    You can include this statement at the following hierarchy levels:

    • [edit interfaces interface-name unit logical-unit-number]
    • [edit logical-systems logical-system-name interfaces interface-name unit logical-unit-number]

    You can also configure a logical interface to forward packets and learn MAC addresses within each VPLS routing instance configured with a VLAN ID that matches a VLAN ID specified in a list using the vlan-id-list statement. VLAN IDs can be entered individually using a space to separate each ID, entered as an inclusive list separating the starting VLAN ID and ending VLAN ID with a hyphen, or a combination of both.

    For example, to configure the VLAN IDs 20 and 45 and the range of VLAN IDs between 30 and 40, issue the following command from the CLI:

    set interfaces ge-1/0/1 unit 1 vlan-id-list [20 30-40 45];

    To configure a list of VLAN IDs for a logical interface, include the vlan-id-list statement:

    vlan-id-list list-of-vlan-ids;

    You can include this statement at the following hierarchy levels:

    • [edit interfaces interface-name unit logical-unit-number]
    • [edit logical-systems logical-system-name interfaces interface-name unit logical-unit-number]

    Note: ACX Series routers do not support the [edit logical-systems] hierarchy.

    For more information about how to configure VLANs, see the Junos OS Network Interfaces Library for Routing Devices. For detailed information about how VLAN identifiers in a VPLS routing instance are processed and translated, see the MX Series Layer 2 Configuration Guide.

    Sample Scenario of Hierarchical Virtual Private LAN Service on Logical Tunnel Interface

    This section describes how to configure the hierarchical virtual private LAN service (H-VPLS) on ACX5048 and ACX5096 routers. Junos OS for ACX5048 and ACX5096 routers supports configuring H-VPLS using the logical tunnel interface encapsulation.

    For example, you have three provider edge devices (PE1, PE2 and PE3). PE2 device connects both PE1 and PE3 devices. The pseudowire connecting PE1 and PE2 devices are encapsulated with circuit cross-connect (CCC). In this case, PE1 device acts as a spoke and PE2 as a hub. The pseudowire connecting PE2 and PE3 devices are encapsulated with VPLS. You need to encapsulate CCC and VPLS pseudowires using the logical tunnel interface on the PE2 device.

    The following steps describe how to encapsulate CCC and VPLS pseudowires using the logical tunnel interface on the PE2 device:

    1. Create a logical tunnel interface on the PE2 device by using the set chassis fpc fpc-slot pic pic-slot tunnel-services port port-number CLI command. The port-number can be any port on the chassis which is not used for regular traffic forwarding. For example,
      [edit]
      user@host# set chassis fpc 0 pic 0 tunnel-services port 65
      
    2. Encapsulate the CCC and VPLS pseudowires using the logical tunnel interface (lt-0/0/65) created on the PE2 device. Use the Ethernet CCC (ethernet-ccc) and Ethernet VPLS (ethernet-vpls) encapsulation types at the [edit interfaces interface-name unit logical-unit-number] hierarchy level as shown in the example:

      Device PE2

      [edit]
      user@host# set interfaces lt-0/0/65 unit 0 encapsulation ethernet-ccc;
      user@host# set interfaces lt-0/0/65 unit 0 encapsulation peer-unit 1;
      user@host# set interfaces lt-0/0/65 unit 1 encapsulation ethernet-vpls;
      user@host# set interfaces lt-0/0/65 unit 1 encapsulation peer-unit 0;
      
    3. Verify the configuration by entering the show command at the logical tunnel interface level. The output should display as follows:
      [edit interfaces lt-0/0/65]
      user@host# show 
      unit 0 {
          encapsulation ethernet-ccc;
          peer-unit 1;
      }
      unit 1 {
          encapsulation ethernet-vpls;
          peer-unit 0;
      }
      

    Based on this configuration, you can see that:

    • The CCC pseudowire on PE2 device originates from lt-0/0/65.0
    • The VPLS pseudowire on PE2 device originates from lt-0/0/65.1
    • The CCC pseudowire on PE1 device originates from a regular interface
    • The VPLS pseudowire on PE3 device originates from a regular interface

    Configuring Aggregated Ethernet Interfaces for VPLS

    You can configure aggregated Ethernet interfaces between CE devices and PE routers for VPLS routing instances. Traffic is load-balanced across all of the links in the aggregated interface. If one or more links in the aggregated interface fails, the traffic is switched to the remaining links.

    For more information about how aggregated Ethernet interfaces function in the context of VPLS, see VPLS and Aggregated Ethernet Interfaces.

    To configure aggregated Ethernet interfaces for VPLS, configure the interface for the VPLS routing instance as follows:

    interfaces aex {
    vlan-tagging;
    encapsulation encapsulation-type;
    unit logical-unit-number {
    vlan-id number;
    }
    }

    You can configure the following physical link-layer encapsulation types for the VPLS aggregated Ethernet interface:

    • ethernet-vpls
    • extended-vlan-vpls
    • flexible-ethernet-services
    • vlan-vpls

    Note: ACX Series routers do not support the extended-vlan-vpls and vlan-vpls encapsulation types.

    For the interface configuration statement, in aex, the x represents the interface instance number to complete the link association; x can be from 0 through 127, for a total of 128 aggregated interfaces.

    For more information about how to configure aggregated Ethernet interfaces, see the Ethernet Interfaces Feature Guide for Routing Devices.

    The aggregated Ethernet interface must also be configured for the VPLS routing instance as shown in the following example:

    [edit]
    routing-instances {
    green {
    instance-type vpls;
    interface ae0.0;
    route-distinguisher 10.255.234.34:1;
    vrf-target target:11111:1;
    protocols {
    vpls {
    site-range 10;
    site green3 {
    site-identifier 3;
    }
    }
    }
    }
    }

    Interface ae0.0 represents the aggregated Ethernet interface in the routing instance configuration. The VPLS routing instance configuration is otherwise standard.

    Modified: 2017-09-13