Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    family (for EX Series switches)

    Syntax

    family ccc

    family ccc;

    family ethernet-switching

    family ethernet-switching {
    filter [input | output] filter-name;
    native-vlan-id vlan-id;
    port-mode mode;
    vlan {
    members [ (all | names | vlan-ids)];
    }
    }

    family inet

    family inet {
    address address {
    arp ip-address (mac | multicast-mac) mac-address <publish>;
    vrrp-group group-id {
    advertise-interval milliseconds;
    preempt | no-preempt {
    hold-time seconds;
    }
    priority number;
    virtual-address [addresses];
    virtual-link-local-address ip-address;
    }
    }
    client-identifier (ascii ascii | hexadecimal hexadecimal);
    lease-time (seconds | infinite);
    server-address ip-address;
    vendor-id vendor-id;
    }
    input filter-name;
    output filter-name;
    }
    mtu bytes;
    }

    family inet6

    family inet6 {
    address address {
    ndp ip-address (mac | multicast-mac) mac-address <publish>;
    }
    (dad-disable | no-dad-disable);
    input filter-name;
    output filter-name;
    }
    mtu bytes;
    no-neighbor-learn;
    }

    family iso

    family iso {
    address interface-address;
    mtu bytes;
    }

    family mpls

    family mpls {
    mtu bytes;
    }

    Hierarchy Level

    [edit interfaces interface-name unit logical-unit-number],
    [edit interfaces interface-range name unit logical-unit-number]

    Release Information

    Statement introduced in Junos OS Release 9.0 for EX Series switches, including options ethernet-switching, inet, and iso.

    Option inet6 introduced in Junos OS Release 9.3 for EX Series switches.

    Options ccc and mpls introduced in Junos OS Release 9.5 for EX Series switches.

    Description

    Configure protocol family information for the logical interface on the switch.

    You must configure a logical interface to be able to use the physical device.

    Default

    Interfaces on EX2200, EX3200, EX3300, EX4200, and EX4500 switches are set to family ethernet-switching by the default factory configuration. Before you can change the family setting for an interface to another family type, you must delete this default setting or any user-configured family setting. EX6200 and EX8200 switch interfaces do not have a default family setting.

    Options

    See Table 1 for protocol families available on the switch interfaces. Different protocol families support different subsets of the interface types on the switch. Interface types on the switch are:

    • Aggregated Ethernet (ae)

    • Gigabit Ethernet (ge)

    • Interface-range configuration (interface-range)

    • Loopback (lo0)

    • Management Ethernet (me0)

    • Routed VLAN interface (RVI) (vlan)

    • Virtual management Ethernet (vme)

    • 10-Gigabit Ethernet (xe)

    If you are using an interface range, the supported protocol families are the ones supported by the interface types that compose the range.

    Not all interface types support all family substatements. Check your switch CLI for supported substatements for a particular protocol family configuration.

    Table 1: Protocol Families and Supported Interface Types

    FamilyDescriptionSupported Interface Types
    ae ge lo0 me0 vlanvme xe

    ccc

    Circuit cross-connect protocol family

    ✓*

        

    ethernet-
    switching

    Ethernet switching protocol family

     

      

    inet

    IPv4 protocol family

    inet6

    IPv6 protocol family

    iso

    Junos OS protocol family for IS-IS traffic

    mpls

    MPLS protocol family

     

    *Supported on EX8200 switches only

    The remaining statements are explained separately. See CLI Explorer.

    Required Privilege Level

    interface—To view this statement in the configuration.
    interface-control—To add this statement to the configuration.

    Modified: 2017-12-21