Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    family

    Syntax

    family ccc

    family ccc;
    filter {
    group group-number;
    input filter-name;
    input-list [filter-names];
    output filter-name;
    output-list [filter-names];
    }
    policer {
    input policer-name;
    output policer-name;
    }
    }

    family ethernet-switching

    family ethernet-switching {
    filter {
    input filter-name;
    output filter-name;
    }
    interface-mode (access | trunk);
    storm-control profile-name;
    vlan {
    members (vlan-name |[-vlan-names] | all);
    }
    }

    family inet

    family inet {
    accounting {
    destination-class-usage;
    source-class-usage {
    input;
    output;
    }
    }
    address ipv4-address {
    arp ip-address (mac | multicast-mac) mac-address <publish>;
    broadcast address;
    vrrp-group group-number {
    (accept-data | no-accept-data);
    advertise–interval seconds;
    advertisements-threshold number;
    authentication-key key;
    authentication-type authentication;
    fast-interval milliseconds;
    (preempt | no-preempt) {
    hold-time seconds;
    }
    priority number;
    track {
    interface interface-name {
    priority-cost number;
    }
    priority-hold-time seconds;
    route ip-address/mask routing-instance instance-name priority-cost cost;
    }
    virtual-address [addresses];
    vrrp-inherit-from {
    active-group group-number;
    active-interface interface-name;
    }
    }
    }
    input filter-name;
    output filter-name;
    }
    mtu bytes;
    no-neighbor-learn;
    primary;
    rpf-check {
    fail-filter filter-name;
    mode {
    loose;
    }
    }
    }

    family inet6

    family inet6 {
    accounting {
    destination-class-usage;
    source-class-usage {
    input;
    output;
    }
    }
    address address {
    ndp ip-address (mac | multicast-mac) mac-address <publish>;
    vrrp-inet6-group group-id {
    accept-data | no-accept-data;
    advertisements-threshold number;
    authentication-key key;
    authentication-type authentication;
    fast-interval milliseconds;
    hold-time seconds;
    }
    priority number;
    track {
    interface interface-name {
    priority-cost number;
    }
    priority-hold-time seconds;
    route ip-address/mask routing-instance instance-name priority-cost cost;
    }
    vrrp-inherit-from {
    active-group group-name;
    active-interface interface-name;
    }
    }
    }
    (dad-disable | no-dad-disable);
    input filter-name;
    output filter-name;
    }
    mtu bytes;
    nd6-stale-time time;
    no-neighbor-learn;
    no-redirects;
    policer {
    input policer-name;
    output policer-name;
    }
    rpf-check {
    fail-filter filter-name;
    mode {
    loose;
    }
    }
    }

    family iso

    family iso {
    address interface-address;
    mtu bytes;
    }

    Hierarchy Level

    [edit interfaces interface-name unit logical-unit-number],
    [edit interfaces interface-range name unit logical-unit-number]

    Release Information

    Statement introduced in Junos OS Release 9.0 for EX Series switches, including options ethernet-switching, inet, and iso.

    Option inet6 introduced in Junos OS Release 9.3 for EX Series switches.

    Options ccc introduced in Junos OS Release 9.5 for EX Series switches.

    Description

    Configure protocol family information for the logical interface on the switch.

    You must configure a logical interface to be able to use the physical device.

    Default

    Interfaces on EX4300 switches are set to family ethernet-switching by the default factory configuration. Before you can change the family setting for an interface to another family type, you must delete this default setting or any user-configured family setting.

    Options

    See Table 1 for protocol families available on the switch interfaces. Different protocol families support different subsets of the interface types on the switch. Interface types on the switch are:

    • Aggregated Ethernet (ae0)

    • 40-Gigabit Ethernet (et)

    • Gigabit Ethernet (ge)

    • Interface-range configuration (interface-range)

    • Loopback (lo0)

    • Management Ethernet (me0)

    • Integrated Routing and Bridging (IRB) interfaces (IRB) (irb)

    • Virtual management Ethernet (vme)

    • 10-Gigabit Ethernet (xe)

    If you are using an interface range, the supported protocol families are the ones supported by the interface types that compose the range.

    Not all interface types support all family substatements. Check your switch CLI for supported substatements for a particular protocol family configuration.

    Table 1: Protocol Families and Supported Interface Types

    FamilyDescriptionSupported Interface Types
    ae0 etge irblo0 me0 vme xe

    ccc

    Circuit cross-connect protocol family

        

    ethernet-
    switching

    Ethernet switching protocol family

        

    inet

    IPv4 protocol family

    inet6

    IPv6 protocol family

    iso

    Junos OS protocol family for IS-IS traffic

    The remaining statements are explained separately. See CLI Explorer.

    Required Privilege Level

    interface—To view this statement in the configuration.
    interface-control—To add this statement to the configuration.

    Modified: 2017-09-13