Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Example Step: Configuring Integrated Bridging and Routing

    Router 2 and Router 3 on the bridging network act as a kind of gateway to the Layer 3 routers in the rest of the network. Router 2 and Router 3 must be able to route packets as well as bridge frames. This requires the configuration of integrated routing and bridging (IRB) on Routers 2 and 3. The link to the router network is xe-2/1/0 on Router 2 and xe-1/1/0 on Router 3.

    You configure IRB in two steps:

    1. Configure the IRB interface using the irb statement.
    2. Reference the IRB interface at the bridge domain level of the configuration.

    IRB supports Layer 2 bridging and Layer 3 routing on the same interface. If the MAC address on the arriving frame is the same as that of the IRB interface, then the packet inside the frame is routed. Otherwise, the MAC address is learned or looked up in the MAC address database.

    Note: You configure IRB on Router 2 and Router 3. The Virtual Router Redundancy Protocol (VRRP) is configured on the IRB interface so that both links can be used to carry traffic between the bridge domain and the router network.

    To configure IRB on Router 2 and Router 3:

    Note: The configurations in this chapter are only partial examples of complete and functional router configurations. Do not copy these configurations and use them directly on an actual system. The ae1 and ae3 interfaces have been previously configured in Example Step: Configuring Interfaces and VLAN Tags.

    1. Configure the router link and IRB on Router 2:

      [edit]
      interfaces {
      xe-2/1/0 {
      unit 0 {
      family inet {
      address 10.0.10.2/24; # Routing interface
      }
      }
      }
      irb {
      unit 0 {
      family inet {
      address 10.0.1.2/24 {
      vrrp-group 1 {
      virtual-address 10.0.1.51;
      priority 254;
      }
      }
      }
      }
      unit 1 {
      family inet {
      address 10.0.2.2/24 {
      vrrp-group 2 {
      virtual-address 10.0.2.51;
      priority 100;
      }
      }
      }
      }
      }
      }
      bridge-domains {
      vlan-100 {
      domain-type bridge;
      vlan-id 100;
      interface ge-2/2/2.100;
      interface ae1.100;
      interface ae3.100
      routing-interface irb.0;
      }
      vlan-200 {
      domain-type bridge;
      vlan-id 200;
      interface ge-3/3/3.200;
      interface ae1.200;
      interface ae3.200
      routing-interface irb.1;
      }
      }
    2. Configure the router link and IRB on Router 3:

      [edit]
      interfaces {
      xe-1/1/0 {
      unit 0 {
      family inet {
      address 10.0.20.3/24; # Routing interface
      }
      }
      }
      irb {
      unit 0 {
      family inet {
      address 10.0.1.3/24 {
      vrrp-group 1 {
      virtual-address 10.0.1.51;
      priority 100;
      }
      }
      }
      }
      unit 1 {
      family inet {
      address 10.0.2.3/24 {
      vrrp-group 2 {
      virtual-address 10.0.2.51;
      priority 254;
      }
      }
      }
      }
      unit 2 {
      family inet {
      address 10.0.3.2/24 {
      }
      }
      unit 3 {
      family inet {
      address 10.0.3.3/24 {
      }
      }
      unit 4 {
      family inet {
      address 10.0.3.4/24 {
      }
      }
      unit 5 {
      family inet {
      address 10.0.3.5/24 {
      }
      }
      unit 6 {
      family inet {
      address 10.0.3.6/24 {
      }
      }
      unit 7 {
      family inet {
      address 10.0.3.7/24 {
      }
      }
      unit 8 {
      family inet {
      address 10.0.3.8/24 {
      }
      }
      }
      }
      bridge-domains {
      vlan-100 {
      domain-type bridge;
      vlan-id 100;
      interface ge-2/2/2.100;
      interface ae2.100;
      interface ae3.100;
      routing-interface irb.0;
      }
      vlan-200 {
      domain-type bridge;
      vlan-id 200;
      interface ge-3/3/3.200;
      interface ae2.200;
      interface ae3.200;
      routing-interface irb.1;
      }
      vlan201 {
      vlan-id 201;
      routing-interface irb.2
      }
      vlan202 {
      vlan-id 202;
      routing-interface irb.3
      }
      vlan203 {
      vlan-id 203;
      routing-interface irb.4
      }
      vlan204 {
      vlan-id 204;
      routing-interface irb.5
      }
      vlan205 {
      vlan-id 205;
      routing-interface irb.6
      }
      }

    Modified: 2017-08-31