Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Example: Configuring Remote LFA over LDP Tunnels in OSPF Networks

    In an OSPF network, a loop free alternate(LFA) is a directly connected neighbor that provides precomputed backup paths to the destinations reachable through the protected link on the point of local repair (PLR). A remote LFA is not directly connected to the PLR and provides precomputed backup paths using dynamically created LDP tunnels to the remote LFA node. The PLR uses this remote LFA backup path when the primary link fails. The primary goal of the remote LFA is to increase backup coverage for the OSPF networks and provide protection for Layer 1 metro-rings. This example shows how to configure remote LFA for LDP tunnels in an OSPF network for extending backup protection.

    Requirements

    This example uses the following hardware and software components:

    • One ACX5000 router and eight other routers with OSPF protocol and LDP enabled on the connected interfaces.
    • Junos OS Release 15.1X54–D60 running on ACX5000 routers.
    • Junos OS Release 14.2 or later running on other supporting devices.

    Before you configure remote LFA over LDP tunnels in an OSPF networks, make sure of the following:

    • LDP is enabled on the loopback interface. Without a loopback interface, LDP targeted adjacency cannot be formed. Remote LFA cannot be configured without LDP targeted adjacency.
    • Remote LFA must allow asymmetric remote neighbor discovery—that is, it must send periodic targeted hello messages to the router that initiated the remote neighbor for LDP auto targeted adjacency.
    • Link protection or node-link protection must be configured on the point of local repair (PLR).

    Overview

    The example includes one ACX5000 router and eight other routers in a ring topology. Configure the OSPF protocol on the directly connected interfaces. Device R0 is the ACX5000 router and Device R6 is the PLR. This example verifies that Junos OS updates the routing table of Device R6 with LDP next-hop routes as the backup route.

    Topology

    In the topology Figure 1 shows the remote LFA over LDP tunnels in OSPF networks is configured on Device R6.

    Figure 1: Example Remote LFA over LDP Tunnels

    Example Remote LFA over LDP Tunnels

    Configuration

    CLI Quick Configuration

    To quickly configure this example, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

    R0

    set interfaces ge-0/0/0 unit 0 family inet address 10.1.1.1/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 90.1.1.1/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces ge-0/0/2 unit 0 family inet address 110.1.1.1/24
    set interfaces ge-0/0/2 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 1.1.1.1/32
    set interfaces lo0 unit 0 family mpls
    set routing-options static route 88.88.88.88/32 discard
    set routing-options router-id 1.1.1.1
    set routing-options forwarding-table export per-packet
    set protocols mpls interface ge-0/0/0.0
    set protocols mpls interface ge-0/0/1.0
    set protocols mpls interface ge-0/0/2.0
    set protocols mpls interface lo0.0
    set protocols ospf backup-spf-options remote-backup-calculation
    set protocols ospf export static
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp auto-targeted-session teardown-delay 20
    set protocols ldp auto-targeted-session maximum-sessions 60
    set protocols ldp egress-policy static
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface ge-0/0/1.0
    set protocols ldp interface ge-0/0/2.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept
    set policy-options policy-statement static from protocol static
    set policy-options policy-statement static then accept

    R1

    set interfaces ge-0/0/0 unit 0 family inet address 10.1.1.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 20.1.1.1/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces ge-0/0/2 unit 0 family inet address 80.1.1.1/24
    set interfaces ge-0/0/2 unit 0 family mpls
    set interfaces ge-0/0/3 unit 0 family inet address 100.1.1.1/24
    set interfaces ge-0/0/3 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 2.2.2.2/32
    set interfaces lo0 unit 0 family mpls
    set routing-options router-id 2.2.2.2
    set routing-options forwarding-table export per-packet
    set protocols ospf backup-spf-options remote-backup-calculation
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/2.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0 link-protection
    set protocols ospf area 0.0.0.0 interface ge-0/0/3.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp auto-targeted-session teardown-delay 20
    set protocols ldp auto-targeted-session maximum-sessions 60
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface ge-0/0/1.0
    set protocols ldp interface ge-0/0/2.0
    set protocols ldp interface ge-0/0/3.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept

    R2

    set interfaces ge-0/0/0 unit 0 family inet address 20.1.1.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 30.1.1.1/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces ge-0/0/2 unit 0 family inet address 110.1.1.1/24
    set interfaces ge-0/0/2 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 3.3.3.3/32
    set interfaces lo0 unit 0 family mpls
    set protocols ospf area 0.0.0.0 interface all
    set protocols ospf area 0.0.0.0 interface fxp0.0 disable
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept

    R3

    set interfaces ge-0/0/0 unit 0 family inet address 30.1.1.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 40.1.1.1/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 4.4.4.4/32
    set interfaces lo0 unit 0 family mpls
    set routing-options router-id 4.4.4.4
    set routing-options forwarding-table export per-packet
    set protocols ospf backup-spf-options remote-backup-calculation
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp auto-targeted-session teardown-delay 20
    set protocols ldp auto-targeted-session maximum-sessions 60
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface ge-0/0/1.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept

    R4

    set interfaces ge-0/0/0 unit 0 family inet address 40.1.1.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 50.1.1.1/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 5.5.5.5/32
    set interfaces lo0 unit 0 family mpls
    set routing-options router-id 5.5.5.5
    set routing-options forwarding-table export per-packet
    set protocols ospf backup-spf-options remote-backup-calculation
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp auto-targeted-session teardown-delay 60
    set protocols ldp auto-targeted-session maximum-sessions 20
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface ge-0/0/1.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept

    R5

    set interfaces ge-0/0/0 unit 0 family inet address 50.1.1.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 60.1.1.1/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 6.6.6.6/32
    set interfaces lo0 unit 0 family mpls
    set routing-options router-id 6.6.6.6
    set routing-options forwarding-table export per-packet
    set protocols ospf backup-spf-options remote-backup-calculation
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp auto-targeted-session teardown-delay 20
    set protocols ldp auto-targeted-session maximum-sessions 60
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface ge-0/0/1.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept

    R6

    set interfaces ge-0/0/0 unit 0 family inet address 60.1.1.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 70.1.1.1/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces ge-0/0/2 unit 0 family inet address 80.1.1.2/24
    set interfaces ge-0/0/2 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 7.7.7.7/32
    set interfaces lo0 unit 0 family mpls
    set routing-options router-id 7.7.7.7
    set routing-options forwarding-table export per-packet
    set protocols ospf topology default backup-spf-options remote-backup-calculation
    set protocols ospf backup-spf-options remote-backup-calculation
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0 link-protection
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0 link-protection
    set protocols ospf area 0.0.0.0 interface ge-0/0/2.0 link-protection
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp auto-targeted-session teardown-delay 20
    set protocols ldp auto-targeted-session maximum-sessions 60
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface ge-0/0/1.0
    set protocols ldp interface ge-0/0/2.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept

    R7

    set interfaces ge-0/0/0 unit 0 family inet address 70.1.1.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 8.8.8.8/32
    set interfaces lo0 unit 0 family mpls
    set routing-options router-id 8.8.8.8
    set routing-options forwarding-table export per-packet
    set protocols mpls interface ge-0/0/0.0
    set protocols mpls interface lo0.0
    set protocols ospf backup-spf-options remote-backup-calculation
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp auto-targeted-session teardown-delay 20
    set protocols ldp auto-targeted-session maximum-sessions 60
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept

    R8

    set interfaces ge-0/0/0 unit 0 family inet address 90.1.1.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 100.1.1.2/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 9.9.9.9/32
    set interfaces lo0 unit 0 family mpls
    set routing-options router-id 9.9.9.9
    set routing-options forwarding-table export per-packet
    set protocols mpls interface ge-0/0/0.0
    set protocols mpls interface ge-0/0/1.0
    set protocols mpls interface lo0.0
    set protocols ospf backup-spf-options remote-backup-calculation
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp auto-targeted-session teardown-delay 20
    set protocols ldp auto-targeted-session maximum-sessions 60
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface ge-0/0/1.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement per-packet then load-balance per-packet
    set policy-options policy-statement per-packet then accept

    Configuring Device R6

    Step-by-Step Procedure

    The following example requires that you navigate various levels in the configuration hierarchy. For information about navigating the CLI, see Using the CLI Editor in Configuration Mode in the CLI User Guide.

    To configure Device R6:

    1. Configure the interfaces.
      [edit interfaces]
      user@R6# set ge-0/0/0 unit 0 family inet address 60.1.1.2/24
      user@R6# set ge-0/0/0 unit 0 family mpls
      user@R6# set ge-0/0/1 unit 0 family inet address 70.1.1.1/24
      user@R6# set ge-0/0/1 unit 0 family mpls
      user@R6# set ge-0/0/2 unit 0 family inet address 80.1.1.2/24
      user@R6# set ge-0/0/2 unit 0 family mpls
    2. Assign the loopback addresses to the device.
      [edit lo0 unit 0 family]
      user@R6# set address 7.7.7.7/32
      user@R6# set mpls
    3. Configure the router ID. Apply the policy to the forwarding table of the local router with the export statement.
      [edit routing-options]
      user@R6# set router-id 7.7.7.7
      user@R6# set forwarding-table export per-packet
    4. Enable remote LFA backup, which calculates the backup next hop using dynamic LDP label-switched path.
      [edit protocols ospf]
      user@R6# set topology default backup-spf-options remote-backup-calculation
      user@R6# set backup-spf-options remote-backup-calculation
    5. Configure the traffic engineering and the link protection for the interfaces in the OSPF area.
      [edit protocols ospf]
      user@R6# set traffic-engineering
      user@R6# set area 0.0.0.0 interface ge-0/0/0.0 link-protection
      user@R6# set area 0.0.0.0 interface ge-0/0/1.0 link-protection
      user@R6# set area 0.0.0.0 interface ge-0/0/2.0 link-protection
      user@R6# set area 0.0.0.0 interface lo0.0
    6. Specify a time interval for which the targeted LDP sessions are kept up when the remote LFA goes down, and specify a maximum number of automatically, targeted LDP sessions to optimize the use of memory.
      [edit protocols ldp]
      user@R6# set auto-targeted-session teardown-delay 20
      user@R6# set auto-targeted-session maximum-sessions 60
    7. Configure the LDP protocols on the interfaces.
      [edit protocols ldp]
      user@R6# set interface ge-0/0/0.0
      user@R6# set interface ge-0/0/1.0
      user@R6# set interface ge-0/0/2.0
      user@R6# set interface lo0.0
    8. Configure the policy options to load-balance the per-packet of the policy-statement routing policy.
      [edit policy-options policy-statement]
      user@R6# set per-packet then load-balance per-packet
      user@R6# set per-packet then accept

    Results

    From configuration mode, confirm your configuration by entering the show interfaces, show protocols, show policy-options, and show routing-options commands. If the output does not display the intended configuration, repeat the instructions in this example to correct the configuration.

    user@R6# show interfaces
    ge-0/0/0 {
    unit 0 {
    family inet {
    address 60.1.1.2/24;
    }
    family mpls;
    }
    }
    ge-0/0/1 {
    unit 0 {
    family inet {
    address 70.1.1.1/24;
    }
    family mpls;
    }
    }
    ge-0/0/2 {
    unit 0 {
    family inet {
    address 80.1.1.2/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 0 {
    family inet {
    address 7.7.7.7/32;
    }
    family mpls;
    }
    }
    user@R6# show protocols
    ospf {
    topology default {
    backup-spf-options {
    remote-backup-calculation;
    }
    }
    backup-spf-options {
    remote-backup-calculation;
    inactive: per-prefix-calculation all;
    }
    traffic-engineering;
    area 0.0.0.0 {
    interface ge-0/0/0.0 {
    link-protection;
    }
    interface ge-0/0/1.0 {
    link-protection;
    }
    interface ge-0/0/2.0 {
    link-protection;
    }
    interface lo0.0;
    }
    }
    ldp {
    auto-targeted-session {
    teardown-delay 20;
    maximum-sessions 60;
    }
    interface ge-0/0/0.0;
    interface ge-0/0/1.0;
    interface ge-0/0/2.0;
    interface lo0.0;
    }
    user@R6# show policy-options
    policy-statement per-packet {
    then {
    load-balance per-packet;
    accept;
    }
    }
    user@R6# show routing-options
    router-id 7.7.7.7;
    forwarding-table {
    export per-packet;
    }

    If you are done configuring the device, enter commit from the configuration mode.

    Verification

    Confirm that the configuration is working properly.

    Verifying the Routes

    Purpose

    Verify that the expected routes are learned.

    Action

    On Device R6, from operational mode, run the show route 6.6.6.6/24 command to display the routes in the routing table.

    user@R6> show route 6.6.6.6/24
    inet.0: 75 destinations, 75 routes (75 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    6.6.6.6/32         *[OSPF/10] 02:21:07, metric 1
                        > to 60.1.1.1 via ge-0/0/0.0
                          to 80.1.1.1 via ge-0/0/2.0, Push 299872
    
    inet.3: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    6.6.6.6/32         *[LDP/9] 02:21:07, metric 1
                        > to 60.1.1.1 via ge-0/0/0.0
                          to 80.1.1.1 via ge-0/0/2.0, Push 299792, Push 299872(top)
    inet.0: 75 destinations, 75 routes (75 active, 0 holddown, 0 hidden)
    6.6.6.6/32 (1 entry, 1 announced)
            State: <FlashAll>
            *OSPF   Preference: 10
                    Next hop type: Router, Next hop index: 1048585
                    Address: 0x9df2690
                    Next-hop reference count: 10
                    Next hop: 60.1.1.1 via ge-0/0/0.0 weight 0x1, selected
                    Session Id: 0x141
                    Next hop: 80.1.1.1 via ge-0/0/2.0 weight 0x101 uflags Remote neighbor path
                    Label operation: Push 299872
                    Label TTL action: prop-ttl
                    Load balance label: Label 299872: None; 
                    Label element ptr: 0x9dc27a0
                    Label parent element ptr: 0x0
                    Label element references: 6
                    Label element child references: 4
                    Label element lsp id: 0
                    Session Id: 0x142
                    State: <Active Int>
                    Age: 2:22:40    Metric: 1 
                    Validation State: unverified 
                    Area: 0.0.0.0
                    Task: OSPF
                    Announcement bits (2): 0-KRT 4-LDP 
                    AS path: I
    
    inet.3: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    
    6.6.6.6/32 (1 entry, 1 announced)
    State: <FlashAll>
            *LDP    Preference: 9
                    Next hop type: Router, Next hop index: 0
                    Address: 0x9df2a90
                    Next-hop reference count: 1
                    Next hop: 60.1.1.1 via ge-0/0/0.0 weight 0x1, selected
                    Label element ptr: 0x9dc0dc0
                    Label parent element ptr: 0x0
                    Label element references: 1
                    Label element child references: 0
                    Label element lsp id: 0
                    Session Id: 0x0
                    Next hop: 80.1.1.1 via ge-0/0/2.0 weight 0x101 uflags Remote neighbor path
                    Label operation: Push 299792, Push 299872(top)
                    Label TTL action: prop-ttl, prop-ttl(top)
                    Load balance label: Label 299792: None; Label 299872: None; 
                    Label element ptr: 0x9dc1ba0
                    Label parent element ptr: 0x9dc27a0
                    Label element references: 1
                    Label element child references: 0
                    Label element lsp id: 0
                    Session Id: 0x0
                    State: <Active Int>
                    Age: 2:22:40    Metric: 1 
                    Validation State: unverified 
                    Task: LDP               
                    Announcement bits (1): 0-Resolve tree 1 
                    AS path: I
    

    Meaning

    The output shows all the routes in the routing table of Device R6.

    Verifying the LDP Routes

    Purpose

    Verify the automatically targeted LDP routes.

    Action

    From operational mode, enter the show ldp session auto-targeted detail command.

    user@R6> show ldp session auto-targeted detail
      Address: 4.4.4.4, State: Operational, Connection: Open, Hold time: 28
      Session ID: 7.7.7.7:0--4.4.4.4:0
      Next keepalive in 8 seconds
      Active, Maximum PDU: 4096, Hold time: 30, Neighbor count: 1
      Neighbor types: auto-targeted
      Keepalive interval: 10, Connect retry interval: 1
      Local address: 7.7.7.7, Remote address: 4.4.4.4
      Up for 02:28:28
      Capabilities advertised: none
      Capabilities received: none
      Protection: disabled
      Session flags: none
      Local - Restart: disabled, Helper mode: enabled
      Remote - Restart: disabled, Helper mode: enabled
      Local maximum neighbor reconnect time: 120000 msec
      Local maximum neighbor recovery time: 240000 msec
      Local Label Advertisement mode: Downstream unsolicited
      Remote Label Advertisement mode: Downstream unsolicited
      Negotiated Label Advertisement mode: Downstream unsolicited
      MTU discovery: disabled
      Nonstop routing state: Not in sync
      Next-hop addresses received:
        4.4.4.4
        30.1.1.2
        40.1.1.1
        128.92.25.37

    Verifying the OSPF Routes

    Purpose

    Display all the LDP backup routes in the OSPF routing table of Device R6.

    Action

    On Device R6, from operational mode, run the show ospf route command to display the routes in the OSPF routing table.

    user@R6> show ospf route
    Topology default Route Table:
    
    Prefix             Path  Route      NH       Metric NextHop       Nexthop      
                       Type  Type       Type            Interface     Address/LSP
    1.1.1.1            Intra AS BR      IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    2.2.2.2            Intra Router     IP            1 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    4.4.4.4            Intra Router     IP            3 ge-0/0/0.0    60.1.1.1
                                                        ge-0/0/2.0    80.1.1.1
    5.5.5.5            Intra Router     IP            2 ge-0/0/0.0    60.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    6.6.6.6            Intra Router     IP            1 ge-0/0/0.0    60.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    8.8.8.8            Intra Router     IP            1 ge-0/0/1.0    70.1.1.2
    9.9.9.9            Intra Router     IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    128.92.21.22       Intra Router     IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    1.1.1.1/32         Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    2.2.2.2/32         Intra Network    IP            1 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    3.3.3.3/32         Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    4.4.4.4/32         Intra Network    IP            3 ge-0/0/0.0    60.1.1.1
                                                        ge-0/0/2.0    80.1.1.1
    5.5.5.5/32         Intra Network    IP            2 ge-0/0/0.0    60.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    6.6.6.6/32         Intra Network    IP            1 ge-0/0/0.0    60.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    7.7.7.7/32         Intra Network    IP            0 lo0.0
    8.8.8.8/32         Intra Network    IP            1 ge-0/0/1.0    70.1.1.2
    9.9.9.9/32         Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    10.1.1.0/24        Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    20.1.1.0/24        Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    30.1.1.0/24        Intra Network    IP            3 ge-0/0/2.0    80.1.1.1
                                        Bkup IP         ge-0/0/0.0    60.1.1.1
    40.1.1.0/24        Intra Network    IP            3 ge-0/0/0.0    60.1.1.1
                                        Bkup IP         ge-0/0/2.0    80.1.1.1
    50.1.1.0/24        Intra Network    IP            2 ge-0/0/0.0    60.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    60.1.1.0/24        Intra Network    IP            1 ge-0/0/0.0
    70.1.1.0/24        Intra Network    IP            1 ge-0/0/1.0
    80.1.1.0/24        Intra Network    IP            1 ge-0/0/2.0
    88.88.88.88/32     Ext2  Network    IP            0 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    90.1.1.0/24        Intra Network    IP            3 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    100.1.1.0/24       Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    110.1.1.0/24       Intra Network    IP            3 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    128.92.19.153/32   Intra Network    IP            1 ge-0/0/0.0    60.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    128.92.19.176/32   Intra Network    IP            0 lo0.0
    128.92.21.13/32    Intra Network    IP            1 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    128.92.21.22/32    Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    128.92.23.228/32   Intra Network    IP            1 ge-0/0/1.0    70.1.1.2
    128.92.25.37/32    Intra Network    IP            3 ge-0/0/0.0    60.1.1.1
                                                        ge-0/0/2.0    80.1.1.1
    128.92.25.196/32   Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    128.92.26.29/32    Intra Network    IP            2 ge-0/0/2.0    80.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4
    128.92.29.156/32   Intra Network    IP            2 ge-0/0/0.0    60.1.1.1
                                        Bkup LSP                      LDP->4.4.4.4

    Meaning

    The output shows all the LDP backup routes in the OSPF routing table of Device R6.

    Verifying the Designated Backup Path Node

    Purpose

    Display the remote LFA next hop determined for a given destination.

    Action

    From operational mode, enter the show ospf backup spf results command.

    user@R6> show ospf backup spf results
    Topology default results:
    
    Area 0.0.0.0 results:
    
    6.6.6.6
      Self to Destination Metric: 1
      Parent Node: 60.1.1.2
      Primary next-hop: ge-0/0/0.0 via 60.1.1.1
      Backup next-hop: LDP->4.4.4.4 via ge-0/0/2.0
      Backup Neighbor: 6.6.6.6 via: Direct
        Neighbor to Destination Metric: 0, Neighbor to Self Metric: 1
        Self to Neighbor Metric: 1, Backup preference: 0x0
        Not eligible, Reason: Primary next-hop link fate sharing
      Backup Neighbor: 2.2.2.2 via: Direct
        Neighbor to Destination Metric: 2, Neighbor to Self Metric: 1
        Self to Neighbor Metric: 1, Backup preference: 0x0
        Not eligible, Reason: Path loops
      Backup Neighbor: 8.8.8.8 via: Direct
        Neighbor to Destination Metric: 2, Neighbor to Self Metric: 1
        Self to Neighbor Metric: 1, Backup preference: 0x0
        Not eligible, Reason: Path loops
      Backup Neighbor: 4.4.4.4 via: LDP (LSP endpoint)
        Neighbor to Destination Metric: 2, Neighbor to Self Metric: 3
        Self to Neighbor Metric: 3, Backup preference: 0x0
        Eligible, Reason: Contributes backup next-hop

    Meaning

    The output indicates whether a specific interface or node has been designated as a remote backup path and why.

    Verifying the Backup Neighbors

    Purpose

    Display the backup neighbors for the Device R6

    Action

    From operational mode, enter the show ospf backup neighbor command.

    user@R6>show ospf backup neighbor
    Topology default backup neighbors:
    
    Area 0.0.0.0 backup neighbors:
    
    6.6.6.6 via: Direct
      Neighbor to Self Metric: 1
      Self to Neighbor Metric: 1
      Direct next-hop: ge-0/0/0.0 via 60.1.1.1
    
    8.8.8.8 via: Direct
      Neighbor to Self Metric: 1
      Self to Neighbor Metric: 1
      Direct next-hop: ge-0/0/1.0 via 70.1.1.2
    
    2.2.2.2 via: Direct
      Neighbor to Self Metric: 1
      Self to Neighbor Metric: 1
      Direct next-hop: ge-0/0/2.0 via 80.1.1.1
    
    4.4.4.4 via: LDP (LSP endpoint)
      Neighbor to Self Metric: 3
      Self to Neighbor Metric: 3
      Direct next-hop: LDP->4.4.4.4 via ge-0/0/2.0
      Direct next-hop: LDP->4.4.4.4 via ge-0/0/0.0
      Neighbors Protected: 2

    Meaning

    The output displays the backup neighbors available for area 0.0.0.0.

    Modified: 2017-03-08