Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Example: Configuring Aggregated Ethernet Device with LAG and LACP (CLI Procedure)

    Requirements

    No special configuration beyond device initialization is required before configuring this feature.

    Overview

    This example shows the configuration of aggregated Ethernet (ae) devices with LAG and LACP.

    Configuration

    Step-by-Step Procedure

    To configure LAG:

    1. Configure the number of aggregated Ethernet interfaces with LAG interface that you need to create. Set the device-count option to 5.
      [edit]user@host# set chassis aggregated-devices ethernet device-count 5
    2. Add a port to the aggregated Ethernet interface with LAG.
      [edit]user@host# set interfaces ge-2/0/1 ether-options 802.3ad ae0user@host# set interfaces ge-2/0/2 ether-options 802.3ad ae0
    3. Configure LACP for the aggregated Ethernet interface with LAG.
      [edit]user@host# set interfaces ae0 aggregated-ether-options lacp active
    4. Configure family Ethernet switching for the aggregated Ethernet interface with LAG.
      [edit]user@host# set interfaces ae0 unit 0 family ethernet-switching
    5. Configure the VLAN vlan20 with VLAN ID 20.
      [edit]user@host# set vlans vlan20 vlan-id 20
    6. Add the aggregated Ethernet interface to the VLAN.
      [edit]user@host# set vlans vlan20 interface ae0
    7. Check the configuration by entering the show vlans and show interfaces commands
      user@host# show vlans
      vlan20 {
          vlan-id 20;
          interface {
              ae0.0;
          }
      }
      
      user@host# show interfaces
      ge-2/0/1 {
          ether-options {
              802.3ad ae0;
          }
      }
      ge-2/0/2 {
          ether-options {
              802.3ad ae0;
          }
      }
      ae0 {
          aggregated-ether-options {
              lacp {
                  active;
              }
          }
          unit 0 {
              family ethernet-switching;
          }
      }
      
    8. If you are done configuring the device, commit the configuration.
      [edit]user@host# commit

      Note: Likewise, you can configure other devices with LAG and LACP.

    Verification

    Verifying Aggregated Ethernet Interface with LAG and LACP

    Purpose

    Verify that you can configure aggregated Ethernet interfaces with LAG and LACP.

    Action

    From configuration mode, enter the show lacp interfaces to view the LACP interfaces.

    user@host# run show lacp interfaces
    Aggregated interface: ae0
        LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
          ge-2/0/1     Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
          ge-2/0/1   Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
          ge-2/0/2     Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
          ge-2/0/2   Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
        LACP protocol:        Receive State  Transmit State          Mux State
          ge-2/0/1                Current   Fast periodic Collecting distributing
          ge-2/0/2                Current   Fast periodic Collecting distributing
    

    From configuration mode, enter the show vlans command to view the VLAN interfaces.

    user@host# run show vlans
    Name           Tag     Interfaces
    default         1      None
    vlan20          20     ae0.0
    

    From configuration mode, enter the show interfaces (interface name) command to view the status of the ge-2/0/1 and ge-2/0/2 interfaces.

    user@host# run show interfaces ge-2/0/1 terse
    Interface               Admin Link Proto    Local                 Remote
    ge-2/0/1                up    up
    ge-2/0/1.0              up    up   aenet    --> ae0.0
    
    user@host# run show interfaces ge-2/0/2 terse
    Interface               Admin Link Proto    Local                 Remote
    ge-2/0/2                up    up
    ge-2/0/2.0              up    up   aenet    --> ae0.0
    

    Meaning

    The output shows the aggregated Ethernet Interface with LAG and LACP is configured.

    Modified: 2017-03-23