Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Troubleshooting Issues with Collecting JMBs

    Problem

    Description: Junos Space Service Now fails to collect JMBs.

    Symptoms: Service Now does not list any JMBs.

    Cause

    • Firewall rules on the device prevent Service Now from collecting JMBs.
    • AI-Scripts do not function properly.

    Resolution

    Setting Firewall Rules on the Device

    Service Now may not be able to collect JMBs from a device running Junos OS if the device does not allow traffic to the localhost address (127.0.0.1). Service Now uses the loopback interface on a device running Junos OS for collecting JMBs.

    Set the following firewall rules on the device running Junos OS for Service Now to communicate by using the loopback address:

    set firewall family inet filter scp-block term ais-scp from source-address 127.0.0.1/32
        set firewall family inet filter scp-block term ais-scp from destination-address 127.0.0.1/32
        set firewall family inet filter scp-block term ais-scp from protocol tcp
        set firewall family inet filter scp-block term ais-scp from port 22
        set firewall family inet filter scp-block term ais-scp then accept
        Router001# show firewall family inet filter scp-block term ais-scp
        from {
        source-address {
        127.0.0.1/32;
        }
        destination-address {
        127.0.0.1/32;
        }
        protocol tcp;
        port 22;
        }
        then accept;
    

    If you do not want to use the loopback address, modify the firewall family configuration to use the device's management IP address for collecting JMBs.

    Resolving an AI-Scripts Error

    Service Now might be unable to collect JMBs as a result of an AI-Scripts error. AI-Scripts errors are logged in the Junos OS system logs as AIS_DATA_AVAILABLE: ERROR: as follows:

    AIS_DATA_AVAILABLE: ERROR: rsi_done-timeout
    AIS_DATA_AVAILABLE: ERROR: waiting_on_slax-timeout
    

    The error may be caused by an issue in the Junos OS software (for example, a CLI command does not return the expected output) or can be due to an internal AI-Scripts error.

    To troubleshoot issues with JMB collection because of an AI-Scripts error:

    1. Log in to the device.
    2. Execute the following commands to obtain the relevant logs and files for troubleshooting:
      show log messages | match cscript
      show log escript.log
      show configuration groups juniper-ais | display commit-scripts | no-more
      show configuration system | display inheritance
      show version
      file list /var/db/scripts/op/ detail
      file list /var/tmp/ detail
      show system storage detail
      show system processes extensive | match csc
      start shell
      ps ax | grep ais exit
    3. After collecting the files, do the following:
      • Look for related events that occurred when or just before an AI-Scripts error message is generated in the system log output.
      • Look for SLAX errors logged during the execution of any of the event scripts in the escript.log file.
      • Examine the error messages in the error JMB files that may be created.
      • Save the collected files for further investigation.
      • For AI-Scripts versions earlier than AI-Scripts Release 4.0, execute the request support information command and store and note the size of the output created.
    4. During a maintenance window, uninstall the AI-Scripts package from the device.

      Note: You must uninstall AI-Scripts manually from the backup Routing Engines by using the request system scripts delete jais package name command, where jais package name is the name of the AI-Scripts package installed on the backup Routing Engine.

    5. Manually install the AI-Scripts package by using the request system scripts add /var/tmp/jais package name CLI command, where jais package name is the name of the AI-Scripts installation package. Save the output printed on the monitor.
    6. For AI-Scripts Release 4.1R1 and later, if Junos OS Release 14.1R1 or later is installed on the device, generate a health report JMB to obtain necessary information about the AI-Scripts error. To generate the health report JMB, execute the following command on the device running Junos OS:
      op ais-health-report job-ID job-id-number
      where, job-id-number is the number that you assign to the job.
    7. If you continue to receive error messages, open a case with your technical support representative to investigate the issue further. Provide the following information with the case:
      • All Junos OS CLI command output mentioned in Step 2
      • Any error JMB files that you received
      • Output when you manually installed AI-Scripts
      • Version of Junos Space and Service Now that you used

    Modified: 2017-06-08