Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Example: Base Configuration for N-PE Device in a Multipoint Service

    An N-PE device to be used in a multipoint service must have the following entities configured before you assign the N-PE role to the device:

    • Gigabit Ethernet interfaces to the network core
    • Loopback interface
    • Routing options
    • MPLS protocol
    • BGP protocol
    • OSPF protocol
    • LDP protocol

    The N-PE device in this configuration example has just one interface to the network core. In a more complex network in which the N-PE device connects to more than one P device, you need to configure multiple interfaces.

    interfaces {
        ge-0/0/0 {
            unit 0 {
                family inet {
                    address 10.1.22.2/30;
                }
                family mpls;
            }
        }
    
        }
        lo0 {
            unit 0 {
                family inet {
                    address 192.168.1.30/32;
                }
            }           
        }
    
    }
    routing-options {
        autonomous-system 65410;
    }
    protocols {
        mpls {
            interface ge-0/0/0.0;
            interface lo0.0;
        }
        bgp {
            group CA-Peer {
                type internal;
                local-address 192.168.1.30;
                family l2vpn {
                    signaling;
                }
                neighbor 192.168.1.40;
                neighbor 192.168.1.10;
                neighbor 192.168.1.20;
                neighbor 192.168.1.50;
                neighbor 192.168.1.60;
            }
        }
        ospf {
            traffic-engineering;
            area 0.0.0.0 {
                interface lo0.0 {
                    passive;
                }       
                interface ge-0/0/0.0;
        }
        ldp {
            interface ge-0/0/0.0;
            interface lo0.0;
        }
    }
    

    Modified: 2017-02-02