Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Example: Simple Unified Edge Configuration

    This example describes how to configure a simple unified edge, and consists of the following sections:

    Requirements

    This example requires the following hardware and software:

    • Hardware — MX240, MX480, or MX960 with MOB-MS-DPC
    • Software — Junos OS Release 11.2W or later

    Overview and Topology

    This example includes the following components:

    • SGSN (serving GPRS support node) — The SGSN is the gateway between the mobile user equipment and the core network in a GPRS/UMTS network. Signaling to or from this node is processed on interface ge-2/1/1.
    • GGSN (gateway GPRS support node)—The GGSN is responsible for interaction between the GPRS network and external packet-switched networks, such as the Internet. For the external network, the GGSN functions like a router to a subnetwork. The GGSN hides the GPRS infrastructure from the external network. The GGSN is the anchor point that enables the mobility of the user terminal in the GPRS/UMTS network. Its function in GPRS is similar to the home agent in Mobile IP. It maintains the routing necessary to tunnel the protocol data units (PDUs) to the SGSN that services a particular mobile station (MS). It also performs authentication, charging functions, QoS, and policy enforcement.
    • Connectivity from the user equipment to external packet data networks

    Table 1 shows the MobileNext Broadband Gateway components used in this solution.

    Table 1: Unified Edge — Simple Configuration

    Component

    Configuration

    Settings

    SGSN-facing interface

    ge–2/1/1

    200.6.1.1/24

    GGSN

    unified-edge ggsn-pgw gateway PGW

    gn interface lo0.0 v4-address 99.1.1.1 Loopback interface for receiving packets from the Packet Forwarding Engine.

    Mobility control plane

    ms-3/0/0

    Services PIC used for processing packets received from the Packet Forwarding Engine.

    Mobility control plane

    ms-3/1/0

    unit 16000—Unit required for outgoing packets.

    unit 0—One unit required for each APN destination.

    Mobile address assignment pool

    default-ipv4-address-pool

    network 29.0.0.0/8—Subnet for address assignment to user equipment.

    range r1—Named address range.

    low 29.0.0.1–Lowest address available.

    high 29.255.255.254—Highest address available.

    Configuration

    To configure a simple unified edge environment, perform the following tasks:

    Configuring the Hardware Components for Mobility

    CLI Quick Configuration

    To quickly configure the chassis for this example, copy the following commands and paste them into the router terminal window:

    [edit]load merge /etc/config/mobility-defaults.confset chassis fpc 2 forwarding-packages mobility ggsn-pgwset chassis fpc 3 pic 0 apply-groups mobilityset chassis fpc 3 pic 1 apply-groups mobility

    Step-by-Step Procedure

    To configure the chassis options that support the unified edge:

    1. Load and merge the default configuration file for the mobility group.
      [edit] user@host# load merge /etc/config/mobility-defaults.conf
    2. Configure the forwarding package at the FPC level.
      [edit] user@host# set chassis fpc 2 forwarding-packages mobility ggsn-pgw

      Note: You must include every Packet Forwarding Engine configured with the ggsn-pgw forwarding package at the [edit unified-edge gateways ggsn-pgw gateway-name system anchor-pfes] hierarchy level on the broadband gateway. If you do not specify the Packet Forwarding Engine as an anchor interface, then the Packet Forwarding Engine will not be used by the broadband gateway.

    3. Configure the mobility group for the services PICs that are processing the packets.
      [edit] user@host# set chassis fpc 3 pic 0 apply-groups mobility user@host# set chassis fpc 3 pic 1 apply-groups mobility

      Note: You must include every services PIC configured with the jservices-mobile package at the [edit unified-edge gateways ggsn-pgw gateway-name system anchor-spics] hierarchy level on the broadband gateway. If you do not include the services PIC as an anchor interface, then the services PIC will not be used by the broadband gateway.

    Results

    Check the results of the configuration:

    root@host> show configuration chassis
    fpc 2 {
        forwarding-packages {
            mobility ggsn-pgw;
        }
    }
    fpc 3 {
        pic 0 {
            adaptive-services {
                service-package {
                    extension-provider {
                        boot-os embedded-junos64;
                        control-cores 1;
                        data-pollers 1; 
                        object-cache-size 512;
                        package jservices-mobile;
                        total-wired-memory 14336;
                        wired-max-processes 8;
                        wired-process-memory-size 1024;
                    }
                }
            }
        }
        pic 1 {
            adaptive-services {
                service-package {
                    extension-provider {
                        boot-os embedded-junos64;
                        control-cores 1;
                        data-pollers 1;
                        object-cache-size 512;
                        package jservices-mobile;
                        total-wired-memory 14336;
                        wired-max-processes 8;
                        wired-process-memory-size 1024;
                    }
                }
            }
        }
    }
    

    Configuring the Interface to the Gn Side

    CLI Quick Configuration

    To quickly configure the interface to the Gn side (SGW/SGSN signaling), copy the following commands and paste them into the router terminal window:

    [edit interfaces ge-2/1/1]set description sgw-em0set unit 0 family inet address 200.6.1.1/24

    Step-by-Step Procedure

    To configure the interface to the SGSN (signaling) function:

    1. Identify the interface.
      user@host# edit interfaces ge-2/1/1[edit interfaces ge-2/1/1]
    2. Provide a description that identifies the function of the interface.
      [edit interfaces ge-2/1/1]user@host# set description sgw-em0
    3. Identify the unit and IP address for the interface.
      [edit interfaces ge-2/1/1]user@host# set unit 0 family inet address 200.6.1.1/24

    Results

    Check the results of the configuration:

    root@host> show configuration interfaces ge-2/1/1
    description sgw-em0;
    unit 0 {
        family inet {
            address 200.6.1.1/24;
        }
    }
    

    Configuring the Mobile Interface Units for Mobility Support

    CLI Quick Configuration

    To quickly configure the mobile interface units needed to process packets on the services PIC, copy the following commands and paste them into the router terminal window:

    [edit interfaces mif]edit interfaces mifset unit 0 family inetset unit 1 family inetset unit 2 family inetset unit 16000 family inet

    Step-by-Step Procedure

    To configure the mobile interface units used to process information packets on the services PIC:

    1. Access the mobile interface hierarchy.
      user@host# edit interfaces mif
    2. Assign one mobile interface for each access point name.
      [edit interfaces mif]user@host# edit interfaces mifuser@host# set unit 0 family inetuser@host# set unit 1 family inetuser@host# set unit 2 family inetuser@host# set unit 16000 family inet description "Reserved mobile interface"

    Results

    Check the results of the configuration:

    user@host# edit interfaces mif
    user@host# show
    unit 0 {
            family inet;
    }
    unit 1 {
            family inet;
    }
    unit 2 {
            family inet;
    }
    unit 16000 {
        description "Reserved mobile interface";
        family inet;
    }
    
    user@host# edit configuration interfaces ms-3/1/0
    user@host# show
    unit 16000 {
            family inet;
    }
    
    user@host# edit configuration interfaces mif
    user@host# show
    unit 0 {
        family inet;
    }
    unit 1 {
        family inet;
    unit 16000 {
        family inet;
    }

    Configuring the Address Pool for Assigning IP Addresses to the User Equipment

    CLI Quick Configuration

    To quickly configure the address pool for assigning IP addresses to the user equipment, copy the following commands and paste them into the router terminal window:

    [edit access address-assignment mobile-pools default-pool family inet network]user@host# set 29.0.0.0/8 range r1 low 29.0.0.1 high 29.255.255.254

    Step-by-Step Procedure

    To configure the address pool for assigning IP addresses to user equipment:

    1. Create a named pool.
      user@host# edit access address-assignment mobile-pools default-ipv4-address-pool
    2. Optionally, set the pool as the default pool.
      [edit access address assignment mobile-pools default-ipv4-address-pool ]user@host# set default-pool
    3. Set the network address for the pool and a range of available addresses.
      [edit access address assignment mobile-pools default-ipv4-address-pool ]user@host# set family inet network 29.0.0.0/8 range r1 low 29.0.0.1 high 29.255.255.254

    Results

    Check the results of the configuration:

    user@host# edit access
    user@host# show
    access {
        address-assignment {
            mobile-pools {
                default-ipv4-address-pool  {                   
                    family inet {
                        network {
                            29.0.0.0/8 {
                                range {
             	                       r1 {
                                        low 29.0.0.1;
                                        high 29.255.255.254;
                                    }
                                }
                            }
                        }
                    }
                    default-pool;
                }
            }
        }
    }
    

    Configuring the GGSN Parameters

    CLI Quick Configuration

    To quickly configure the GGSN parameters, copy the following statements and paste them into the router terminal window:

    [edit unified-edge gateways ggsn-pgw PGW]set home-plmn mcc 421 mnc 342edit gtpset gn interface lo0.0 v4-address 99.1.1.1

    Step-by-Step Procedure

    To define a broadband gateway GTP configuration, from the customer edge to the provider network:

    1. Define the broadband gateway as P-GW.
      user@host# edit unified-edge gateways ggsn-pgw PGW
    2. Define the home public land mobile network (HPLMN), mobile country code (MCC), and mobile network code (MNC).
      [edit unified-edge gateways ggsn-pgw PGW]user@host# set home-plmn mcc 421 mnc 342
    3. Configure the GTP settings.
      user@host# edit unified-edge gateways ggsn-pgw PGW gtp
    4. Configure the Gn interface for receiving GTP-C and GTP-U packets on the GGSN to use the loopback interface and IP address specified.
      [edit unified-edge gateways ggsn-pgw PGW gtp ]user@host# set gn interface lo0.0 v4-address 99.1.1.1

    Results

    Check the results of the configuration:

    user@host# edit unified-edge
    user@host# show
    unified-edge {
        mobile-gateways {
            gateway PGW {
                gtp {
                    path-management disable;
                    gn {                    
                        interface lo0.0 v4-address 99.1.1.1;
                    }
                    traceoptions {
                        file gtp_local size 1m;
                        level all;
                        flag all;
                    }
                }
                home-plmn mcc 421 mnc 342;
    

    Verification

    To confirm that the configuration is working properly, perform the following tasks:

    Verifying the Mobile Address Pool

    Purpose

    Verify the mobile pool address assignments.

    Action

    user@host# show access address-assignment mobile-pools default-ipv4-address-pool
    family inet {
        network {
            29.0.0.0/8 {
                range {
                    r1 {
                        low 29.0.0.1;
                        high 29.255.255.254;
                    }
                }
            }
        }
    }
    default-pool;

    Meaning

    The output shows the subnet and available address ranges for the mobile pool.

    Verifying the Gateway Configuration

    Purpose

    Verify the configuration of the GGSN/P-GW gateways.

    Action

    user@host# show unified-edge gateways
    ggsn-pgw PGW {
        gtp {
             path-management disable;
            gn {
                interface lo0.0 v4-address 200.6.88.1;            
            }
            s5 {
                interface lo0.0 v4-address 200.6.88.1;
            }
                }
        home-plmn {
            inactive: mcc 365 mnc 840;
            inactive: mcc 365 mnc 84;
            mcc 421 mnc 342;
    

    Published: 2011-11-16