Appendix


p1.ewr
## Last changed: 2019-03-23 04:55:54 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30; inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.5;
autonomous-system 4200000000 asdot-notation;
}
}
IGP {
protocols {
isis {
level 1 disable;
level 2 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
level 1 disable;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/1.0 {
point-to-point;
level 2 metric 999999;
}
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 5;
ipv6-index 65;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.5;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-transit-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/transit/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 DNS RR IGP MPLS INFRA_INTERFACES RSVP-TE LOGGING SR
IN-BAND PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES TELEMETRY ];
p1.iad
## Last changed: 2019-03-22 14:51:27 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.9;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.9;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
cluster 128.49.106.9;
allow 128.49.106.0/24;
neighbor 128.49.106.3 {
description p1.nyc;
}
neighbor 128.49.106.2 {
description p2.nyc;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [
em0.0 fxp0.0 ];
then reject;
}
term LOCAL-LOOPBACK {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-/128;
}
then {
tag 1111;
accept;
}
}
term L1-TO-L2 {
from {
protocol isis;
level 1;
tag 1111;
}
to level 2;
then accept;
}
term L2-TO-L1 {
from {
protocol isis;
level 2;
tag 1111;
}
to level 1;
then accept;
}
then reject;
}
}
protocols {
isis {
level 2 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/1.0 {
point-to-point;
level 2 metric 999999;
}
export ISIS-EXPORT;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 9;
ipv6-index 69;
}
}
}
}
}
LSP {
protocols {
mpls {
label-switched-path p1.nyc:0 {
to 128.49.106.3;
}
label-switched-path p2.nyc:0 {
to 128.49.106.2;
}
label-history;
}
}
}
LSP-ATTRIBUTES {
protocols {
mpls {
label-switched-path <*> {
ldp-tunneling;
record;
oam {
bfd-liveness-detection {
minimum-interval 20000;
minimum-receive-interval 20000;
multiplier 3;
}
}
node-link-protection;
adaptive;
}
}
}
}
FA {
protocols {
isis {
label-switched-path p1.nyc:0 {
level 2 disable;
}
label-switched-path p2.nyc:0 {
level 2 disable;
}
}
}
}
ISIS-OVERLOAD {
protocols {
isis {
overload;
}
}
}
SR-O-RSVP {
protocols {
isis {
traffic-engineering {
family inet-mpls {
shortcuts;
}
}
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:9;
cluster 128.49.106.9;
allow 2001:db8:0:0:128:49:106::/112;
}
}
}
}
SR-O-RSVP_v6 {
protocols {
isis {
traffic-engineering {
family inet6-mpls {
shortcuts;
}
}
}
}
}
LSP-HIGH-METRIC {
protocols {
mpls {
label-switched-path <*:0> {
metric 16777215;
}
}
}
}
BGP-LS {
policy-options {
policy-statement NLRI-TO-BGP-LS {
term 1 {
from family traffic-engineering;
then accept;
}
}
policy-statement TED-TO-NLRI {
term LEVEL-1 {
from {
protocol isis;
level 1;
}
then accept;
}
term LEVEL-2 {
from {
protocol isis;
level 2;
}
then accept;
}
}
}
protocols {
isis {
traffic-engineering {
inactive: igp-topology;
}
}
mpls {
traffic-engineering {
database {
import {
igp-topology {
inactive: bgp-link-state;
}
policy TED-TO-NLRI;
}
}
}
}
bgp {
group NORTHSTAR {
type internal;
local-address 192.168.88.9;
family traffic-engineering {
unicast;
}
export NLRI-TO-BGP-LS;
neighbor 192.168.88.99;
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.9;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-transit-lsp {
server-name ns-lsp; export-name ns;
resource /junos/services/segment-routing/traffic-engineering/transit/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
PCEP {
protocols {
mpls {
lsp-external-controller pccd;
}
source-packet-routing {
lsp-external-controller pccd;
telemetry {
statistics;
}
}
pcep {
pce NORTHSTAR {
local-address 192.168.88.9;
destination-ipv4-address 192.168.88.100;
destination-port 4189;
pce-type active stateful;
lsp-provisioning;
spring-capability;
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 DNS RR IGP MPLS INFRA_INTERFACES RSVP-TE LSP-ATTRIBUTES
FA LOGGING SR SR-O-RSVP RR_v6 SR-O-RSVP_v6 LSP-HIGH-METRIC IN-BAND
BGP-LS TELEMETRY PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES PCEP
];
p1.nyc
## Last changed: 2019-03-23 04:54:48 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.3;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.3;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
cluster 128.49.106.3;
allow 128.49.106.0/24;
neighbor 128.49.106.9 {
description p1.iad;
}
neighbor 128.49.106.8 {
description p2.iad;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [
em0.0 fxp0.0 ];
then reject;
}
term LOCAL-LOOPBACK {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-/128;
}
then {
tag 1111;
accept;
}
}
term L1-TO-L2 {
from {
protocol isis;
level 1;
tag 1111;
}
to level 2;
then accept;
}
term L2-TO-L1 {
from {
protocol isis;
level 2;
tag 1111;
}
to level 1;
then accept;
}
then reject;
}
}
protocols {
isis {
level 2 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/1.0 {
point-to-point;
level 2 metric 999999;
}
export ISIS-EXPORT;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 3;
ipv6-index 63;
}
}
level 1 labeled-preference 8;
}
}
}
LSP-ATTRIBUTES {
protocols {
mpls {
label-switched-path <*> {
ldp-tunneling;
record;
oam {
bfd-liveness-detection {
minimum-interval 20000;
minimum-receive-interval 20000;
multiplier 3;
}
}
node-link-protection;
adaptive;
}
}
}
}
LSP-IAD {
protocols {
mpls {
label-switched-path p1.iad:0 {
to 128.49.106.9;
}
label-switched-path p2.iad:0 {
to 128.49.106.8;
}
}
}
}
FA {
protocols {
isis {
label-switched-path p1.iad:0 {
level 2 disable;
}
label-switched-path p2.iad:0 {
level 2 disable;
}
}
}
}
SRMS {
routing-options {
source-packet-routing {
mapping-server-entry srms.p1 {
prefix-segment-range 128.49.106/24 {
start-prefix 128.49.106.10/32;
start-index 10;
size 4;
}
}
}
}
protocols {
isis {
source-packet-routing mapping-server srms.p1;
}
}
}
SRMC {
protocols {
isis {
source-packet-routing ldp-stitching;
}
}
}
LDP-SR-STITCHING {
protocols {
ldp {
sr-mapping-client;
}
}
}
LSP-ATTRIBUTES-AUTOBW {
protocols {
mpls {
statistics {
auto-bandwidth;
}
label-switched-path <*> {
auto-bandwidth {
adjust-interval 300;
adjust-threshold 1;
adjust-threshold-absolute 100;
adjust-threshold-activate-bandwidth 1k;
maximum-bandwidth 1m;
adjust-threshold-overflow-limit 3;
adjust-threshold-underflow-limit 3;
resignal-minimum-bandwidth;
}
}
}
}
}
SR-O-RSVP {
protocols {
isis {
traffic-engineering {
family inet-mpls {
shortcuts;
}
}
}
}
}
LSP-HIGH-METRIC {
protocols {
mpls {
label-switched-path <*:0> {
metric 16777215;
}
}
}
}
LSP-EWR {
protocols {
mpls {
label-switched-path p1.ewr:0 {
to 128.49.106.5;
}
label-switched-path p2.ewr:0 {
to 128.49.106.4;
}
}
}
}
LSP-PHL {
protocols {
mpls {
label-switched-path p1.phl:0 {
to 128.49.106.7;
}
label-switched-path p2.phl:0 {
to 128.49.106.6;
}
}
}
}
SR-RSVP-BDARK {
interfaces {
"<ge-0/0/[1-9]>" {
unit <*> {
bandwidth 100k;
}
}
}
routing-options {
auto-bandwidth {
template {
SR-RSVP-COEXIST {
adjust-interval 30;
adjust-threshold 1;
statistic-collection-interval 10;
}
}
}
}
protocols {
isis {
source-packet-routing {
traffic-statistics {
statistics-granularity per-interface;
auto-bandwidth SR-RSVP-COEXIST;
}
}
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:3;
cluster 128.49.106.3;
allow 2001:db8:0:0:128:49:106::/112;
neighbor 2001:db8::128:49:106:9 {
description p1.iad;
}
neighbor 2001:db8::128:49:106:8 {
description p2.iad;
}
}
}
}
}
SR-O-RSVP_v6 {
protocols {
isis {
traffic-engineering {
family inet6-mpls {
shortcuts;
}
}
}
}
}
PCEP {
protocols {
mpls {
lsp-external-controller pccd;
}
source-packet-routing {
lsp-external-controller pccd;
telemetry {
statistics;
}
}
pcep {
pce NORTHSTAR {
local-address 192.168.88.3;
destination-ipv4-address 192.168.88.100;
destination-port 4189;
pce-type active stateful;
lsp-provisioning;
spring-capability;
}
}
}
}
BGP-LS {
policy-options {
policy-statement NLRI-TO-BGP-LS {
term 1 {
from family traffic-engineering;
then accept;
}
}
policy-statement TED-TO-NLRI {
term LEVEL-1 {
from {
protocol isis;
level 1;
}
then accept;
}
term LEVEL-2 {
from {
protocol isis;
level 2;
}
then accept;
}
}
}
protocols {
isis {
traffic-engineering {
inactive: igp-topology;
}
}
mpls {
traffic-engineering {
database {
import {
igp-topology {
inactive: bgp-link-state;
}
policy TED-TO-NLRI;
}
}
}
}
bgp {
group NORTHSTAR {
type internal;
local-address 192.168.88.3;
family traffic-engineering {
unicast;
}
export NLRI-TO-BGP-LS;
neighbor 192.168.88.99;
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.3;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-transit-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/transit/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 DNS RR IGP INFRA_INTERFACES MPLS RSVP-TE LSP-ATTRIBUTES
FA SR LSP-ATTRIBUTES-AUTOBW LOGGING SR-O-RSVP LSP-HIGH-METRIC LSP-EWR
LSP-PHL SR-RSVP-BDARK RR_v6 SR-O-RSVP_v6 IN-BAND PCEP BGP-LS PKI TI-LFA-NODE-PROTECT
SR-TE-COLORED-ROUTES TELEMETRY ];
p1.phl
## Last changed: 2019-03-22 14:51:27 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30; inactive:
skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.7;
autonomous-system 4200000000 asdot-notation;
}
}
IGP {
protocols {
isis {
level 1 disable;
level 2 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
level 1 disable;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/1.0 {
point-to-point;
level 2 metric 999999;
}
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 7;
ipv6-index 67;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.7;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-transit-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/transit/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 DNS RR IGP MPLS INFRA_INTERFACES RSVP-TE LOGGING SR
IN-BAND PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES TELEMETRY ];
p2.ewr
## Last changed: 2019-03-22 14:51:27 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30; inactive:
skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.4;
autonomous-system 4200000000 asdot-notation;
}
}
IGP {
protocols {
isis {
level 1 disable;
level 2 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
level 1 disable;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/1.0 {
point-to-point;
level 2 metric 999999;
}
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 4;
ipv6-index 64;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.4;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-transit-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/transit/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 DNS RR IGP MPLS INFRA_INTERFACES RSVP-TE LOGGING SR
IN-BAND PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES TELEMETRY ];
p2.iad
## Last changed: 2019-03-22 14:51:26 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.8;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.8;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
cluster 128.49.106.8;
allow 128.49.106.0/24;
neighbor 128.49.106.3 {
description p1.nyc;
}
neighbor 128.49.106.2 {
description p2.nyc;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [ em0.0 fxp0.0 ];
then reject;
}
term LOCAL-LOOPBACK {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-/128;
}
then {
tag 1111;
accept;
}
}
term L1-TO-L2 {
from {
protocol isis;
level 1;
tag 1111;
}
to level 2;
then accept;
}
term L2-TO-L1 {
from {
protocol isis;
level 2;
tag 1111;
}
to level 1;
then accept;
}
then reject;
}
}
protocols {
isis {
level 2 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/1.0 {
point-to-point;
level 2 metric 999999;
}
export ISIS-EXPORT;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 8;
ipv6-index 68;
}
}
}
}
}
LSP {
protocols {
mpls {
label-switched-path p1.nyc:0 {
to 128.49.106.3;
}
label-switched-path p2.nyc:0 {
to 128.49.106.2;
}
label-history;
}
}
}
LSP-ATTRIBUTES {
protocols {
mpls {
label-switched-path <*> {
ldp-tunneling;
record;
oam {
bfd-liveness-detection {
minimum-interval 20000;
minimum-receive-interval 20000;
multiplier 3;
}
}
node-link-protection;
adaptive;
}
}
}
}
FA {
protocols {
isis {
label-switched-path p1.nyc:0 {
level 2 disable;
}
label-switched-path p2.nyc:0 {
level 2 disable;
}
}
}
}
SR-O-RSVP {
protocols {
isis {
traffic-engineering {
family inet-mpls {
shortcuts;
}
}
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:8;
cluster 128.49.106.8;
allow 2001:db8:0:0:128:49:106::/112;
}
}
}
}
SR-O-RSVP_v6 {
protocols {
isis {
traffic-engineering {
family inet6-mpls {
shortcuts;
}
}
}
}
}
LSP-HIGH-METRIC {
protocols {
mpls {
label-switched-path <*:0> {
metric 16777215;
}
}
}
}
BGP-LS {
policy-options {
policy-statement NLRI-TO-BGP-LS {
term 1 {
from family traffic-engineering;
then accept;
}
}
policy-statement TED-TO-NLRI {
term LEVEL-1 {
from {
protocol isis;
level 1;
}
then accept;
}
term LEVEL-2 {
from {
protocol isis;
level 2;
}
then accept;
}
}
}
protocols {
isis {
traffic-engineering {
inactive: igp-topology;
}
}
mpls {
traffic-engineering {
database {
import {
igp-topology {
inactive: bgp-link-state;
}
policy TED-TO-NLRI;
}
}
}
}
bgp {
group NORTHSTAR {
type internal;
local-address 192.168.88.8;
family traffic-engineering {
unicast;
}
export NLRI-TO-BGP-LS;
neighbor 192.168.88.99;
}
}
}
}
PCEP {
protocols {
mpls {
lsp-external-controller NORTHSTAR;
}
source-packet-routing {
lsp-external-controller NORTHSTAR;
maximum-segment-list-depth 5;
telemetry {
statistics;
}
}
pcep {
pce NORTHSTAR {
local-address 192.168.88.8;
destination-ipv4-address 192.168.88.100;
destination-port 4189;
pce-type active stateful;
lsp-provisioning;
spring-capability;
max-sid-depth 5;
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.8;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-transit-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/transit/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 DNS RR IGP MPLS INFRA_INTERFACES LSP-ATTRIBUTES RSVP-TE
FA LOGGING SR SR-O-RSVP RR_v6 SR-O-RSVP_v6 LSP-HIGH-METRIC BGP-LS
PCEP IN-BAND PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES TELEMETRY
];
p2.nyc
## Last changed: 2019-03-22 14:51:28 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.2;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.2;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
cluster 128.49.106.2;
allow 128.49.106.0/24;
neighbor 128.49.106.9 {
description p1.iad;
}
neighbor 128.49.106.8 {
description p2.iad;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [ em0.0 fxp0.0 ];
then reject;
}
term LOCAL-LOOPBACK {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-/128;
}
then {
tag 1111; accept;
}
}
term L1-TO-L2 {
from {
protocol isis;
level 1;
tag 1111;
}
to level 2;
then accept;
}
term L2-TO-L1 {
from {
protocol isis;
level 2;
tag 1111;
}
to level 1;
then accept;
}
then reject;
}
}
protocols {
isis {
level 2 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/1.0 {
point-to-point;
level 2 metric 999999;
}
export ISIS-EXPORT;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 2;
ipv6-index 62;
}
}
level 1 labeled-preference 8;
}
}
}
LSP-ATTRIBUTES {
protocols {
mpls {
label-switched-path <*> {
ldp-tunneling;
record; oam {
bfd-liveness-detection {
minimum-interval 20000;
minimum-receive-interval 20000;
multiplier 3;
}
}
node-link-protection;
adaptive;
}
}
}
}
LSP-IAD {
protocols {
mpls {
label-switched-path p1.iad:0 {
to 128.49.106.9;
}
label-switched-path p2.iad:0 {
to 128.49.106.8;
}
label-history;
}
}
}
FA {
protocols {
isis {
label-switched-path p1.iad:0 {
level 2 disable;
}
label-switched-path p2.iad:0 {
level 2 disable;
}
}
}
}
SRMC {
protocols {
isis {
source-packet-routing ldp-stitching;
}
}
}
SRMS {
routing-options {
source-packet-routing {
mapping-server-entry srms.p2 {
prefix-segment 128.49.106.10/32 index 10;
prefix-segment 128.49.106.11/32 index 11;
prefix-segment 128.49.106.13/32 index 13;
}
}
}
protocols {
isis {
source-packet-routing mapping-server srms.p2;
}
}
}
LDP-SR-STITCHING {
protocols {
ldp {
sr-mapping-client;
}
}
}
LSP-ATTRIBUTES-AUTOBW {
protocols {
mpls {
statistics {
auto-bandwidth;
}
label-switched-path <*> {
auto-bandwidth {
adjust-interval 300;
adjust-threshold 1;
adjust-threshold-absolute 100;
adjust-threshold-activate-bandwidth 1k;
maximum-bandwidth 1m;
adjust-threshold-overflow-limit 3;
adjust-threshold-underflow-limit 3;
resignal-minimum-bandwidth;
}
}
}
}
}
SR-O-RSVP {
protocols {
isis {
traffic-engineering {
family inet-mpls {
shortcuts;
}
}
}
}
}
LSP-HIGH-METRIC {
protocols {
mpls {
label-switched-path <*:0> {
metric 16777215;
}
}
}
}
LSP-EWR {
protocols {
mpls {
label-switched-path p1.ewr:0 {
to 128.49.106.5;
}
label-switched-path p2.ewr:0 {
to 128.49.106.4;
}
}
}
}
LSP-PHL {
protocols {
mpls {
label-switched-path p1.phl:0 {
to 128.49.106.7;
}
label-switched-path p2.phl:0 {
to 128.49.106.6;
}
}
}
}
SR-RSVP-BDARK {
interfaces {
"<ge-0/0/[1-9]>" {
unit <*> {
bandwidth 100k;
}
}
}
routing-options {
auto-bandwidth {
template {
SR-RSVP-COEXIST {
adjust-interval 30;
adjust-threshold 1;
statistic-collection-interval 10;
}
}
}
}
protocols {
isis {
source-packet-routing {
traffic-statistics {
statistics-granularity per-interface;
auto-bandwidth SR-RSVP-COEXIST;
}
}
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:2;
cluster 128.49.106.2;
allow 2001:db8:0:0:128:49:106::/112;
neighbor 2001:db8::128:49:106:9 {
description p1.iad;
}
neighbor 2001:db8::128:49:106:8 {
description p2.iad;
}
}
}
}
}
SR-O-RSVP_v6 {
protocols {
isis {
traffic-engineering {
family inet6-mpls {
shortcuts;
}
}
}
}
}
PCEP {
protocols {
mpls {
lsp-external-controller NORTHSTAR;
}
source-packet-routing {
lsp-external-controller NORTHSTAR;
telemetry {
statistics;
}
}
pcep {
pce NORTHSTAR {
local-address 192.168.88.2;
destination-ipv4-address 192.168.88.100;
destination-port 4189;
pce-type active stateful;
lsp-provisioning;
spring-capability;
}
}
}
}
BGP-LS {
policy-options {
policy-statement NLRI-TO-BGP-LS {
term 1 {
from family traffic-engineering;
then accept;
}
}
policy-statement TED-TO-NLRI {
term LEVEL-1 {
from {
protocol isis;
level 1;
}
then accept;
}
term LEVEL-2 {
from {
protocol isis;
level 2;
}
then accept;
}
}
}
protocols {
isis {
traffic-engineering {
inactive: igp-topology;
}
}
mpls {
traffic-engineering {
database {
import {
igp-topology {
inactive: bgp-link-state;
}
policy TED-TO-NLRI;
}
}
}
}
bgp {
group NORTHSTAR {
type internal;
local-address 192.168.88.2;
family traffic-engineering {
unicast;
}
export NLRI-TO-BGP-LS;
neighbor 192.168.88.99;
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.2;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-transit-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/transit/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 DNS RR IGP INFRA_INTERFACES MPLS RSVP-TE LSP-ATTRIBUTES
FA SR LSP-ATTRIBUTES-AUTOBW LOGGING SR-O-RSVP LSP-HIGH-METRIC LSP-EWR
LSP-PHL SR-RSVP-BDARK RR_v6 SR-O-RSVP_v6 IN-BAND PCEP BGP-LS PKI TI-LFA-NODE-PROTECT
SR-TE-COLORED-ROUTES TELEMETRY ];
p2.phl
## Last changed: 2019-03-22 14:51:27 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.6;
autonomous-system 4200000000 asdot-notation;
}
}
IGP {
protocols {
isis {
level 1 disable;
level 2 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
level 1 disable;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/1.0 {
point-to-point;
level 2 metric 999999;
}
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 6;
ipv6-index 66;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.6;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-transit-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/transit/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 DNS RR IGP MPLS INFRA_INTERFACES RSVP-TE LOGGING SR
IN-BAND PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES TELEMETRY ];
pe1.iad
## Last changed: 2019-03-22 14:41:30 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30; inactive:
skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
PEERS_IPv4 {
interfaces {
ge-0/0/11 {
description >ce1.iad:ge-0/0/4;
unit 0 {
description >198.51.100.54;
family inet {
address 198.51.100.55/31;
}
}
}
ge-0/0/12 {
description >ce1.iad:ge-0/0/5;
unit 0 {
description >198.51.100.56;
family inet {
address 198.51.100.57/31;
}
}
}
ge-0/0/13 {
description >ce1.iad:ge-0/0/6;
unit 0 {
description >198.51.100.58;
family inet {
address 198.51.100.59/31;
}
}
}
}
}
RR {
routing-options {
router-id 128.49.106.11;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.11;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
neighbor 128.49.106.9 {
description p1.iad;
}
neighbor 128.49.106.8 {
description p2.iad;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [ em0.0 fxp0.0 ];
then reject;
}
inactive: term PREFIX-SID-CONFLICT {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.9/32 exact;
}
then accept;
}
term LOCAL-LOOPBACK {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-/128;
}
then {
tag 1111;
accept;
}
}
then reject;
}
}
protocols {
isis {
level 2 disable;
level 1 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/11.0 {
disable;
}
interface ge-0/0/12.0 {
disable;
}
interface ge-0/0/13.0 {
disable;
}
export ISIS-EXPORT;
overload;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 11;
ipv6-index 71;
}
}
}
}
}
PEERS_IPv6 {
interfaces {
ge-0/0/11 {
unit 0 {
family inet6 {
address 2001:db8::198:51:100:55/127;
}
}
}
ge-0/0/12 {
unit 0 {
family inet6 {
address 2001:db8::198:51:100:57/127;
}
}
}
ge-0/0/13 {
unit 0 {
family inet6 {
address 2001:db8::198:51:100:59/127;
}
}
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:11;
export PEERS;
neighbor 2001:db8::128:49:106:9 {
description p1.iad;
}
neighbor 2001:db8::128:49:106:8 {
description p2.iad;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.11;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/tunnel/ingress/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
BGP-EPE {
protocols {
bgp {
egress-te-sid-stats;
group PEERS {
neighbor 198.51.100.56 {
egress-te-node-segment {
label 1044444;
}
}
}
}
}
}
PREFIX-SID-CONFLICT {
interfaces {
lo0 {
unit 0 {
family inet {
address 128.49.106.9/32;
}
}
}
}
policy-options {
policy-statement ISIS-EXPORT {
term PREFIX-SID-CONFLICT {
then {
prefix-segment index 99;
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
SR-TE-SBFD {
protocols {
bfd {
sbfd {
local-discriminator 111 {
minimum-receive-interval 100;
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 PE_CE_IPv4 PEERS_IPv4 DNS RR IGP MPLS INFRA_ INTERFACES
SVC_VPNv4 SVC_IPv4 LOGGING SR PEERS_IPv6 PE_CE_IPv6 RR_v6 SVC_IPv6
IN-BAND RSVP-TE PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES SR-TE-SBFD
TELEMETRY ];
pe1.nyc
## Last changed: 2019-03-25 06:54:33 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.1;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.1;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
neighbor 128.49.106.3 {
description p1.nyc;
}
neighbor 128.49.106.2 {
description p2.nyc;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [ em0.0 fxp0.0 ];
then reject;
}
term LOCAL-LOOPBACK {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-/128;
}
then {
tag 1111;
accept;
}
}
then reject;
}
}
protocols {
isis {
level 2 disable;
level 1 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/10.1 {
disable;
}
export ISIS-EXPORT;
overload;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 1;
ipv6-index 61;
}
explicit-null;
}
level 1 labeled-preference 8;
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:1;
export PEERS;
neighbor 2001:db8::128:49:106:3 {
description p1.nyc;
}
neighbor 2001:db8::128:49:106:2 {
description p2.nyc;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.1;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/ingress/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-STATS {
protocols {
source-packet-routing {
telemetry {
statistics;
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 PE_CE_IPv4 DNS RR IGP MPLS INFRA_INTERFACES SVC_VPNv4
SVC_IPv4 SR LOGGING PE_CE_IPv6 SVC_IPv6 RR_v6 IN-BAND RSVP-TE PKI
TI-LFA-NODE-PROTECT SR-TE-STATS SR-TE-COLORED-ROUTES TELEMETRY ];
pe2.iad
## Last changed: 2019-03-22 14:41:52 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
PEERS_IPv4 {
interfaces {
ge-0/0/11 {
description >ce1.iad:ge-0/0/7;
unit 0 {
description >198.51.100.60;
family inet {
address 198.51.100.61/31;
}
}
}
ge-0/0/12 {
description >ce1.iad:ge-0/0/8;
unit 0 {
description >198.51.100.62;
family inet {
address 198.51.100.63/31;
}
}
}
}
}
RR {
routing-options {
router-id 128.49.106.10;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.10;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
neighbor 128.49.106.9 {
description p1.iad;
}
neighbor 128.49.106.8 {
description p2.iad;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [ em0.0 fxp0.0 ];
then reject;
}
term LOCAL-LOOPBACK {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-/128;
}
then {
tag 1111;
accept;
}
}
then reject;
}
}
protocols {
isis {
level 2 disable;
level 1 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/11.0 {
disable;
}
interface ge-0/0/12.0 {
disable;
}
interface ge-0/0/13.0 {
disable;
}
export ISIS-EXPORT;
overload;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 10;
ipv6-index 70;
}
}
}
}
}
PEERS_IPv6 {
interfaces {
ge-0/0/11 {
unit 0 {
family inet6 {
address 2001:db8::198:51:100:61/127;
}
}
}
ge-0/0/12 {
unit 0 {
family inet6 {
address 2001:db8::198:51:100:63/127;
}
}
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:10;
export PEERS;
neighbor 2001:db8::128:49:106:9 {
description p1.iad;
}
neighbor 2001:db8::128:49:106:8 {
description p2.iad;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.10;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/tunnel/ingress/usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 PE_CE_IPv4 PEERS_IPv4 DNS RR IGP MPLS INFRA_ INTERFACES
SVC_VPNv4 SVC_IPv4 LOGGING SR PEERS_IPv6 SVC_IPv6 PE_CE_IPv6 RR_v6
IN-BAND RSVP-TE PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES TELEMETRY
];
pe2.nyc
## Last changed: 2019-03-25 06:51:43 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
}
}
RR {
routing-options {
router-id 128.49.106.0;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.0;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
neighbor 128.49.106.3 {
description p1.nyc;
}
neighbor 128.49.106.2 {
description p2.nyc;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [ em0.0 fxp0.0 ];
then reject;
}
term LOCAL-LOOPBACK {
from {
175 pe2.nyc
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-
/128;
}
then {
tag 1111;
accept;
}
}
then reject;
}
}
protocols {
isis {
level 2 disable;
level 1 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/10.1 {
disable;
}
export ISIS-EXPORT;
overload;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 0;
ipv6-index 60;
}
explicit-null;
}
level 1 labeled-preference 8;
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:0;
export PEERS;
neighbor 2001:db8::128:49:106:3 {
176 Appendix
description p1.nyc;
}
neighbor 2001:db8::128:49:106:2 {
description p2.nyc;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.0;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/tunnel/ingress/
usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
177 pe2.nyc
}
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-STATS {
protocols {
source-packet-routing {
telemetry {
statistics;
}
}
}
}
SR-TE {
protocols {
source-packet-routing {
lsp-external-controller pccd;
segment-list pe1.iad_v6_path0 {
/* needs to be updated unless persistent adj-sids are used
*/
hop1 label 24;
hop2 {
label 1061;
label-type {
node;
}
}
hop3 {
label 1071;
label-type {
node;
}
}
}
segment-list pe1.iad_v4_path0 {
hop1 label 21;
hop2 {
label 1011;
label-type {
node;
}
}
}
segment-list pe1.iad_v4_path1_epe {
hop1 label 21;
hop2 {
label 1011;
label-type {
node;
}
178 Appendix
}
hop3 label 1044444;
}
source-routing-path pe2.nyc:pe1.iad_v6 {
to 2001:db8::128:49:106:11;
color 7100;
binding-sid 1000000;
primary {
pe1.iad_v6_path0;
}
}
source-routing-path pe2.nyc:pe1.iad_v4 {
to 128.49.106.11;
color 7100;
binding-sid 1000001;
primary {
pe1.iad_v4_path0;
}
}
}
}
}
SR-TE-COLORED-ROUTES {
policy-options {
policy-statement COLOR-ROUTES_v4 {
term 1 {
from {
protocol bgp;
route-filter 198.51.100.54/31 exact;
}
then {
community = HIGH-PRIORITY;
accept;
}
}
term all {
then accept;
}
}
policy-statement COLOR-ROUTES_v6 {
term 1 {
from {
protocol bgp;
route-filter 2001:db8::198:51:100:54/127 exact;
}
then {
community = HIGH-PRIORITY;
accept;
}
}
term all {
then accept;
}
}
community HIGH-PRIORITY members color:0:7100;
}
protocols {
bgp {
group INTERNAL {
import COLOR-ROUTES_v4;
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
import COLOR-ROUTES_v6;
179 pe3.iad
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
SR-TE-SBFD {
protocols {
bfd {
sbfd {
local-discriminator 100;
}
}
source-packet-routing {
source-routing-path pe2.nyc:pe1.iad_v4 {
primary {
pe1.iad_v4_path0 {
bfd-liveness-detection {
sbfd {
remote-discriminator 111;
}
minimum-interval 100;
multiplier 4;
}
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 PE_CE_IPv4 DNS RR IGP INFRA_ INTERFACES MPLS SVC_VPNv4
SVC_IPv4 SR LOGGING RR_v6 SVC_IPv6 PE_CE_IPv6 IN-BAND RSVP-TE PKI
TI-LFANODE-PROTECT SR-TE-STATS SR-TE SR-TE-COLORED-ROUTES SR-TE-SBFD
TELEMETRY ];
pe3.iad
## Last changed: 2019-03-22 14:42:14 PDT
groups {
SERVICES {
system {
services {
extension-service {
request-response {
grpc {
ssl {
port 32767;
local-certificate local-cert;
mutual-authentication {
certificate-authority root_ca;
client-certificate-request require-certificate-and-verify;
}
}
max-connections 30;
inactive: skip-authentication;
}
}
}
netconf {
ssh;
}
}
180 Appendix
}
}
PEERS_IPv4 {
interfaces {
ge-0/0/11 {
description >ce1.iad:ge-0/0/9;
unit 0 {
description >198.51.100.64;
family inet {
address 198.51.100.65/31;
}
}
}
}
}
RR {
routing-options {
router-id 128.49.106.13;
autonomous-system 4200000000 asdot-notation;
}
protocols {
bgp {
group INTERNAL {
type internal;
local-address 128.49.106.13;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family evpn {
signaling;
}
family route-target;
neighbor 128.49.106.9 {
description p1.iad;
}
neighbor 128.49.106.8 {
description p2.iad;
}
}
}
}
}
IGP {
policy-options {
policy-statement ISIS-EXPORT {
term OOB-MANAGEMENT-DENY {
from interface [ em0.0 fxp0.0 ];
then reject;
}
term LOCAL-LOOPBACK {
from {
protocol direct;
interface lo0.0;
route-filter 128.49.106.0/24 prefix-length-range /32-/32;
}
then {
tag 1111;
accept;
}
}
term LOCAL-LOOPBACK-V6 {
from {
family inet6;
protocol direct;
interface lo0.0;
route-filter 2001:db8:0000:0000:128:49:106::/112 prefix-length-range
/128-
/128;
181 pe3.iad
}
then {
tag 1111;
accept;
}
}
then reject;
}
}
protocols {
isis {
level 2 disable;
level 1 wide-metrics-only;
interface all {
point-to-point;
}
interface lo0.0 {
passive;
}
interface ge-0/0/0.0 {
disable;
}
interface ge-0/0/11.0 {
disable;
}
interface ge-0/0/12.0 {
disable;
}
interface ge-0/0/13.0 {
disable;
}
export ISIS-EXPORT;
overload;
}
}
}
SR {
protocols {
isis {
source-packet-routing {
srgb start-label 1000 index-range 128;
node-segment {
ipv4-index 13;
ipv6-index 73;
}
}
}
}
}
PEERS_IPv6 {
interfaces {
ge-0/0/11 {
unit 0 {
family inet6 {
address 2001:db8::198:51:100:65/127;
}
}
}
}
}
RR_v6 {
protocols {
bgp {
group INTERNAL_v6 {
type internal;
local-address 2001:db8::128:49:106:13;
export PEERS;
neighbor 2001:db8::128:49:106:9 {
description p1.iad;
182 Appendix
}
neighbor 2001:db8::128:49:106:8 {
description p2.iad;
}
}
}
}
}
TELEMETRY {
services {
analytics {
streaming-server ns-ifd {
remote-address 192.168.88.100;
remote-port 2000;
}
streaming-server ns-ifl {
remote-address 192.168.88.100;
remote-port 2001;
}
streaming-server ns-lsp {
remote-address 192.168.88.100;
remote-port 2002;
}
export-profile ns {
local-address 128.49.106.13;
local-port 2000;
reporting-rate 30;
format gpb;
transport udp;
}
sensor ifd {
server-name ns-ifd;
export-name ns;
resource /junos/system/linecard/interface/;
}
sensor ifl {
server-name ns-ifl;
export-name ns;
resource /junos/system/linecard/interface/logical/usage/;
}
sensor lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/label-switched-path/usage/;
}
sensor sr-lsp {
server-name ns-lsp;
export-name ns;
resource /junos/services/segment-routing/traffic-engineering/tunnel/ingress/
usage/;
}
}
}
protocols {
mpls {
sensor-based-stats;
}
}
}
OC_TELEMETRY {
protocols {
isis {
source-packet-routing {
sensor-based-stats {
per-interface-per-member-link ingress egress;
per-sid ingress egress;
}
}
}
183 pe3.iad
}
}
TI-LFA-NODE-PROTECT {
protocols {
isis {
backup-spf-options {
use-post-convergence-lfa;
}
interface all {
level 1 {
post-convergence-lfa {
node-protection;
}
}
level 2 {
post-convergence-lfa {
node-protection;
}
}
}
}
}
}
SR-TE-COLORED-ROUTES {
protocols {
bgp {
group INTERNAL {
family inet {
unicast {
extended-nexthop;
extended-nexthop-color;
}
}
}
group INTERNAL_v6 {
family inet6 {
unicast {
extended-nexthop-color;
}
}
}
}
}
}
}
apply-groups [ global member0 AAA SERVICES OAM CHASSIS
FIB INFRA_IPv4 PE_CE_IPv4 PEERS_ IPv4 DNS RR IGP MPLS INFRA_INTERFACES
SVC_VPNv4 SVC_IPv4 LOGGING SR PEERS_IPv6 PE_CE_IPv6 SVC_ IPv6 RR_v6
IN-BAND RSVP-TE PKI TI-LFA-NODE-PROTECT SR-TE-COLORED-ROUTES TELEMETRY
];