Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation  Back up to About Overview 
ContentIndex
  
[+] Expand All
[-] Collapse All

No index entries found.

Upgrade Information

You upgrade to CTPOS 7.2.x as follows:

  • If you are upgrading to CTPOS Release 7.2.x from software releases 4.x, 5.x, 6.0x or 6.1x, you use upgrade kits to upgrade your CTP device to CTPOS Release 7.2.x
  • If you are upgrading to CTPOS Release 7.2.x from software releases 7.1.x, 7.0x, 6.2Rx, 6.3Rx, 6.4Rx, 6.5Rx, or 6.6Rx, you can use software files for the upgrade.

Upgrading from CTPOS Release 4.x, 5.x, 6.0x or 6.1x to CTPOS Release 7.2..x with an Upgrade Kit

Because of the new features and hardware supported in CTPOS Release 7.2.x, a direct code upgrade from earlier versions of CTPOS by using an upgrade archive is not supported. CTPOS Release 5.x and earlier require an upgrade kit. You must perform the upgrade to CTPOS Release 7.x by using an upgrade kit. There are two upgrade kits, the use of which depends on whether you are using a PP310 or PP332 processor in your CTP2000 Series device.

If the CompactFlash card contains CTPOS 6.1R7 or earlier and you want to upgrade directly to CTPOS Release 7.2.x and later, you need to reburn the CompactFlash card with the CTPOS Release 7.2.x or later code before you perform the upgrade.

Upgrading from CTPOS Release 6.2x or Later to CTPOS Release 7.2R1

To upgrade from CTPOS Release 6.2x or later, use the following files:

  • CTPOS Upgrade Archive File: acorn_429_7.2R1_160203.tgz
  • Flash Archive: flash_7.2R1.img—Required only when you are creating a new flash card.
  • CTP Complete Package File: ctp_complete_7.2R1_160203.tgz—Required only when you use CTPView.
  • Migration Flash Archive File: acorn_xxx_7.2R1_160203_migration_flash.tgz—Required only when you create a migration flash card.
  • CTP2000 BIOS Archive File: acorn_429_110915_bios_V221.tgz—Required only during migration. This file is not required for the CTPOS upgrade.
  • Voice Card Archive File: acorn_429_111021_em9c_fxo61_fxs50_voice.tgz
  • NTP: acorn_429_ntp4.2.8p4_151127.tgz
  • FPGA Archive File: acorn_429_140915_fpga_150_s27_t1c_2000_s1b_t2c.tgz
  • Boot FPGA Archive File: acorn_xxx_boot_fpga_s25_t1b_130317.tgz—Required only for CTP 150 devices.
  • CTP2000 Winmon Archive File: acorn_429_111115_winmon_210.tgz
  • Dcard Archive File: acorn_429_111121_dcardpld_t1e1_3_4wto_4.tgz
  • KIS Archive File: acorn_xxx_150909_KIS.tgz
  • Bash Archive File: acorn_429_bash-4.3.30_141212.tgz
  • GLIBC Archive File: acorn_429_glibc-2.3.2_150327.tgz
  • OpenSSL Archive File: acorn_429_openssl_1.0.2e_151205.tgz
  • OpenSSH Archive File: acorn_429_openssh_7.1p2_160127.tgz

Note: The version of the Winmon support file (210) is the same as that in the CTPOS Release 6.2R1 Winmon version. However, the date portion of the file name is modified (111115 vs 100331). Only the installation file is modified. There is no change in the Winmon code, hence the change in date and not the version. The voice daughter card support files are also affected by this.

Make sure you disable all ports and bundles before starting the upgrade process.

Caution: When you upgrade CTPOS by using the Boot FPGA archive file, you must ensure that there is no power fluctuation or interruption during the upgrade processes. Any fluctuation or interruption of power during the upgrade can make the device unusable and the device will have to be returned to the factory.

The CTP device must not be used until the upgrade process is complete.

Manually Upgrading from CTPOS Release 7.1R2 to 7.2R1

Best Practice: Before you start the upgrade process, you must ensure that only the required archive files are present in the /tmp directory. You can manually upgrade any package in noninteractive or interactive mode. You can use the upgrade y command to upgrade a package in noninteractive mode.

Note:

  • The Winmon file is used to upgrade CTP2000-IM-8P-T1E1 Cards.
  • The FPGA file is used to upgrade both CTP2000-IM-8P-T1E1 and CTP2000-IM-8P-xx cards.
  • In the CTP2000 Series, you may have to upgrade the voice support files if they are present.

When you upgrade the archive in interactive mode, you have to select the following two options after issuing the upgrade command from the CLI:

Do you want to install the newest archive in quick mode (no questions)? y[n]: n 
Do you want to install the newest archive interactively (w/ questions)? y[n]: y

Upgrading the Winmon Archive in Interactive Mode

To upgrade the Winmon archive:

Do you want to install the newest archive in quick mode (no questions)? y[n]: n
Do you want to install the newest archive interactively (w/ questions)? y[n]: y
....
Loading Micro Winmon image to SCC0.....
Same version of Micro Winmon is already programmed, skip... !
....

Upgrading the Glibc Archive in Interactive Mode

To upgrade the acorn_429_glibc-2.3.2_150327.tgz archive:

Do you want to install the newest archive in quick mode (no questions)? y[n]: n
Do you want to install the newest archive interactively (w/ questions)? y[n]: y
Would you like to continue? y[n]: y
……..
-----
Done...

Upgrading the OpenSSL Archive in Interactive Mode

To upgrade the acorn_429_openssl_1.0.2e_151205.tgz archive:

Do you want to install the newest archive in quick mode (no questions)? y[n]: n
Do you want to install the newest archive interactively (w/ questions)? y[n]: y
Continuing...
===== Uncompressing and Extracting Archive =====
      Archive file: acorn_429_openssl_1.0.2e_151205.tgz
acorn_install/
acorn_install/gui_instr
acorn_install/install
acorn_install/openssl-1.0.2e.tgz
Running install interactively
*******************************************************************
This installation script will update openssl version to 1.0.2e
*******************************************************************

Would you like to continue? y[n]: y
.............
............
done.

Upgrading the Open SSH Archive in Interactive Mode

To upgrade the acorn_429_openssh_7.1p2_160127.tgz archive:

CTP system software upgrade utility - Version 1.4.9
Found kernel version 2.4.29, setting KVER to 429
Checking for active menu sessions
…….
Do you want to install the newest archive in quick mode (no questions)? y[n]: y
Continuing...
…….
+++++ OpenSSH 7.1p2 already installed, did not reinstall! +++++
…….
===== Archive Cleanup =====
Done...

Upgrading the NTP Archive in Interactive Mode

To upgrade the acorn_429_ntp4.2.8p4_151127.tgz archive:

******************************************************************
NOTE: CTPOS code upgrades will interrupt data on running circuits.
Say "no" to run more interactive or install a different archive)
******************************************************************
Do you want to install the newest archive in quick mode (no questions)? y[n]: n
Do you want to install the newest archive interactively (w/ questions)? y[n]: y

Continuing...

*******************************************************************
This installation script will update NTP on this system to
version 4.2.8p4. After installation, the box MUST be rebooted.
*******************************************************************

Would you like to continue? y[n]: y

Done...

Upgrading the Boot FPGA Archive in Interactive Mode

To upgrade the acorn_xxx_boot_fpga_s25_t1b_130317.tgz archive:

Note: After you upgrade the FPGA archive, you need to upgrade the main archive and restart the system.

Note: Boot FPGA is applicable to CTP150 systems only.

******************************************************************
NOTE: CTPOS code upgrades will interrupt data on running circuits.
Say "no" to run more interactive or install a different archive)
******************************************************************
Do you want to install the newest archive in quick mode (no questions)? y[n]: n
Do you want to install the newest archive interactively (w/ questions)? y[n]: y
Continuing...
===== Uncompressing and Extracting Archive =====
      Archive file: acorn_xxx_boot_fpga_s25_t1b_130317.tgz
acorn_install/
acorn_install/gluon_t1e1.rpd
acorn_install/load_fpga
acorn_install/install
acorn_install/nova_2.rbf
acorn_install/epcs
acorn_install/gui_instr
acorn_install/gluon.rpd
acorn_install/nova.rbf
Running install interactively

***** CTP150 Boot upgrade archives are not for CTP-2000! *****
……..
ManageFlashVersions: Skip... This is a Boot archive.
……..

Upgrading the Bash Archive in Interactive Mode

To upgrade the acorn_429_bash-4.3.30_141212.tgz archive:

Do you want to install the newest archive in quick mode (no questions)? y[n]: n
Do you want to install the newest archive interactively (w/ questions)? y[n]: y
Continuing...


Would you like to continue? y[n]: y

===== BASH 4.3.30 installed! =====

Done...

Upgrading the acorn_429_7.2R1_160203.tgz Archive in Interactive Mode

To upgrade the acorn_429_7.2R1_160203.tgz archive:

Do you want to install the newest archive in quick mode (no questions)? y[n]: n
Do you want to install the newest archive interactively (w/ questions)? y[n]: y
....
Would you like to continue? y[n]: y
....
Would you like to continue? y[n]: y
....

Modified: 2016-02-05