Help us improve your experience.

Let us know what you think.

Do you have time for a two-minute survey?

Navigation
Guide That Contains This Content
[+] Expand All
[-] Collapse All

    Starting the PSM Client

    Use this procedure to start the PSM client on Windows, Linux, or OS X.

    1. Launch the psmclient executable file as follows:
      • Windows: navigate to the bin folder within the PSM client installation folder and double-click the psmclient.exe file. Alternatively launch the client from the Desktop icon or Start menu entry created by the PSM client installer.
      • OS X or Linux: open a terminal window, navigate to the PSM client installation directory and launch from the command line: bin/psmclient. Alternatively launch the client from the Desktop icon created by the PSM client installer.

      The PSM installation starts by displaying the splash screen.

      Then PSM displays the login screen.

    2. In the Server field, enter the IP address for the PSM server, or choose a previously used server from the drop-down menu.
    3. Enter the Username and Password.
    4. Click Login.

      After successful login, the PSM client navigation window is displayed. The following screen shows a newly installed server with no pre-discovered network elements.

      A "Connected to Server" indication is displayed in the lower right corner of the window. If connectivity to the server is lost, this changes to a "Connection to Server Lost" indication.

      Note: Depending on the frequency with which the client and server check the path, it might take several minutes for a loss of connectivity to be detected and displayed.

      If Juniper Networks has updated the utility software, you might see the following dialog in certain situations:

      The utility software is the software defined in Tools >Options >Utilities. Choose:

      • Overwrite if you have not changed any of the Type or Version Default settings. Choosing this option only overwrites the Default settings, and does not affect or overwrite the Type or Version-specific settings.
      • Not Now if you have changed the Default settings and you want to save them before you overwrite them. To save the current Default settings, select Tools >Options >Utilities and click Export to save the settings (including the Default settings) to a zipped file. The Default settings can be found in config\Preferences\com\btisystems\pronx\ems\client\preferences.properties in the exported file. After you save the Default settings, re-launch the PSM client and choose Overwrite in the dialog.
      • Skip Versions only if instructed to do so by Juniper Networks Support.

    This procedure is complete.

    Modified: 2017-03-29