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ABOUT THIS GUIDE

This preface provides the following guidelines for using the Security Threat
Response Manager Adaptive Log Exporter:

« Documentation Feedback
« Requesting Support

Documentation
Feedback

We encourage you to provide feedback, comments, and suggestions so that we
can improve the documentation. Send your comments to
techpubs-comments@juniper.net, or fill out the documentation feedback form at
http://iwww.juniper.net/techpubs/docbug/docbugreport.html. If you are using e-mail, be
sure to include the following information with your comments:

e Document name

« Document part number

« Page number

« Software release version

Requesting
Support

Open a support case using the Case Management link at http://www.juniper.net/support/
or call 1-888-314-JTAC (from the United States, Canada, or Mexico) or
1-408-745-9500 (from elsewhere).

STRM Adaptive Log Exporter






OVERVIEW

The Adaptive Log Exporter is a stand-alone application that allows you to integrate
devices/applications with STRM. This chapter includes:

« Integrating Device Support Modules (DSMs) with STRM
e Using the Adaptive Log Exporter
« Deploying Changes

Integrating Device
Support Modules
(DSMs) with STRM

Step 1

Step 2

Step 3

Step 4

Step 5

STRM can log and correlate events received from external sources such as
security equipment and network equipment. The Adaptive Log Exporter enables
you to forward data from Windows-based devices and applications to STRM for
processing. Using the Adaptive Log Exporter, you can easily integrate
Windows-based devices with STRM.

To integrate device/applications with STRM:

Install available device types.

For more information, see Chapter 4 Managing Devices, Installing Device Types.
Add and configure the required devices.

For more information, see Chapter 4 Managing Devices, Configuring Devices.
Add and configure the required device destinations.

For more information, see Chapter 5 Managing Destinations, Configuring
Destinations.

Add Map the device to the desired destination, such as syslog or a log file.

For more information, see Chapter 5 Managing Destinations, Mapping to a
Destination.

Deploy all changes.

STRM Adaptive Log Exporter



6 OVERVIEW

Using the Adaptive

Log Exporter

Using the Menu

Using the Toolbar

The Adaptive Log Exporter provides menu and tool bar options. This section
provides information on the available options including:

e Using the Menu

e Using the Toolbar

The menu options include:

Table 1-1 Adaptive Log Exporter Menu Options

Menu Sub-Menu Description
File Save Allows you to save current changes.
Save All Allows you to save all changes made during the
current session.
Deploy Allows you to deploy all changes made during
the current session.
Preferences Allows you to configure Adaptive Log Exporter
preferences. For more information, see.
Chapter 3 Setting Up the Adaptive Log
Exporter.
Exit Allows you to exit the application.
Edit Edit Device Allows you to edit the settings for a currently
saved device. For more information, see
Chapter 4 Managing Devices.
Edit Destination Allows you to edit the mapping destination for a
device. For more information, see Chapter 4
Managing Devices.
Window Show Views Allows you to view the Destination or Devices
tabs.
Help Help Contents  Allows you to access the on-line documentation.
Software Allows you to check for software updates. For
Updates more information, see Chapter 4 Managing
Devices.
About Allows you to access information about the

version of Adaptive Log Exporter you are using.

The toolbar options include:

Table 1-2 Toolbar Options

Icon Description
- Allows you to save current changes.
&l

Save

STRM Adaptive Log Exporter



Deploying Changes 7

Table 1-2 Toolbar Options (continued)

Icon Description
= Allows you to save all changes made during the current session.
Save all
@ Allows you to edit the settings for a currently saved device.
Edit Device
ull Allows you to edit the mapping destination for a device.
B
Edit Destination
IS Allows you to deploy all changes made during the current session.
Deploy
@) Allows you to access the on-line documentation.
Help Contents

Deploying Changes Once you configure your devices using the Adaptive Log Exporter, you must save
your changes to the staging area using the Save or Save All option. Then, you
must either manually deploy all changes using the Deploy menu option or, upon
exit, a window appears prompting you to deploy changes before you exit. All
deployed changes are then enforced.

STRM Adaptive Log Exporter






INSTALLING THE ADAPTIVE LOG
EXPORTER

This chapter provides information on installing and uninstalling your Adaptive Log
Exporter including:

« Before You Begin
 Installing the Adaptive Log Exporter
e Un-installing the Adaptive Log Exporter

Before You Begin

Before you install the Adaptive Log Exporter, make sure you have the following:
» Windows 2000 or Windows 2003 software installed.
« Your system includes at least 29.6 MB of disk space available.

e Appropriate access to STRM. For more information regarding STRM, see the
STRM Users Guide.

« Appropriate access to all devices and servers you wish to configure. For more
information, see your vendor documentation.

« Java Runtime Environment installed on your system. You can download Java
version 1.5.0 10 at the following web site:
http://java.com/en/download/index.jsp

Installing the
Adaptive Log
Exporter

Step 1

Step 2
Step 3

To install the Adaptive Log Exporter:

Download the Adaptive Log Exporter by selecting Software > Adaptive Log
Exporter from the following website:

http://downloads.qgllabs.com/windowsagent/
Close all other active applications before installing the Adaptive Log Exporter.
Double-click the Adaptive Log Exporter executable.

The Welcome window appeatrs.

STRM Adaptive Log Exporter



5 INSTALLING THE ADAPTIVE LOG EXPORTER

Welcome to the
QRadaraAdaptivel ogExporter
Setup Wizard

Thes vail nztell O adar didaptive Log Exporter 1.0 on your
APt

It &5 racommesdad hat wou close al of har applcations: bedore
canmang

Clhcd Mew 1o continue. ar Canced io ekl Setup.

I_ Hast > J Cancal

Step 4 Click Next.
The Select Destination Location window appears.

Sabact Deztmation Location
"Wans dhauld DR adarsdeniesl ok quortar be nsallad?

_J Setup wilirtall DR adarhdzotheel ogE sporher ino the olowing lolder

Teeonlirue, elick Hest 1 pou waud ke o salect 4 difsent lelder, chek Hiowea

[ Hizwza. . ]

it |eaed 3007 ME af figs dek zpace @ Eouned
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Step 5 Specify the location you wish to install the Adaptive Log Exporter. To browse your
system for a particular location, click Browse.

Step 6 Click Next.
The Start Menu Folder window appears.

STRM Adaptive Log Exporter
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Select Stort Menu Folder
Whee should Seiup places the program's shodculs *

g Sahup vl creaba e program's shodciuts in e folowing Start Maru falder

T coetindse, ok Mai. [ you would [le 1o s2kct @ dilfeent fold, click Brovse
QF adaidaptival acE xpeder Browse.. |

[ 1 Dar't creata a Start Mar fakder

[ £ Back " M |[ Cancel ]

Step 7 Specify the name of the menu option in your Start menu. If you do not wish you
include a menu option in your Start menu, select the Don’t create a start menu
folder check box.

Step 8 Click Next.

The Select Additional Tasks window appears.

Sabect Addilional Tazks
Which addiicea tasks shauld be pafamesd?

Selext the additional faskz pou woul Bke Sebup to posfom while instaling
A adarsdaplival acE xpeder, Ihen clck Mexd

Addiliena ieon:
[«| Create & dexhion icon

(%) Faral usarz

() For e cumark usss anky
[[] Creste & Quick Laureh izea
Otfwa Tacks

[#] Fiun sevics mos

| « Back |[ Hed ]| Coneel |

Step 9 Configure the available options:

Create a desktop icon — Select the check box if you wish to create an icon on
your desktop for the Adaptive Log Exporter. You can also select one of the
following options:

- For all users
- For the current user only

Create a Quick Launch icon — Select the check box if you wish to create an
icon on your Quick Launch toolbar.

Run service now — If you wish to run the Adaptive Log Exporter immediately
after installation, select the Run service now check box.

STRM Adaptive Log Exporter



7 INSTALLING THE ADAPTIVE LOG EXPORTER

Step 10 Click Next.
The Ready to Install window appears.

Feady ta Install
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compuler
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Qthey Tazks
Fiuin saavies pove
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Step 11 Click Install.

The Competing the Setup Wizard appears when the installation is complete.

Completing the
QRadarAdaptiveLogExporter
Setup Wizard

Selup has Inished mealing OF sdattdspieel sabsparar an
o computer. Thee applcation may be launched by s2lecing
e inetallad icans:

Chek Firish bo il Sebup

Step 12 Click Finish.
The installation process is complete.

Un-installing the To un-install the Adaptive Log Exporter:
Adaptive Log
Exporter

Step 1 From your desktop, select Start > Programs > QRadarAdaptiveLogExporter >
Utility > Uninstall QRadarAdapterLogExporter.

A confirmation messages appears.

STRM Adaptive Log Exporter



Un-installing the Adaptive Log Exporter 8

"?f’ Sy SUPE ol nEnt b complately ramewe QR edarddaptiel aoEspertar and 8l of its components?

(R

Step 2 Click Yes to continue.
Once the process is complete, a message appears when the uninstall is complete.

1) crRadaradeptvelogExporter wies successiuly ramoved from oo campater,

Step 3 Click Ok.
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3 SETTING UP THE ADAPTIVE LOG

EXPORTER

This chapter provides information on setting up your Adaptive Log Exporter

including:
e Using the Preferences Window
¢ Managing Updates

Using the The Preferences window provides the following options:
Preferences ,
Window Table 3-1 Preference Options
Menu Sub-Menu Description
Help We recommend that you use the default

values for the Help options. Altering these
options may affect the appearance of the
on-line Help.

Install/Update

Allows you to configure your update options.
For more information, see Configuring
Adaptive Log Exporter Updates.

Automatic Updates

Allows you to schedule updates to your
Adaptive Log Exporter. For more information,
see Scheduling Automatic Updates.

Update Site

Allows you to configure the location that the
Adaptive Log Exporter uses for updates. For
more information, see Configuring the
Update Site.

I? Note: If you deviate from the default values of the Adaptive Log Exporter and you
wish to restore default values, click Restore Defaults in the Preferences window.

STRM Adaptive Log Exporter



16 SETTING UP THE ADAPTIVE LOG EXPORTER

Managing Updates This section provides information on managing updates for your Adaptive Log
Exporter including:

« Configuring Adaptive Log Exporter Updates
e Scheduling Automatic Updates
e Configuring the Update Site

Configuring Adaptive  To configure the preferences for updates:
Log Exporter
Updates

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appeatrs.

Fl Edk - ‘Winoaw Help

=l

Help Contents

Step 2 From the menu, select File > Preferences.
The Preferences window appears.

STRM Adaptive Log Exporter
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oty |

Caeel |

Step 3 Click Install/Update.
The Install/Update parameters appear.

Install/Update (=1

Maximuri number of ‘History' configurations: | 100

Iv Check digital signatures of downloaded archives

Valid updates
+ equivalent {1.0.1 -3 1.0.2 - only service increments)

" compatible (1.0,9 -> 1.1.0 - service and minor increments)

Update Palicy
Policy URL: |

Proxy setkings
™ Enable HTTP proxy conneckion

Restore Defaults | Apply

=1

Cancel |

Step 4 In the Maximum number of History configurations field, enter the number of
configuration changes you wish the system to maintain. The default is 100.

Step 5 To ensure greater security for your downloaded archives, select the Check digital

signatures of downloaded archives check
selected.

box. By default, the check box is

Step 6 To determine the updates you wish your system to perform, choose one of the

following options:

equivalent — Includes updates that are compatible with the other currently

running version of the Adaptive Log Exporter. Typically, this includes plug-ins

and updates.

STRM Adaptive Log Exporter



18 SETTING UP THE ADAPTIVE LOG EXPORTER

« compatible — Includes updates that are available and include a new version of
the application. Typically, this includes a new release of the Adaptive Log
Exporter.

Step 7 To specify a specific update policy, specify a URL in the Policy URL field.

This update policy is useful if your deployment includes many Adaptive Log
Exporter. If this is the case, you may need to schedule event uploads to minimize
the potential high load on the network. For assistance creating a custom update
policy, contact Juniper Customer Support.

Step 8 To specify specific proxy settings for your updates:
a Select the Enable HTTP Proxy connection check box.
Additional fields are activated.

b Inthe HTTP proxy host address field, enter the IP address of the desired proxy
host.

c Inthe HTTP proxy host port field, enter the port number of the proxy host.
sStep 9 Click Apply.
Step 10 Click Ok.

STRM Adaptive Log Exporter



Managing Updates 19

Scheduling  You can configure the Adaptive Log Exporter to automatically search for updates.
Automatic Updates To schedule updates:

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appears.

Flz Edk - window Help

=]

Help Contents

Step 2 From the menu, select File > Preferences.
The Preferences window appears.

[T -] Help
- H } )
- IrctalfUpdars Specify how help infommation i dispkayed,

™ Usa a=tarnal brovesar

Opar wirdow corbedt halp
0 in o dynam helpwiew ¢ inan nfopop

Opan diakeg cortest halp
* ir & dynamic helpowirdew T b aninfapap

Restorn Dafauks | docky |

[ o ] came |

Step 3 In the left navigation pane, click the + sign next to Install/Update.
Additional menu options appear.

Step 4 Click Automatic Updates.
The Automatic Updates parameters appear.

STRM Adaptive Log Exporter
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SETTING UP THE ADAPTIVE LOG EXPORTER

Step 5

Step 6

Step 7

Step 8
Step 9

Automatic Updates LI

I~ Automatically find new updates and notify me

=
-

e I

Restore Defaults Apply

Select the Automatically find new updates and notify me check box.

Additional options become active. When updates are available, a message
appears indicating the available updates.

Select one of the following options to schedule automatic updates:

Look for updates each time platform is started — Enables the system to
search for updates each time you start your Adaptive Log Exporter. This is the
default.

Look for updates on the following schedule: — Allows you to use the
drop-down list boxes to schedule a specific time for searching for updates.

Select one of the following options for downloading updates:

Search for updates and notify me when they are available — Enables the
system to search for updates and provide notification when the updates are
available before downloading.

Download new updates automatically and notify me when ready to install
them — Enables the system to search for new updates automatically and
notifies you when they are ready to install.

Click Apply.
Click Ok.

STRM Adaptive Log Exporter
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Configuring the  To specify a specific location for the Adaptive Log Exporter to search for updates:
Update Site

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appears.

Ak Edk - window Help

=]

Step 2 From the menu, select File > Preferences.
The Preferences window appears.

e fiker box RS Help
g H } )
= IretalfUpdirs Speify how help information i deplayed,

™ Usa a=tarnal brovesar

Opan window porbast FEp
™ in adyname: helpwiew © inan nfopop

Opzn dialog cortest hajp
* in & dynamic helpwirdew T aninfapap

Restoen Dafouks | Aok |
[ o ] cae |

Step 3 In the left navigation pane, click the + sign next to Install/Update.

Additional menu options appear.
Step 4 Click Update Site.
Update Site parameters appeatr.

STRM Adaptive Log Exporter
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Update Site (=l

Update Site URL | file:/fq1dc01)I-TeamWindows AgentfUpdateSite

Restore Defaults | Apply |
(o] 4 | Cancel |

Step 5 In the Update Site URL field, enter the location you wish the Adaptive Log Exporter
to use for searching for updates.

I> Note: Adaptive Log Exporter supports both http and file protocols. For example,
the following are valid locations:

http://<update.server.com>/UpdateSite

On a Windows server:
File:\\<SOMEWINDOWSSERVER>\ALE\UpdateSite
A local file:

file:///e:/UpdateSite

You can download updates from
http://downloads.qgllabs.com/windowsagent/

Step 6 Click Apply.
Step 7 Click Ok.

STRM Adaptive Log Exporter



4 MANAGING DEVICES

This chapter provides information on adding and managing devices using your
Adaptive Log Exporter including:

 Installing Device Types
e Updating Devices
e Configuring Devices

Installing Device To install device types, such as a Cisco ACS, on your Adaptive Log Exporter:
Types

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appeatrs.

Fle Edi - window  Help

]

Help Contents

(T - =c c

Step 2 From the menu, select Help > Software Updates > Add Extensions/Devices.

STRM Adaptive Log Exporter



24 MANAGING DEVICES

Search Results

Selact Features ko nistall from the search result let. S

J

Salact tha features b nstall;

03 Descalact All

Select Redquined
Oof 2 seleched,
[ Shows the babest versin of a feature arly
™ Fiter Features nohuded in other Fastures an the ist
| | I I Cancel

step 3 Click the + sign to expand the menu tree.
The available devices appear.
Step 4 Choose one of the following options:

a If you wish to install all available devices, select the check box of the top level
menu option.

b If you wish to install specific devices, select the check box(es) for all devices
you wish to add to your Adaptive Log Exporter.

Step 5 Click Next.
The Feature License window appears.

Step 6 Read the license associated with the selected device. To continue, you must select
the | accept the terms of the license agreement option.

Step 7 Click Next.

The Installation Window appears.

Installation

The: Falioasire Faabinas will ba installad, Vo can salect 2 Fasture and changs tha location whers tha n |
Feature wil be nstalled, - j.‘—

Featuras toinetal:

L4 Juriper SEA. CRadar Adaptive Log Expovtar Davice 1.0.0
Lk Civem A5 QR adar Adeptive Log Exporter Devis 1,000
L2 File Forwarder QRadar Adaptive Log Exportar Device 1.0,0

Install Location 1P rogram Flec) R adarid ant iv el ngExportes|Oft adarddaptivel opfr  Change Location ...

Raguied space; 574K
Fres spacs: Linknain

awe | o | ] o

[? Note: You must install your devices to the default location. Therefore, do not
change the Install Location for your devices.

Step 8 Click Finish.
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Updating Devices 25

The Feature Verification window appears.
Step 9 Click Install All to install all chosen devices.

Updating Devices To update your device configuration in the Adaptive Log Exporter:

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appears.

Ak Edk - window Help

oy}

Help Contents

Step 2 From the menu, select Help > Software Updates > Update Agent.

If any updates are available, the Updates window appears. If no updates are
available, a message appears.

Search Results l'
Select Feabures bo nstall From the search result kst o
) =
Salart tha Feabures to nstall:
B a0 L gty | Decalact A1
Seleet Reaquired
Dof 2 selected,
[ Shows the batest versian of 3 Feature arly
™ Fiter featuras nouded in other fastures an the st
| || I Cancel

step 3 Click the + sign to expand the menu tree. .
The available devices appear.
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26 MANAGING DEVICES

Step 4

Step 5

Step 6

Step 7

Step 8

Step 9

Step 10

Choose one of the following options:

a If you wish to install all available devices, select the check box of the top level
menu option.

b If you wish to install specific devices, select the check box(es) for all devices
you wish to add to your Adaptive Log Exporter.

Click Next.
The Feature License window appears.

Read the license associated with the selected devices. To continue, you must
select the | accept the terms of the license agreement option.

Click Next.
The Installation Window appears.

Installation »
T Folowdneg Fesabuness vell b installad, Viou can sebect 2 Fasrire and change tha location where tha ~
feature wil be inztabed. ) =
Featuras toinstal;

3 Juripesr SER Radar Adaptive Log Expovtar Davice 1.0.0
Hpk Cisto ACS QRadar Adeptive Log Exparter Device 1.0.0
i File Forvander QRadar Adaptive Log Exportar Davice 1.0,0

Install Locatian cProgram Flesi R adarhd sptivel ogExporterl Ot ad arddaptivel 0of :r - Change Location ...

Raguiad space; G674kE
Fres spaca: Linkrawin

N

If you wish to change the location to which the devices will be installed:

a Click Change Location.

b Click Add Location.

¢ Using the menu tree, select the location you wish to install the devices.
d Click Ok.

e Click Ok.

Click Finish.

The Feature Verification window appears.

Click Install All to install all chosen devices.

Configuring
Devices

Once you have installed the device types, such as Cisco ACS, to your Devices tab,
you can add multiple devices to integrate with STRM. Each device you add to the
device type must be configured and then mapped to a destination. For more

information on configuring the destination, see Chapter 5 Managing Destinations.
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Using the Adaptive Log Exporter, you can,
» Adding a Device

« Editing a Device

« Deleting a Device

Adding a Device To add a device:

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appears.

@
Help Carkzrks

i Destingkions =4d =

| Clscn ACS
File Forweeder
uripar S8R

Step 2 Click the Devices tab.

Step 3 For the device type to which you wish to add a device, use the right-mouse button
(right-click) on the device name and select Add Device.

A new device appears below the main device name and configuration options
appear. For example, if you add a new device to the Cisco ACS device, the
following window appears:

FIR @
Save Sawe Al Help Conbenits

I Davices . Destinations — O = —E=
=l ®§5::::?: - New Cisco ACS' Properties
L W LR
File Forvsandes = Basic Configuration ¢ Advanced Confiquration
Juriper SER, This & the section that descrioes the mandatory
properties of the news device,
hame; Mew Ciza ACS

Description:
Device fiddress:
= Ciste ACS Configuration

This i the ssctien that deserines the Cisee,
AS-spedfic properties of the mew device.

RartLag Dradory: | El

Fraparties

Step 4 In the Basic Configuration area, enter values for the parameters:
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Step 5
Step 6

Step 7

Step 8
Step 9
Step 10
Step 11

Editing a Device
Step 1

Step 2
Step 3

« Name — Specify the name you wish to assign this device. The name can be up
to 50 characters in length.

« Description — Specify a description for this device. The description can be up to
100 characters in length.

« Device Address — Specify the IP address for this device. This is the IP
address this DSM uses to communicate with STRM.

Click the arrow next to Advanced Configuration to reveal the configuration
parameters.

For the Throttle Timeout parameter, specify the number of milliseconds you wish
the Adaptive Log Exporter to check for device changes. The default is 500.

Configure the device specific parameters.

For more information, see the appropriate section for the device specific
configuration.

From the menu, select File > Save.

Repeat for each device you wish to configure.
From the menu, select File > Save All.

From the menu, select File > Deploy.

To edit a device:

From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appeatrs.

@
Help Cortenks
W Cestinakions =} 'O
Cisco ACS
Fila Forverder

Juripar S8R

Click the Devices tab.

For the device type that includes the device you wish to edit, click + to expand the
menu tree.
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Step 5

Step 6

Step 7

Step 8

Step 9
Step 10
Step 11
Step 12

Deleting a Device
Step 1

Configuring Devices 29

For the device you wish to edit, use right-mouse button (right-click) on the device
name and select Edit Device.

The configuration parameters for that device appears.
Update the Basic Configuration, as necessary:

« Name — Specify the name you wish to assign this device. The name can be up
to 50 characters in length.

« Description — Specify a description for this device. The description can be up to
100 characters in length.

« Device Address — Specify the IP address for this device. This is the IP
address this DSM uses to communicate with STRM.

Click the arrow next to Advanced Configuration to reveal the configuration
parameters.

For the Throttle Timeout parameter, specify the number of milliseconds you wish
the Adaptive Log Exporter to check for device changes.

Configure the device specific parameters.

For more information, see the appropriate section for the device specific
configuration.

From the menu, select File > Save.
Repeat for each device you wish to edit.
From the menu, select File > Save All.
From the menu, select File > Deploy.

To delete a device:

From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appears.
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;_;.I
Help Conkerks
iJ Ciestinakions =0 e,
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Fil Faorvwerder
Juripar S8R

Step 2 Click the Devices tab.

Step 3 For the device type that includes the device you wish to delete, click + to expand
the menu tree.

Step 4 For the device you wish to delete, use right-mouse button (right-click) on the
device name and select Delete Device.

A confirmation window appears. .
Step 5 Click Ok.
Step 6 From the menu, select File > Save.
Step 7 Repeat for each device you wish to delete.
Step 8 From the menu, select File > Save All.
Step 9 From the menu, select File > Deploy.

STRM Adaptive Log Exporter



5 MANAGING DESTINATIONS

This chapter provides information on adding and managing your device
destinations using your Adaptive Log Exporter including:

« Configuring Destinations
¢ Mapping to a Destination

Configuring Using the Adaptive Log Exporter, you can,
Destinations e Adding a Destination
e Editing a Destination

e Deleting a Destination

Adding a Destination To add a destination:

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appeatrs.

@
el Cankenks
iJ Ciestingkions =} e,

Cleco ACS
Fila Forvearder
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Step 2 Click the Destination tab.
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Step 3 For the destination type to which you wish to add a new device, use the
right-mouse button (right-click) on the destination name and select Add
Destination.

A new destination appears below the main destination name and configuration
options appear. For example, if you add a new destination to the Syslog UDP
destination, the following window appears:

al L= z
Save Saveal Edi Destination Deply | Help Contents
Davice: L] T O hew Logges T =0
£ Smhg UDR ™New Logger' Properties
=¥ Logger
5 Plew Logger = Basic Confiquration ¢ Advanced Configuration

Thisis the section that desoribes the mardstary
prapartias of e rav destination.

Harme: [Tz Loggar
Description: |

= Logger Configuration
THiS 5 the section that deseribes the prepecties af
evEnts sent to alog file,

Locyger Prafix: D Evarks

B Frepend sysiog headar

Propertias

Step 4 In the Basic Configuration area, enter values for the parameters:
« Name — Specify the name you wish to assign this destination.
« Description — Specify a description for this device.

Step 5 Click the arrow next to Advanced Configuration to reveal the configuration
parameters.

Step 6 For the Number of Threads parameter, specify the number of concurrent
processing threads you wish run in this destination. The default is 1.

Step 7 Choose one of the following options:
a If you are configuring a Syslog UDP destination:

- Syslog Server Address — Specify the IP address of the target syslog
server.

- Syslog Server Port — Specify the port of the target syslog server.
b If you are configuring a Logger destination:

- Logger Prefix — Specify the heading you wish to assign to the logs. The
Logger Prefix entry must start with Device.Events and may contain letters,
numbers and periods.

- Prepend Syslog Header — Select the check box if you wish the syslog
header to be attached to the message in the logs.

Step 8 From the menu, select File > Save.
Step 9 Repeat for each destination you wish to configure.
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Step 10 From the menu, select File > Save All.
Step 11 From the menu, select File > Deploy.

Editing a Destination  To edit a destination:

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appears.

@
el Carkerks

® | Cestinations =4d =

Cietn ACS
Fia Farwaeder
“uripar S8R

Step 2 Click the Destination tab.

Step 3 For the destination type that includes the destination that you wish to edit, click the
+ sign to expand the menu tree.

Step 4 For the destination you wish to edit, use the right-mouse button (right-click) on the
destination name and select Edit Destination.

File  Edit  Windows  Hab
)
EdR Dastinatian Deplay | Help Centents

oo Gorerers~ ) IS -o
¥ syshg UDP 1 ' s
ogs’ Properties
-9 Logger J '
™ Lo =| Basic Configuration ¢ Adyvanced Configuration

This is the section that desoribes the mandetary
propartiss ef the new destinerien.

Hame: [Logs
Description; |Lu-gg=r

= Logger Conhiguration
This is the sechian that deseribes the preperties af
EvENLS sent to alog Fike,

Laypesr Prafia: Divice, Ewarks

B Prepend sysiog headar

Propertie:
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Step 5

Step 6

Step 7

Step 8

Step 9
Step 10
Step 11
Step 12

Deleting a
Destination

Step 1

In the Basic Configuration area, update the values, as necessary:
« Name — Specify the name you wish to assign this destination.
« Description — Specify a description for this device.

Click the arrow next to Advanced Configuration to reveal the configuration
parameters.

For the Number of Threads parameter, update the number of concurrent
processing threads you wish run in this destination.

Choose one of the following options:
a If you are configuring a Syslog UDP destination:

- Syslog Server Address — Specify the IP address of the target syslog
server.

- Syslog Server Port — Specify the port of the target syslog server.
b If you are configuring a Logger destination:

- Logger Prefix — Specify the heading you wish to assign to the logs. The
Logger Prefix entry must start with Device.Events and may contain letters,
numbers and periods.

- Prepend Syslog Header — Select the check box if you wish the syslog
header to be attached to the message in the logs.

From the menu, select File > Save.

Repeat for each destination you wish to edit.
From the menu, select File > Save All.
From the menu, select File > Deploy.

To delete a destination:
From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >

Configure QRadar Adapter Log Exporter.
The Adaptive Log Exporter appeatrs.
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Step 2 Click the Destination tab.

Step 3 For the destination type that includes the destination that you wish to delete, click +
to expand the menu tree.

Step 4 On the destination you wish to delete, use the right-mouse button (right-click) on
the destination name and select Delete Destination.

A confirmation window appears.
step 5 Click Ok.
Step 6 From the menu, select File > Save.
Step 7 Repeat for each device you wish to delete.
Step 8 From the menu, select File > Save All.
Step 9 From the menu, select File > Deploy.
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Mapping to a Once you have configured your devices and destinations, you must map your
Destination device to a destination. This section provides information on mapping a destination
to a device including:

« Creating a Mapping

« Removing a Mapping

Creating a Mapping  To map a device to a destination:

Step 1 From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appeatrs.
Step 2 Click the Destination tab.

Step 3 For the destination type that includes the destination that you map to a device,
click + to expand the menu tree.

Step 4 For the destination you wish to map to a device, use the right-mouse button
(right-click) on the destination name and select Add Device Mapping.

The mapping is created. A new + sign appears next to the mapped destination.

Fle Edt Window Hzlp

- o ®
Edit Destination  Degloy | Help Contents
oﬁ:ﬁ‘m = 0| Dogs = =H
¥ syshouoe ‘Lags' Properties
=¥ Losgper
ety
'y Ao Devices Mapgng + = Basic Confliguration v Advanced Configuration
Thisis tha secon that desorbes the mandakary
Edt Destingtion praperties of the new destnekion.
Dieleta Bastination Name: [Leas
Drszcriphion: |LI:-:|D!I'

= Logger Confiquration

This is the section that desorbes the propertics of
everits sant bo i e e,
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[ Prepend syshog headar
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Step 5 To view the mapping, click + to view the mapped device name.
Step 6 From the menu, select File > Save.

Step 7 Repeat for each destination you wish to map to a device.

Step 8 From the menu, select File > Save All.

Step 9 From the menu, select File > Deploy.
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Step 1

Step 2
Step 3

Step 4

Step 5

Step 6
Step 7
Step 8
Step 9
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To delete a mapping between a device and a destination:

From the Start menu, select Start > Programs > QRadarAdaptiveLogExporter >
Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appears.
Click the Destination tab.

For the destination type that includes the mapping you wish to remove, click + to
expand the menu tree.

For the destination that includes the mapping you wish to remove, click + to
expand the menu tree.

For the mapping you wish to remove, use the right-mouse button (right-click) on
the device name and select Delete Device Mapping.

The mapping is removed.

From the menu, select File > Save.

Repeat for each mapping you wish to remove.
From the menu, select File > Save All.

From the menu, select File > Deploy.
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CONFIGURING THE Cisco ACS
DEVICE

This chapter provides information on configuring your Cisco ACS device.

For information on adding or managing a device, see Chapter 4 Managing
Devices.

'New Cisco ACS' Properties

~ Basic Configuration ¥ Advanced Configuration

This is the section that describes the mandatory properties of
the new device.

Marme: | Mew Cisco ACS

Description: |

Device Address: |

+ Cisco ACS Configuration

This is the section that describes the Cisca ACS-specific
properties of the new device.,

Root Log Direckary: | D

Properties

Configure the Cisco ACS device parameter to specify the Root Log Directory,
which is the location Cisco ACS stores the logs files.
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CONFIGURING THE Cisco CSA
DEVICE

Cisco Security Agents (CSA) provides security to your deployment to defend
against the spread of attacks across networks and systems. These CSA devices
enforce a set of policies provided by the Management Center (MC) for CSA
devices and selectively applied to system nodes by the network administrator.

This chapter provides information on configuring your CSA device using the STRM
Adaptive Log Exporter. For information on adding or managing a device, see
Chapter 4 Managing Devices.

M\_ =5

"Sew Cisco CSA' Properties

i Basic Configuration ¢ Advanced Configuration

This is the section that desciibes the mandatory properties of the
new device

Name: |Naw Cigco C54

Description; |

Device Address: |

~ Cisco CSA Configuration
This is the section that describes the Cisco CSA-specific
properties of the new device.

Root Log Directory: | EI

Log Filenare: |Iogf\|a.txl

F’mperlias]

Enter values the following parameters:

* Root Log Directory — Specify the location of the CSA MC alert log files. By
default, the CSA alert log files are located in the C:\alerts\ directory

» Log Filename — Specify the name of the active alert log file. The CSA MC can
generate a flat logging file to which events are written with a name of your
choosing.

Note: This file data is encoded in UTF-8 format. Entry fields are separated by a
comma. Event entries are separated by a carriage return/line feed (ASCII Hex 0D
0A). Once a log file exceeds 1 MB, the file is closed and the file name is suffixed
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with a time stamp. A new file, using the same file name entered in the CSA MC
Alerts Log file field, is then created. Events continue to be written to this new file
until it reaches 1 MB.
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CONFIGURING THE FILE
FORWARDER DEVICE

This chapter provides information on configuring your File Forwarder device.

For information on adding or managing a device, see Chapter 4 Managing
Devices.

'New File Forwarder' Properties

~ Basic Configuration } Advanced Configuration

This is the section that describes the mandatory properties of
the new device,

Mame: | Mew File Forwarder

Description: |

Device Address: |

~ File Forwarder Configuration

This is the section that describes the File Forwarder-specific
propetties of the new device,

Root Log Directary: | EI

[ starts with: [
O Ends with: [

Properties

Enter values the following parameters:

Root Log Directory — Specify the location the File Forwarder device stores
the logs files.

Starts With — If you wish the device to monitor files that start with a specific
character combination, select the check box and enter the desired characters.
The entered string can be up to 255 characters in length.

Ends With — If you wish the device to monitor files that ends with a specific
character combination, select the check box and enter the desired characters.
The entered string can be up to 255 characters in length.
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CONFIGURING THE JUNIPER SBR
DEVICE

This chapter provides information on configuring your Juniper SBR device.

For information on adding or managing a device, see Chapter 4 Managing
Devices.

‘New Juniper SBR' Properties

! Basic Configuration } Advanced Configuration

This is the section that describes the mandatory properties of
the new device,

Mame: | Mew Juniper SBR.

Description: |

Dievice Address: |

= Juniper SBR Configuration

This is the section that describes the Juniper SBR-specific
properties of the new device.

Rook Log Direckory: | D

Propetties

Configure the Juniper SBR parameter to specify the Root Log Directory, which is
the location Juniper SBR stores the logs files.
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CONFIGURING THE WINDOWS EVENT
LOG DEVICE

In Microsoft Windows, an event is any significant occurrence in the system, a
program that requires users to be notified, or an entry added to a log. The event
log device records application, security, and system events in the STRM Event
Viewer. Using the Event Viewer, you view hardware, software, and system
component information. You can also monitor security events on a local or remote
computer. Event logs enable you to identify and diagnose the source of current
system problems or help you predict potential system problems.

This chapter provides information on configuring your Windows Event Log device
using the STRM Adaptive Log Exporter. For information on adding or managing a
device, see Chapter 4 Managing Devices.

New Windows Event Log' Properties

#: Basic Configuration ¢ Advanced Configuration

Thiz iz the sechion that describes the mandatory
properties of the new device.

Mame: INew ‘windows Event Log

D escription: |

Device Address: |

+ Windows Event Log Configuration - Windows Event Log Remote System Configuration
Thiz iz the gechion that describes the Windows Thig iz the zection that descnbes the [optional] remote machine
Event Log-zpecific properties of the new device. properties.

O Application Log O Remate Machine; |

O Securiy Log Pal intervat | EE

O 5ystem Log

Enter values the following parameters:

« Application Log — Select the check box if you wish the device to monitor the
application log. The application log contains events logged by programs, for
example, a database program may record a file error in the application log. The
specific events recorded by the application log are determined by the software
program.

« Security Log — Select the check box if you wish the device to monitor the
security log. The security log records events (for example, valid and invalid
logon attempts) and events related to resource use (for example, creating,
opening, or deleting files). You must be logged in with administrator privileges

STRM Adaptive Log Exporter



48

CONFIGURING THE WINDOWS EVENT LOG DEVICE

or as a member of the administrators group to enable, use, and specify which
events you wish to record in the security log.

System Log — Select the check box if you wish the device to monitor the
system log. The system log contains events logged by Windows XP system
components. For example, if a driver fails to load during startup, an event is
recorded in the system log. Windows XP predetermines the events that are
logged by system components.

Remote Machine— Select the check box if you wish the device to retrieve the
logs from a remote machine. Enter the desired Universal Naming Convention
(UNC) name. The entered string can be up to 255 characters in length. For
example, \\tango123

Note: When accessing remote logs, make sure that you configure the STRM
Adaptive Log Exporter service to run as a user with Administrative privileges on
the remote system. For more information, see the Configure how a service is
started technical note on www.microsoft.com.

Poll Interval — Specify the remote poll interval enter a value, in milliseconds.
The default is 5000 milliseconds.
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CONFIGURING THE WINDOWS DHCP
DEVICE

In the Microsoft Windows Server family, DHCP server log files use audit logging to
permit log files to remain enabled without additional monitoring or administration.
This allows you to manage log file growth or conserve disk resources.

This chapter provides information on configuring your Windows DHCP device
using the STRM Adaptive Log Exporter. For information on adding or managing a
device, see Chapter 4 Managing Devices.

M =0

™New Windows DHCP' Properties

+ Basic Configuration i Advanced Configuration

This iz the section that describes the mandatory properties of the new Thig iz the section that describes the
device, optional/tuning praperties of the new

Marne: |Naw ‘windows DHCP device.

Thirottls timeout: |5EIEI

Description; |

Device Address: |

= Windows DHCP Configuration

This iz the section that describes the Windows DHCP-specific properties of
the new devics.

Root Lag Directony: |C:\W’I MDOWSAS petern32hdhep B

Pruperlies]

Configure the Root Log Directory parameter, which is the location of the DHCP
server log files. By default, the DHCP audit log files are located at
%windir%\System32\Dhcp.

Once you configure your Window DHCP device, make sure you restart the DHCP
service to allow the Adaptive Log Exporter to communicate with your DHCP
device.
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CONFIGURING THE MICROSOFT
WINDOWS IAS DEVICE

The Microsoft Windows Internet Authentication Service (IAS) devices provides a
Remote Authentication Dial-in User Service (RADIUS) server and proxy. As a
RADIUS server, IAS performs centralized connection authentication, authorization,
and accounting for many types of network access, including wireless and virtual
private network (VPN) connections. As a RADIUS proxy, IAS forwards
authentication and accounting messages to other RADIUS servers.

This chapter provides information on configuring your Windows IAS device using
the STRM Adaptive Log Exporter. For information on adding or managing a
device, see Chapter 4 Managing Devices.

(® “Nowwindons 5 X W0 =5

'New Windows IAS' Properties

= Basic Configuration ¥ Advanced Configuration

Thiz iz the section that describes the mandatory properties of the This iz the section that describes the optional/tuning
hew device, properties of the new device.

Marne: |New “indows A5 Throtte timeout: |5EID

Desciiption: I

Device Address: |

= Windows |AS Configuration

Thiz iz the section that describes the 'Wwindows 145 -specific
properties of the new device:

Root Log Directarny: | D

Prnperlias]

Configure the Root Log Directory parameter, which is the location of the IAS
server log files. By default, the IAS log files are located in the
%windir%\System32\LogFi les directory.
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CONFIGURING THE TREND MICRO
INTERSCAN VIRUSWALL DEVICE

InterScan VirusWall (ISVW) 6 for Windows provides an all-in-one gateway,
antivirus, anti-spam, and content management solution for your network.
VirusWall's real-time scanning services for SMTP VirusWall, POP3, VirusWall,
FTP VirusWall, and HTTP VirusWall monitors for security threats in e-mail, the
Internet, and in file transfers to and from the local area network (LAN).

This chapter provides information on configuring your Trend Micro InterScan
VirusWall device. For information on adding or managing a device, see Chapter 4
Managing Devices.

M =7

New Trend Micro InterScan VirusWall' Properties

~ Basic Configuration #! Advanced Configuration

Thiz iz the section that desciibes the mandatory properties of the new This iz the section that describes the
device, optional/tuning properties of the new device.

Name: |New Trend Micro InterS can Vst all Throttle timeout: |500

Drescription: |

Device Addiess: |

~ InterScan YirusWall Configuration
Thiz iz the ection that desciibes the InterScan Vinugw'all-specific
properties of the new device.

Root Log Directory: | E|

F‘lopelties]

Configure the Root Log Directory parameter, which is the location of the
InterScan VirusWall log files. By default, the VirusWall log files are located in the
<installation folder>\Log directory. The <installation folder> is the
folder in which you installed your InterScan VirusWall device.
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CONFIGURING THE MICROSOFT
EXCHANGE SERVER DEVICE

The Microsoft Exchange Server provides you with electronic mail, calendaring,
contacts and tasks, and support for the mobile and web-based access to
information, as well as supporting data storage. The Microsoft Exchange Server
device allows you to forward Outlook Web Access (OWA) or SMTP logs to the
STRM Adaptive Log Exporter.

This chapter provides information on forwarding OWA or SMTP logs from your
Microsoft Exchange Server using the STRM Adaptive Log Exporter including:
e Forwarding OWA Logs

e Forwarding SMTP Logs

Forwarding OWA
Logs

To forward OWA logs to the STRM Adaptive Log Exporter, select the Microsoft
Exchange Server OWA device. For information on adding or managing a device,
see Chapter 4 Managing Devices.

M =0

'New Microsoft Exchange Server OWA Logs' Properties

&1 Basic Configuration » Advanced Configuration
This is the section that desciibes the mandatory properties of the new device:

Mame; INEW ticrosoft Exchange Server 0w/, Logs

Description: |

Device Address: |

- Mi ft Exch Confi
Thig is the section that describes the Microsoft Exchange-specific properties
of the new device.

Raot Log Directon: I Ij

Pronert\es]

Configure the Root Log Directory parameter, which is the location of the
Microsoft Exchange Server OWA log files. By default, the Exchange log files are
located in the %windir%\System32\LogFiles\W3SVC1\ directory.
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Forwarding SMTP To forward SMTP logs to the STRM Adaptive Log Exporter, select the Microsoft
Logs Exchange Server SMTP device. For information on adding or managing a device,
see Chapter 4 Managing Devices.

m =g

'New Microsoft Exchange Server SMTP Logs' Properties

& Basic Configuration ¢ Advanced Configuration
This iz the section that describes the mandatory properties of the new device.

Marne: |New Microsoft Exchange Server SMTP Logs

Drescription, |

Device Address: |

- M, ft Exch Confi
This is the section that describes the Miciosoft Exchange-specific properties
of the new device

Foot Log Directony: | |:|

Pruparlies]

Configure the Root Log Directory parameter, which is the location of the
Microsoft Exchange Server SMTP log files. By default, the Exchange log files are
located in the %windir®%\System32\LogFiles\SMTPSVC1\ directory.
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CONFIGURING THE MICROSOFT SQL

SERVER DEV

ICE

Microsoft SQL Server is a comprehensive, integrated, end-to-end data solution
that provides a platform for enterprise data and Bl applications. This chapter
provides information on configuring your Microsoft SQL Server device using the
STRM Adaptive Log Exporter. For information on adding or managing a device,
see Chapter 4 Managing Devices.

m\

New Microsoft SQL Server' Properties

#1 Basic Configuration

This iz th_e section that describes the mandatory properties of the

hiew device.

» Advanced Configuration

Narne: |New Microsaft SOL Server

Description, I

Device Address |

« Microsoft 5L Configuration

This iz the section that describes the Miciosoft S0L-specific
properties of the new device,

Ruoot Log Directary: I

Log Filename: [ERROALOG

]

Proneltles]

Enter values the following parameters:

* Root Log Directory — Specify the location of the Microsoft SQL Server log
files. By default, the SQL log files are located in the C:\Program
Files\Microsoft SQL Server\MSSQL\LOG\ directory.

e Log Filename — Specify the name of the active log file. By default, the name is
ERRORLOG. If this field is empty, the filename defaults to ERRORLOG.

The error log is a standard text file that contains SQL Server information and

error messages. The error

log can provide meaningful information to assist you

in troubleshooting issues or alerting you to potential or existing problems. The

error log output includes th
of the message, and the d

e time and date the message was logged, the source
escription of the message. If an error occurs, the log

contains the error message number and description. Typically, SQL Server
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retains backups of the previous six logs and provides each backup with an
accrued number appended to the end of the name. For example, the most
recent log backup is saved with the extension .1 and the second most recent

with the extension .2.
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CONFIGURING THE MICROSOFT IIS
DEVICE

Microsoft Internet Information Services (IIS) includes a broad range of
administrative features for managing web sites. You can monitor attempts to
access your sites, virtual folders, or files and determine whether attempts were
made to read or write to your files. 1IS log file formats allow you to record events
independently for any site, virtual folder, or file. For more information regarding
your Microsoft IIS device, see your vendor documentation.

This chapter provides information on configuring your Microsoft IS server using
the STRM Adaptive Log Exporter. For information on adding or managing a
device, see Chapter 4 Managing Devices.

M\ =0

New Microsoft 118" Properties

i Basic Configuration » Advanced Configuration

This iz the section that describes the mandatory properties of the
e device

Mame: |New Microsoft [15

Dezcription: |

Device Address: |

~ Microsoft 15 Configuration

This is the section that describes the Microsoft 11S-specific
properties of the new device,

Root Log Directory: | D

PruperliEsJ

Configure the Root Log Directory parameter, which is the location of the
Microsoft IIS log files. By default, the IIS log files are located in the
%windir%\System32\LogFi les\ directory.

Note: You can choose a format and enable logging for individual web sites and

FTP sites. After you enable logging on a web or FTP site, all traffic to the site
(including virtual directories) is written to the corresponding file for each site.
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COLLECTING WINDOWS EVENT
LOGS

This appendix provides information about monitoring event logs from
Windows-based servers and hosts. Typically, you can monitor your event logs with
or without an agent. The STRM Adaptive Log Exporter is an independent
application that runs on a Windows host, commonly referred to as an agent. The
STRM Adaptive Log Exporter collects local and remote Windows logs supporting
each method of monitoring event logs.

If you choose to use an agent, you must physically install software on the host to
be monitored. The host collects and exports the log information to the desired
destination. An agent distributes log collection and processing across multiple
systems, which reduces the performance impact on each host. If a server or
network outage occurs, logging activity is only affected on the server or area of the
network affected by the outage. However, maintaining an agent-based deployment
may require additional maintenance. For example, if configuration changes are
required, you must replicate the configuration changes across all monitored hosts.

If you choose not to use an agent, the log information must be exported or
collected from the Windows system without software being installed on the
individual monitored hosts. However, you must communicate with remote
Windows systems using NETBIOS, which is a relatively slow method of
communication. Therefore, monitoring several Windows hosts remotely may cause
a significant performance impact for the host server. Communicating remotely also
requires that the appropriate domain credentials are supplied to the host server,
which may be considered a security risk.

This appendix includes:

e Collecting Logs Without an Agent
e Collecting Logs With an Agent

e Configuring STRM To Accept Logs
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Collecting Logs To collect logs without an agent, you must install the STRM Adaptive Log Exporter
Without an Agent in your network. The STRM Adaptive Log Exporter allows you to connect to remote
Windows systems to return logs to your STRM appliance.

I? Note: For more information on the STRM Adaptive Log Exporter, see the STRM
Adaptive Log Exporter Users Guide.

The Adaptive Log Exporter collects logs from individual hosts and forwards data to
your STRM appliance using a UDP syslog connection. Collecting logs without an
agent simplifies maintenance and does not require you to install software on
individual Windows hosts.

When collecting logs without an agent, the STRM Adaptive Log Exporter monitors
the network and if a network outage occurs, any missed events are automatically

collected and processed by STRM when network connectivity is restored. When
the network connection is lost, records are archived on individual hosts.

Figure A-1 shows an example of a network collecting logs without using an agent.

Agent-less Windows Log Collection

STRM Appliance

The Adaptive Log Exporter
communicates events from all
Windows machines back to

STRM server via Syslog

Windows Server Hosting
STRM Adaptive Log Agent

The Adaptive Log Exporter pulls
event log data back from
Remote Windows Machines via
NetBIOS

Monitored
Windows Servers

- /

Figure A-1 Collecting Logs Without an Agent
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Configuring the  To configure the STRM Adaptive Log Exporter to support a network without an
Adaptive Log agent:
Exporter

Step 1 Download and install the STRM Adaptive Log Exporter on the system you wish to
host the Adaptive Log Exporter.

For detailed information on the STRM Adaptive Log Exporter, see the STRM
Adaptive Log Exporter Users Guide.

Step 2 Download and install the Windows Event Log plug-in:

a From the Start menu, select Start > Programs >
QRadarAdaptiveLogExporter > Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appears.

Fla Edk - Winoaw Help

=]

Help Corfents

b From the menu, select Help > Software Updates > Add Extensions/Devices.

Search Results

Salect Faahires b nstall Fram the ssarch rest bst. LN

J 3

Salact tha feabures o nstall;

+ O ey Desslact il

Seleet Reaquired

Dof 2 selected,

[ Shows the batest versian of 3 Feature arly

™ Fiter featuras nouded in other fastures an the st

¢ Click the + sign to expand the menu tree.
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The available devices appear.

d Select the Windows Event Log plug-in.

e Click Next.

The Feature License window appears.

f Read the license associated with the selected device. To continue, you must
select the | accept the terms of the license agreement option.

g Click Next.

The Installation Window appears.

I? Note: You must install your devices to the default location. Therefore, do not
change the Install Location for your devices.

h Click Finish.

The Feature Verification window appears.

i Click Install All to install all chosen devices.

Step 3 In the STRM Adaptive Log Exporter, click the Devices tab.

Step 4 Using your right mouse button (right-click) the Windows Event Log and select Add

Device.

A new instance of the device is created and the Properties panel appears.

- “Remate Windows Server X

 Basic Configuration

Thiz is the section that describes the mandatory
properties of the new device,

Mame: ’m
Description: ,W
Device Address: W
+ Windows Event Log Confi on

This is the section that describes the Windows
Event Log-specific properties of the new device.

Application Log
Security Log
System Log

Properties

'Remote Windows Server' Properties

» Advanced Configuration

 Wind Event Log R te System Confi ion
This is the section that describes the {optional) remote machine
properties.

Remote Machine: | WwindowsHost2k3

Poll interval: | 5000

Step 5 In the Basic Configuration area, enter values for the parameters:

« Name — Specify the name you wish to assign this device.

« Description — Specify a description for this device.

« Device Address — Specify the IP address or the hostname of the Windows
system you wish to monitor.

Step 6 In the Windows Event Log Configuration area, enter values for the parameters:
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Application Log — Select the check box if you wish the device to monitor the
application log.

Security Log — Select the check box if you wish the device to monitor the
security log.

System Log — Select the check box if you wish the device to monitor the
system log.

Step 7 In the Windows Event Log Remote System Configuration, enter values for the
parameters:

Remote Machine— Select the check box for the device to retrieve the logs
from a remote machine. Enter the desired Universal Naming Convention (UNC)
name. The entered string can be up to 255 characters in length. For example,
\\tango123.

Poll Interval — Specify the remote poll interval enter a value, in milliseconds.
The default is 5000 milliseconds.

Collecting Logs
With an Agent

i

To collect logs with an agent, you must install the STRM Adaptive Log Exporter on
each monitored host in your network. The STRM Adaptive Log Exporter then
reports, using syslog, to your STRM system. The agent reads the individual
Windows event logs and passes information to STRM using syslog.

Note: For more information on the STRM Adaptive Log Exporter, see the STRM
Adaptive Log Exporter Users Guide.
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Figure A-2 shows an example of a network collecting logs using an agent.

Agent based Windows Log Collection

STRM Appliance

The Adaptive Log Exporter
communicates events from all
Windows systems to STRM
using syslog

Monitored Windows
servers running the
Adaptive Log
Exporter

\ %

Figure A-2 Collecting Logs With an Agent

Configuring the  To configure the STRM Adaptive Log Exporter to support a network with an agent:
Adaptive Log
Exporter

Step 1 Download and install the STRM Adaptive Log Exporter on the system you wish to
host the Adaptive Log Exporter.

For more information on the STRM Adaptive Log Exporter, see the STRM Adaptive
Log Exporter Users Guide.

Step 2 Download and install the Windows Event Log plug-in:

a From the Start menu, select Start > Programs >
QRadarAdaptiveLogExporter > Configure QRadar Adapter Log Exporter.

The Adaptive Log Exporter appeatrs.
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File Edk - Windaw Help

o

Help Corfents

b From the menu, select Help > Software Updates > Add Extensions/Devices.

Search Results
Selert Faabures b mstall from the smarch resyit list, e
=
Salact tha Faabures bo install;
0 Decalact Al
Selack Requined

Dof 2 selected,
[ Shows the batest versin of 3 feature arly
™ Fiter featuras nouded in other Festures on the ist

| Il | come

¢ Click the + sign to expand the menu tree.
The available devices appear.

d Select the Windows Event Log plug-in.

e Click Next.
The Feature License window appears.

f Read the license associated with the selected device. To continue, you must
select the | accept the terms of the license agreement option.

g Click Next.
The Installation Window appeatrs.

D Note: You must install your devices to the default location. Therefore, do not
change the Install Location for your devices.
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Step 3
Step 4

Step 5

Step 6

Step 7

Step 8

h Click Finish.
The Feature Verification window appears.
i Click Install All to install all chosen devices.
In the STRM Adaptive Log Exporter, click the Devices tab.

Using your right mouse button (right-click) the Windows Event Log and select Add
Device.

A new instance of the device is created and the Properties panel appears.

™ “Remote Windows Server X ol

'Remote Windows Server' Properties

 Basic Configuration ¥ Advanced Configuration

This is the section that describes the mandatory
properties of the new device.

Mame: Remote Windows Server
Description: HR Windows Server\
Device Address: | 10,100.100.118

- Wi Event Log Ci ion - Wi Event Log System G ion
Thig is the section that describes the Windows This is the section that describes the (optional) remote machine
Event Log-specific properties of the new device. properties.

Application Log Remote Machine: | \iwindowsHost2k3

ey Lo Poll interval: | 5000

System Log

Properties

In the Basic Configuration area, enter values for the parameters:
« Name — Specify the name you wish to assign this device.
« Description — Specify a description for this device.

« Device Address — Specify the IP address or the hostname of the Windows
system you wish to monitor.

In the Windows Event Log Configuration area, enter values for the parameters:

« Application Log — Select the check box if you wish the device to monitor the
application log.

« Security Log — Select the check box if you wish the device to monitor the
security log.

+ System Log — Select the check box if you wish the device to monitor the
system log.

In the Windows Event Log Remote System Configuration, clear the Remote
Machine check box so the device does not retrieve the logs from a remote system.

Repeat Step 4 to Step 7 for each remote host you wish to monitor.
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Configuring STRM
To Accept Logs

Both methods of collecting logs (with or without an agent) results in information
being transmitted to STRM using syslog. By default, STRM collects information
forwarded using syslog through the device discovery function. STRM automatically
recognizes and normalizes Windows event logs.

Once the system begins normalizing event data, STRM can analyze, report, and
store the information. To verify that your Windows logs are being processed by
STRM, use the Filter/Search function in the Event Viewer to filter on Windows
Authorization devices. For more information on filtering using the Event Viewer,
see the STRM Users Guide. The below window shows an example of data that
results from a search.

Virming aveers feen 2007 A0AF 154707 02 HOTH213 160000 (Wigw Real Tars B
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