J-Security Center

Title: Php-Stats 'admin.php' Multiple Cross-Site Scripting Vulnerabilities

Severity: MODERATE

Description:

Php-Stats a PHP-based tool for creating statistical information about a file tree.

Php-Stats is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input to the following parameters of the 'admin.php' script:

'sel_mese'
'sel_anno'

Attackers may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow attackers to steal cookie-based authentication credentials and to launch other attacks.

Php-Stats 0.1.9.1 is vulnerable; other versions may also be affected.

Affected Products:

  • Php-Stats Php-Stats 0.1.9.1

References:

Juniper Networks provides this content via a wide variety of sources and production methods. If notified of errors or omissions in the content of this page, Juniper Networks, at its discretion, will modify or remove the page or leave the content as is, depending on various factors including but not limited to the reputation and authority of the party providing the notification. Please use the contact information displayed elsewhere on this page to report any errors or omissions regarding the content on this page.