J-Security Center

Title: Yahoo! Toolbar Helper Class ActiveX Control Remote Buffer Overflow Denial of Service Vulnerability

Severity: MODERATE

Description:

Yahoo! Toolbar ActiveX Control is prone to a buffer-overflow denial-of-service vulnerability.

The ActiveX control with a CLSID of {02478D38-C3F9-4EFB-9B51-7695ECA05670} that uses the 'yt.dll' library is prone to a denial-of-service issue because the application fails to properly bounds-check user-supplied data. Specifically, a buffer overflow occurs in the 'c' function of the 'yt.ythelper.2' class. An attacker could trigger the issue by supplying an overly long argument to the function.

Attackers can exploit this issue to cause denial-of-service conditions in Internet Explorer or other applications that use the vulnerable ActiveX control.

Reports indicate that code execution is not possible, but this has not been confirmed.

Yahoo! Toolbar 1.4.1 is vulnerable to this issue; other versions may also be affected.

Affected Products:

  • Yahoo! Toolbar 1.4.1

References:

Juniper Networks provides this content via a wide variety of sources and production methods. If notified of errors or omissions in the content of this page, Juniper Networks, at its discretion, will modify or remove the page or leave the content as is, depending on various factors including but not limited to the reputation and authority of the party providing the notification. Please use the contact information displayed elsewhere on this page to report any errors or omissions regarding the content on this page.